Workspace Previews are Empty

Hello again!

I know that’s the second topic that I opened today but I felt I have to separate these problems because I specified that before at Dash To Dock Fails but no one ever looked it. Maybe I’m the only one person who uses CTRL + ALT + ARROW (LEFT / RIGHT) to change workspaces but I have to tell it’s really useful thing with previews because it displays active panels in a small window.

Here how it’s looking like, completely nothing to see.

You’re definitely not the only one that uses ctrl+alt+left/right. There’s an addon called Workspace Matrix that fixes this. Gnome 40 support is still WIP, but you can get the source from the developer’s Github if you’re interested in trying it anyways.

Thanks for suggestion. I’ve just tried it and unfortunately it doesn’t work well.

The settings of extension had an error:

Gtk.BuilderError: /home/user/.local/share/gnome-shell/extensions/ Invalid property: GtkBox.margin_left

Stack trace:

As mentioned, gnome 40 support is a work in progress, so you’ll need to use the code from the pull request for it to work (How to)

Number of columns and rows (workspaces) are static, and “Time to show the popup” is set to a very low number, so you’ll probably want to change this. But it definitely works for me.

Oh, thanks. I missed the mention, I’ll try it. Hope soon native transparent workspace previews will be added to Gnome :smile: