Since latest update (Gnome 40) the "dash to dock" shows no more window previews

After running the latest Manjaro update (on July 13) the dash to dock extension for Gnome stopped working.
I reinstalled the extension, which helped but there are still some issues.

I couldn’t open the settings (I can now after running this fix Dash to dock fails and default desktop view changed after the update - #19 by kuznero)

But I the window previews (when multiple windows of an application are open) are still not working.

I tried:

  • disabling/enabling the extension
  • changed the setting to the other options like cycling (which all seem to work)
  • rebooting after changing settings

Take look in the last Stable-Update-Thread:

Try to delete “schemas” folder at /usr/share/gnome-shell/extensions/

It worked for me

I did that, but it only fixed the error when opening the settings

Have you looked at Layout?

Please test gnome-shell-extension-dash-to-dock 69+14+g302c693-4, I think I may have found the issue.

EDIT: I’m referring to the settings dialog.

I disabled the extension, removed the old one, rebooted, installed the one you mentioned (with Add/Remove software), and rebooted again and enabled Dash-to-Dock via “Extensions”.

The windows preview is still not working on the setting “Show windows preview”, however there are previews when I set it to “Focus or show previews”.

I meant I think I may have fixed the issue with the settings dialog being broken. Is that working?

I never said I fixed the upstream issues. :wink:

Heres what I did:
I removed the schemas directory, and then followed these steps:

then I changed the theme in tweaks to “default” and voila, I works perfectly again.

1 Like

What I suggested on the Spanish thread was, as per below:

  1. Trying to set up the missing property with the gsettings command
gsettings set preview-size-scale 0.0
  1. Check out the schema XML file for the missing properties. If missing, then add them manually:

File path:


<key type="d" name="preview-size-scale">
      <summary>Preview size scale</summary>
      <description>Set the allowed maximum dash preview size scale. Allowed range: 0,00..1,00.</description>

And finally, if the above didn’t help to fix the issue, forcing a reinstall of the extension via pamac.

I’m wondering what step actually fixed the issue for @martinator though. I bet it is the extension reinstall via pamac? :sweat_smile:

None of that should be necessary. The only reason why the settings dialog produced that error is because the gschemas.compiled wasn’t being compiled to match the version. I can’t reproduce it, so I’m shooting blind here. I did find an inconsistency with the packaging that should have fixed it.

1 Like

The settings dialog is working with that version :slight_smile:
(but it also worked after I applied the fix with the schemas directory that I mentioned in the initial post :wink: )

But thank you for your work and effort on this :slight_smile:

Is there an error log or verbose mode to figure out why the previews are not showing?
Happy to assist if finding the problem or debugging, if there is anything I can do.

there is problem with my dash to doc after I upgraded. here is the error that it produces:

GLib.FileError: Failed to open file “/usr/share/gnome-shell/extensions/”: open() failed: No such file or directory

Stack trace:

Restart GMOME Shell or logout / login.

1 Like

thanks, restarting Gnome helped

Thanks a lot!

Try to delete “schemas” folder at /usr/share/gnome-shell/extensions/

gsettings set preview-size-scale 0.0
and Logoff/Logon helped to solve the issue.

However to get back ‘show previews’ on windows, I had to change ‘Click action’ under ‘Behavior’ tab to ‘Focus, minimize or show previews’ in Dash to Dock settings. In previous Gnome it worked with ‘Minimize or show previews’ option.