Cannot run Manjaro Live from USB

I want to install Manjaro KDE on an internal drive in my pc.

I tried to make a bootable USB, and boot the device.

From bios i select the UEFI boot of my USB device and Manjaro configuration screen appears.

When i press the button to start Manjaro from USB using Proprietary Driver or Open Source Driver (It doesn’t matter), i receive this error:

mount: /run/miso/sfs/livefs: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error
ERROR: Failed to mount ‘/dev/loop0’’
Falling back to interactive prompt
You can try to fix the problem manually, log out when you are finished
sh: can’t access tty: job control turned off

Then i tried more times with other solutions: i disabled “secure mode” in the bios settings, i changed 3 usb devices (3.0 and 2.0 both), i added to boot parameters “acpi=noirq”, i flashed more than 3 versions of Manjaro, and i changed the application that make usb bootable (i tried with rufus and unetbootin), tried gnome and xfe versions, nothing worked.

I also tried to resolve using solved online forums, but however it doesn’t work.

Thanks if you could help me.

Important: It can’t run only if i turn on pc with SSD connected.

When i tried to boot Manjaro from USB without SSD it started perfectly.

Hello @fredmel2 :wink:

That basically means that your written ISO is corrupt. Please check it against the checksum.

For the note:

I checked it, sha1 does match every time. I tried different versions (gnome, xfce) and two different usb sticks

Did you check it against the ISO on the flash drive or against the ISO on your Download folder?

In download folder.

And there you see the difference. There might be an issue when writing it to the flash drive. Try ventoy :wink:

Thanks for recommendation, just tried ventroy, installed in one of my usbs, move iso file there, checked sha1 again - it matched. But same error :frowning:

low probability ideas

Just in case, what SSD model and UEFI do you have?

Try to check firmware updates for both

… but I do not know will the data preserves after flashing SSD.

If ssd is from samsung it could be found here:

Does the SSD is empty? Has no files in partitions or have no partition table? Which partition table it has (if any): MBR / GPT?

May be you have some sort of “fast boot” option in UEFI also? Try to turn it off also.

Are there other SSD options in UEFI? May be secure encryption or other stuff prevents LiveCD to recognize the SSD hardware?

Is it possible to reset the UEFI to defaults or you have too much settings to reconfigure after this?

Samsung 850 PRO, not sure about UEFI im noob when it comes to it

i format it in win10

i will check fast boot option and try reset UEFI next day

low possibility thoughts

I mean motherboard firmware (early it named BIOS, nowadays many of them are UEFI). Check you manuafacturer website to see the version and compare with the version you see when you enter BIOS/UEFI.

In case of it has no data for you, may be before to reset UEFI, you have ability to remove partition table on ssd?

On Windows it will be close to this (I am not sure - I write it from my memory):

  1. Open cmd.
  2. diskpart
  3. list disk
    note that number of disk which is target SSD is.
  4. select disk N
    where N is that number
  5. list disk
    again to check the * char presence: do you see that * is located on the line of target ssd to remove partition table from and is absent on all other lines?
  6. Double check: pay attention
    do you see that * is located on the line of target ssd to remove partition table from and is absent on all other lines? If you select wrong disk, by the step 7 you will lose you data.
  7. clean
    Partitions table should be removed, now it has no partition table and has the state like you “just bought it”: perhaps payload data is still available to recover by professionals, but the ssd drive now should not contain any user-available (easy-available) data.
  8. exit or quit.

And try to load Manjaro LiveCD again with that SSD inserted.
Also temporarily switch off all other HDDs, SSDs.

1 Like

Well, I myself trust more this message:

(if it is every time the same)

Could you tell which image it is? (the exact filename)

Maybe try to check it against the gpg signature, which is more accurate.

Otherwise I would assume the ISO is somewhat faulty. :man_shrugging:

i also tried manjaro-gnome-21.1.6-211017-linux513.iso and manjaro-xfce-21.1.6-211017-linux513.iso

I have exactly this version of KDE on my ventoy stick and it works without any problems… Even with all SSDs/HDDs connected. So can’t be a problem of the ISO itself.

Well, it is just a thought and it sounds silly, but there is a search command for images. Could it be possible that there is a livefs image on your SSD, when booting from a flash disk?

If so, then this behavior would make sense… :thinking:

OMG! That was it! Thanks you so much for the help <3

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.