Boot stuck after update

Using Manjaro KDE on kernel 5.4.62-1-MANJARO x64

So today I when I got to work I installed the new updates. It told me there where issues with installing mhwd-nvidia450xx (I was on 430xx). So I manually upgraded packages related to my videodriver to 450xx and then upgraded the OS. It seemed to have went flawless without issues.

After that, I rebooted. It’ll get stuck on
[OK] Finished TLP system startup/shutdown

I tried an older kernel that I have installed (that also had the GPU driver upgrade) and the fallback initramfs, but it does the same.

Reading online I read mainly found issues with Nvidia, which was being a bit a bitch installing on my pc too. Got some great help from the forums to fix it back then. I figured if it’s the GPU driver I might just be able to rollbsck to the 430xx version. So I tried to get into my live-boot USB I always carry with me in order to chroot into my system but I can’t get in either. It keeps giving errors on my CPU having a soft lock while running a start job for different things.

I’m at work and I kinda need this pc to continue, I’m on my phone now to write this by lack of something else. I don’t have another pc at hand right now either, but I have tonight. However, I need to continue asap. I’m kinda lost now.

I’m normally using Manjaro exactly because it’s stable and I use it for work. It’s been going well for years until it broke today.

While in the Grub Menu of Live media, press e to edit it, and append after quiet this line
systemd.mask=tlp.service
Then press F10 to save and continue booting.
Is that helping?
If that is a desktop pc, i would recommend to remove tlp

1 Like

It’s a laptop, a Asus ROG one. I had a lot of issues with the GPU drivers back when I first got it. Got a lot of help on the old forums. Ended up having to chroot into it to install Nvidia drivers and writing some xserver stuff manually. But after I never had issues updating. I’m not sure if it’s related or important to this issue.

The first errors in the liveboot are gone, but I still get:
BUG: soft lockup - CPU#0 stuck for 22s [(mManager):703]
BUG: soft lockup - CPU#3 stuck for 22s! [kworker/3:2:353]
Repeating continuously.

It seems that some Asus ROG models require the DKMS kernel module support
https://wiki.archlinux.org/index.php/ASUS_G55VW
Maybe is the same for your model?

I wouldn’t know. I also don’t know how to try since I can’t enter my laptop with neither live boot or the main OS. I do know both OS and live boot had been working great for almost 2 years now, so I would expect this week’s update doesn’t break my hardware needing something unless there was a significant change somewhere?

I just checked. I got the laptop in 2018. Back then the issues where with the Manjaro installer not being able to properly install the video drivers. Bumblebee didn’t work. I ended up chrooting into it and installing Optimus drivers manually after which I had to write some xserver stuff. I tried to find the old treat on the classic forum but can’t find it.

So far almost everything I find on both the live boot and the main OS issue seem to be related to Optimus/Nvidia. Considering that one had been a bit unusual during updates, where an issue when I first installed the OS and more people seem to mention issues with the 450xx update lately. I’m suspecting it’s somewhere around there. I’m fine going back to 430xx if need be, bit I need to get into my OS first one way or another.

However, right now I’m not even sure how to get into it to check or alter stuff since I can’t get in with my regular booting nor the live boot. Which I find weird as it was all fine before the update.

I would suggest to boot into bash from grub like this:

  • Append the init=/bin/bash to your boot loader’s boot entry.
  • Your root file system is mounted as read-only now, so remount it as read/write: mount -n -o remount,rw /

Then you have full access as root. Then you are able to change back to 430xx.

mhwd --remove pci video-nvidia-450xx
mhwd --install pci video-nvidia-430xx

2 Likes

You helped me a lot further. The boot into bash thing I didn’t know yet. Sometimes I’m not that knowledgeable yet. So thanks!

However, I’m a morron. I’m really sorry but please bear with me.

I installed the 450xx packages in octopi but I never probably updated the driver. When I would try to remove 450xx it says there is no config. So I tried to install it, but it fails on each step of “synchronizing package databases…” after which it tells me “pacman failed!”

In case it matters, I’m connected to the internet by cable.

Then I figured, if I made this issue by installing the 450xx packages maybe I can fix it by simply removing those and installing the 430xx packages. Sadly, this’ll break the dependency nvidia-utils>=450.51.06 required by cuda. One I’m not sure how to fix at in this situation.

I have photos of the exact output but I’m not allowed to upload photos on the forum it seems.

The packages I touched are:
lib32-nvidia-450xx-utils
lib32-opencl-nvidia-450xx
nvidia-450xx-utils
linux-414-nvidia-450xx
linux-419-nvidia-450xx
linux-54-nvidia-450xx
And their 430xx counterparts

1 Like

Phew…

first check what you’ve installed with mhwd:

mhwd -li

(you can upload images somewhere else and put the links as code here with “`” at the beginning and the end)

then make internet working, since it must be loaded manually. i guess you are using the NetworkManager:

systemctl start NetworkManager

then test it:

ping -c 2 manjaro.org

If it works we can go further.

1 Like

You guys are saving angels and I love you for putting up with and helping people like me.

mhwd -li returns
Name: video-nvidia-430xx
Version: 2019.10.25
Freedriver: false
Type: PCI

pacman -Qs Nvidia shows I only got 450xx packages installed now (and mhwd ones of multiple ones including but not limited to the 450xx). Hence, I’m a morron. I guess the issue is me installing those packages but not upgrading the driver.

systemctl start NetworkManager returns:
System has not been booted with systems as init system (PID 1). Can’t operate.
Failed to connect to bus: Host is down

is there video-linux installed on the list of mhwd?

Checking with pacman -Qs video-linux and pacman -Qs video I can’t find anything.

The mhwd -li only listed the nvidia-430xx I mentioned before, nothing else.

no, video-linux is a config of mhwd. It is “meta-package” for the free-drivers. It is not in pacman listed.

So only nivida is there. That is bad… i hoped you could use the free driver after removing nvidia.

What says:

pacman -Ss xf86 | grep -i install

xf86-video-nouveau maybe there?

It returns:

extra/libxxf86dga 1.1.5-1.1 [installed]
extra/libxxf86vm 1.1.4-4 [installed]
extra/xf86-input-elographics 1.4.2-2 [installed]
extra/xf86-input-evdev 2.10.6-2 (xorg-drivers) [installed]
extra/xf86-input-libinput 0.30.0-1 (xorg-drivers) [installed]
extra/xf86-input-void 1.4.1-5 (xorg-drivers) [installed]
multilib/lib33-libxxf86vm 1.1.4-2 [installed]

Not sure if useful, but since I’m not at work anymore I have a second working Windows10 PC with internet next to me and I do have USB sticks and a external HDD if need be.

Great… we need a manjaro install medium. boot from it and then chroot into you local drive:

manjaro-chroot -a

then it can be fixed.

Like my old liveboot usb? I originally used it to install Manjaro and kept it just in case, but as mentioned before I can’t get in it for some reason.

When using nonfree drivers and the setting I was told in the first comment the CPU softlock is fixed but it’ll hangs on Reached Target Graphical Interface.

I get into grub. Can I use the same trick to boot into bash from the live boot’s grub then use this command?

And what about free drivers? Doesn’t it work also?

exactly the liveboot usb :slight_smile:

The free drivers are the one that gives me that mention of the CPU soft lockup bug. Googling I found using nonfree could help, and the soft lockup bug mention went away indeed, but it hangs on that sentence after which my fan starts blowing very loudly.

I remember vaguely I had to use the command bogdancovaciu mentioned at times of installation. But I’m unsure about other things I did to get in. I used it to install Manjaro two years ago so there must be a way, if only I figured out how I did it back then.

I always kept that liveboot usb with my laptop because I figured I know too little to not screw up sooner or later :sweat_smile:. I had only used Linux for 1 or 2 years and just one day installed Manjaro in a “now I have to learn” mindset overwriting Windows. Untill yesterday it went great, I learned a lot but still know far from everything. Each time I’ve got a issue I learn more :upside_down_face:. But that’s also why I might not know some basic things if I hadn’t need for them before despite using it for a few years now :sweat_smile:.

I have found your thread :smiley:

ok well… you were able to change TTY ?

1 Like

Maybe I’m saying something that’s obviously not possible or a dumb idea.

But is it maybe possible to use my Windows10 desktop to download packages (or something else), put them on a USB stick, boot into grub from my pc and then mount that usb and install the packages from local files?

I have an old Linux installation on there but I had other completely unrelated issues causing instability I didn’t had the time to look into yet. I use it for gaming so I rarely boot it into Linux anyways. But if need be I can give it a try.

Oh great!

Let me check. You mean to ask now if I can change TTY on the already installed broken OS?