Boot from USB stops after Finishing TLP system startup/shutdown

Hello everyone,

So my brother bought a new PC and we build it together yesterday. We tried to install an OS, but failed with Windows and Manjaro Linux.

The Windows try was not very verbose. The main board logo showed up for a few seconds, followed by a blue screen without any information. After a minute or so the PC shut down.

With Linux everything seamed fine. The typical terminal look, printing what the computer is doing and everything is succeeding (except Initializing Pacman keyring.). The last two entries are

[ Ok ] Starting TLP system startup/shutdown...
[ Ok ] Finished TLP system startup/shutdown.

After that nothing happens.

The current setup is:

  • AMD Ryzen 5 5600G 6x 3.90GHz So.AM4 TRAY
  • ASRock Phantom Gaming 4 AMD B550 So.AM4
  • 16GB G.Skill Aegis DDR4-3200 DIMM CL16 Dual Kit
  • 1TB WD Blue SN550 NVMe M.2 PCIe 3.0 x4 3D-NAND TLC

(Of course a graphic card is part of the setup too, but since it could be a further trouble maker we disassembled it.)

The Ram is installed in A2 and B2 as the main board manual suggests. It shows up in the BIOS.
The M.2 SSD and the processor show up correct in the BIOS too.
The BIOS version is currently at 2.10, after the update. Sadly I did not remember with witch version the main board was shipped. After we assembled all parts the BIOS already showed up so it must be at least version 1.80? Or does the BIOS shows up even when the processor is not jet compatible? I ask this question because on the side of the different versions (Link) it notes

To support Ryzen 5000 G-series processors, it requires to update the BIOS with Matisse, Renoir or Vermeer CPU

but we did the update with the above named CPU.

Does anyone know a fix for this?
Many thanks!


Se here

@bogdancovaciu Thank you.

Sadly the TLP service is not the trouble maker. After adding the line, everything is the same except the last two lines. The TLP service does not start. It seams the boot operation freezes at the next step, after the TLP service.

Since I did not now if the CPU was the problem I disassembled my own computer and put an AMD Ryzen 5 3600XT in the system. Sadly the same problems occurred. I flashed the 2.10 BIOS again with this CPU because it is a Matisse 2 type. Nothing changed.

Now I’m sure that the CPU is not the Problem. Apparently the main board in Question is the same as in my system but with an more up to date BIOS version. On my system I had no problems with installing both Windows and Linux. I’m currently typing on it.

So the problem must be in the main board itself? Or could it be that the RAM, or SSD is damaged? But if the problem lays in the SSD then at least I should be able to boot from the stick. And if the RAM is damaged then I would not be able to load even in to the BIOS. Am I correct?

So we finally found a solution. We just flashed a new USB-stick with a new OS-version and suddenly it worked. Strange is that the old USB-stick worked on my PC and laptop just fine and they were flashed not long ago.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.