Boot stuck after update

Maybe, i am not 100% sure. But when the TLP error occurs, change the tty with

CTRL + ALT + F1

That is because we don’t want pictures of text, so what you’re doing is the right thing. :+1:

Please read this:

And in the future, when providing code/output, please copy-paste it in-between 3 backticks at the beginning and end of the code/text ``` so that the output looks like this:

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

instead of like this:

Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

(as that makes our life much easier so you get helped more quickly and efficiently)

:innocent:

1 Like

Ctrl+alt+F1 seems the broken version. But ctrl+alt+F2 does indeed bring me to a TTY2

1 Like

Thank you!

As far as pictures go. It’s mainly because I’m on a phone typing stuff while sitting in front of my laptop, hence I figured pictures might have been more easy and less prone to typos. If that’s the preference I’ll keep typing it.

Thanks. I wasn’t sure how to easily make those code blocks on my phone. 3 backticks it is! I’ll make sure next posts will have it!

2 Likes

Do you have a internet connection now?

ping -c 2 manjaro.org
1 Like
PING manjaro.org (176.9.38.148) 56(84) bytes of data 
64 bytes from mail.manjaro.org (176.9.38.148):icmp_seq=1 TTL=52 time=29.2ms
64 bytes from mail.manjaro.org (176.9.38.148):icmp_seq=2 TTL=52 time=36.1ms

--- manjaro.org ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1001ms
rtt min/avg/mdev = 29.237/33.648/36.060/3.411 ms

I think that means I do.

1 Like

Now you can fix the problem.

remove all packages related to nvidia.

lib32-nvidia-450xx-utils
lib32-opencl-nvidia-450xx
nvidia-450xx-utils
linux-414-nvidia-450xx
linux-419-nvidia-450xx
linux-54-nvidia-450xx

let the 430xx stay

Then remove and reinstall the driver with mhwd:

sudo mhwd -r pci video-nvidia-430xx
sudo mhwd -i pci video-nvidia-430xx
1 Like

I can’t remove them because the dependency with cuda breaks.

checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing nvidia-450xx-utils breaks dependency 'nvidia-utils>=450.51.06' required by cuda

The 430xx aren’t installed at this moment, since they’ld conflict with their 450xx counterparts.

Assuming 450xx will work when installed properly the newer driver is fine too. Would it perhaps work if I use

mhwd --install pci video-nvidia-450xx

And if that goes without error should I remove the 430xx one? Since I installed the packages of 450xx trough octopi but nothing else?

You can do it like this, but i would rather suggest to remove it first.

remove

sudo mhwd -r pci video-nvidia-450xx

install

sudo mhwd -i pci video-nvidia-450xx

Right now trying to remove it just returns

Error: config 'video-nvidia-450xx' is not installed!

I assume because the idiot that I am I only installed the packages trough octopi. Hence, I figured I might be able to install it properly using the install command. At this point I don’t dare to try until I’m told I should. Don’t want to ■■■■ up more :sweat_smile:.

So, is in this case only the install ok?

You have installed 450xx from AUR using octopi. Therefore, to be safe, remove 450xx packages with pacman.

pacman -R linux-414-nvidia-450xx linux-419-nvidia-450xx linux-54-nvidia-450xx  nvidia-450xx-utils  lib32-opencl-nvidia-450xx lib32-nvidia-450xx-utils

then use mhwd. it uses the official packages.

note: i misunderstood. octopi is a pacman gui :smiley:

I did not use AUR for this as far as I’m aware? Normally I can only find AUR packages not installed by searching them with yay, not in the list of octopi. They also had a square before them after installation instead of the alien head my AUR packages have. The packages of all available drivers from official repositories are visible in octopi, both older and newer ones.

I also can’t remove the nvidia-450xx-utils due to the cuda dependency. Or is there a way I can enforce that that I should use?

Due to the note, is there a way to enforce deinstalling despite the cuda dependency or should I just reinstall since I used the official repository?

just run it :see_no_evil: It will not hurt.

1 Like

I’m a bit careful now. Nothing worse than someone who asks support then makes it worse before support can fix it by doing stuff without consulting support :sweat_smile:.

It says it’s successfully installed.

Should I remove the 430xx config or reboot and hope it’s booting properly now?

what says:

mhwd -li
------------------------------------------------------------
NAME                   VERSION         FREEDRIVER    TYPE
------------------------------------------------------------
video-nvidia-450xx   2019.10.25        false          PCI
video-nvidia-430xx   2019.10.25        false          PCI

yes please, remove it :smiley:

and run sudo reboot -f

1 Like

It still doesn’t go past

[OK] Finished TLP system startup/shutdown.

But now the _ keeps blinking and my fan doesn’t start blowing full force, unlike before.

Maybe disable tlp… since it is not a laptop?

sudo systemctl disable tlp

(again in another tty and then reboot)

But i guess there is an issue with the 450 drivers. Remove 450 and install 440 like above.