Update broke nvidia, can't boot

Maybe I’m late to the party as my laptop is only used for work and I had vacation until yesterday. So yesterday I ran the update for the first in 2 weeks, and now my laptop can’t boot anymore. It get’s stuck at Finished TLP system startup/shutdown. I can still get to TTY2. I checked the update and I’m near certain it’s the change in Nvidia drivers. That has always been an issue for me.

I really need this laptop for work as well as that I have an important test comming up for school in which I really need to use it, so any help is very appriciated.

Around two years ago when I got my laptop, it somehow didn’t want to work with the bumblebee drivers. Instead I had to install the nvidia propriety drivers and manually write stuff in xorg. It always ran on nvidia drivers so I could never use the Intel integrated graphics, but it did work and I could use my videocard (using the videocard is important for me).

Now with the new update my laptop won’t boot. I noticed it installed video-hybrid-intel-nvidia-prime, I removed it and installed the video-nvidia one, which installed fine but my computer still won’t boot.
Then I tried installing the nouveau drivers using sudo mhwd -a pci free 0300. I only see Intel related things installing, and the system still won’t boot. When trying to use sudo mhwd -a pci nonfree 0300 it gives an error because video-hybrid-intel-nvidia-prime conflicts with video-nvidia.

My laptop has a GTX1050. My laptop has been very picky on drivers. Last one that worked was 430xx, newer ones broke my system also. I also tried reinstalling the old driver using sudo mhwd -i pci video-nividia-430xxx but it just tells me video-nvidia-430xxx doesn’t exist.

Right now mhwd -li gives

NAME                             VERSION                 FREEDRIVER          TYPE
video-nvidia                    2020.11.30                  false             PCI
video-modesetting               2020.01.13                  true              PCI
video-linux                     2018.05.04                  true              PCI
Warning: No installes USB configs!

I ran inxi --admin --verbosity=7 --filter --no-host --width but half of it goes off-screen. I’m on desktop writing this but here’s a foto (open in new tab to make it readable):

Some other info:
yay -Q | grep nvidia gives

lib32-nvidia-utils 455.45.01-3
linux414-nvidia 455.45.01-4
linux419-nvidia 455.45.01-4
linux54-nvidia 455.45.011-6
mhwd-nvidia 455.45.01-3
mhwd-nvidia-340xx 340.108-1
mhwd-nvidia-390xx 390.138-1
nvidia-utils 455.45.01-2

nvidia-smi tells me I indeed have driver version 455.45.01 now. I think maybe my laptop still won’t work with anything higher than 430, so maybe rolling it back would be a first option? However, I don’t know how.

The previous issue where I couldn’t get a newer driver than 430xx is here: Boot stuck after update
The issue where I had to install Nvidia only drivers and write stuff for Xorg manually was on the old forums and can be found here: Nvidia proprietary drivers not installable - Drivers - Manjaro Linux Forum

Should have payed better attention to the pinned post. It tells me how to roll it back. Rolling it back like that to version 430xx fixed it indeed.

For the record (for full disclosure if people find it browsing the forums later). I removed video-nvidia en video-linux using mhwd. Then I ran:

git clone https://gitlab.manjaro.org/packages/extra/nvidia-430xx-utils.git
git clone https://gitlab.manjaro.org/packages/multilib/lib32-nvidia-430xx-utils.git
git clone https://gitlab.manjaro.org/packages/extra/linux54-extramodules/nvidia-430xx.git

followed by:

cd nvidia-430xx-utils && makepkg -si
cd ../lib32-nvidia-430xx-utils && makepkg -si
cd ../nvidia-430xx && makepkg -sif

mhwd -li now returns only video-modesetting, but it works.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.