After update, my external monitor doesn't get signal

I see it on system settings > display. But when making it active, it blinks looking for signal and gets nothing.

This is recent after last Nov 2022 undate. Any idea why this is?

Hi @ofc3,

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!


:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

```

pasted text

```

This will just cause it to be rendered like this:

Portaest sed
elementum
cursus nisl nisi
hendrerit ac quis
sit
adipiscing
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.


:bangbang: Also, if your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

Please edit your post accordingly.

Is this with that downgraded package or fully updated?

Indeed I downgraded libx package to keep Firefox from crashing - which worked.
Yeah, but now the monitor is silent :confused:

Partial updates are not supported.

Can you reproduce the problem when fully updated?

So we have a catch 22 situation here.
Updating everything will have the third monitor working, but Firefox will crash every chance it gets.
To prevent it from crashing I have to downgrade libx, but then the screen is now silent.
I use Firefox to play Youtube on that screen as it is the largest.

Both scenarios invalidate the usage of that screen, and if there is no better workaround than to downgrade libx, I guess I have to wait for another stable release to hopefully get out of this situation.

Yes, problem existed before I noticed the other problem with firefox.

Same here, this is a very rare case in which an update borks two things I rely on (extrenal monitor, and firefox). Writing this on a windows tablet, the only other device I have. I can’t remember the last time a linux update left a system useless since… > 7 years, since I moved to manjaro. It changed my perception on linux. This incident reminds me that these ‘update kills machine’ set ups are still very much possible even in apps that are as central to the system as it can be.

2 Likes

Same issue here but I don’t use firefix. I described my problem here. Mine happened after an upgrade which also upgraded the package linux60-nvidia from 520.56.06-4 to 520.56.06-9

Are all of the affected people/machines using nvidia?
If so, this might be of interest:

Yes, using nvidia on 2 machines here. And surprise, the old machine that doesn’t have the latest update (but the one before, which uses extra/libx11 1.8.2-1) ALSO has the problem (no external monitor at all). I had to go 2hr to get this machine with the hopes of having a working computer. No luck.

Yes, Nvidia is involved in my case too.
The third monitor is connected via hdmi - this is the problematic one.
However, the other two are attached via DVI ← might be a suggestion worth trying for @ofc3 ??
If you have other input/outputs + cables that is.