Displays over display port not working after update to latest nvidia-driver

I have to reopen my issue from X crashes when enabling third monitor.

It seems that the suggested solution was only temporary and after a restart everything went back to how it was.

Ayn ideas?

My relevant system specs:

  • Linux version 6.0.6-1-MANJARO (builduser@fv-az121-178) (gcc (GCC) 12.2.0, GNU ld (GNU Binutils) 2.39.0)
  • Evga Nvidia 1080 Ti
  • linux60-nvidia 520.56.06-9

Please share
cat /etc/X11/mhwd.d/nvidia.conf

I managed to set both displays to 1920x1080 @ 165 Hz now using sudo nvidia-settings by starting with the lowest resolution 640x480 @ 60 Hz and slowly starting to increase the resolution while hitting “Apply” each time. I saved the config file to /etc/X11/xorg.conf

If I set the resolution directly to 1920x1080 @ 60 Hz it would crash and reset my settings.

They both work now but I’m not sure it will hold. There’s something very strange going on here.

Why? Manjaro uses MHWD and hence the file is

Reason why i asked for it. Whatever you change in Nvidia X Settings should be added there. Please remove the xorg.conf and append the different lines in nvidia.conf
If unsure, share it with your changes.

My bad. It was the default suggestion in nvidia-settings.

Here is the version after I managed to set both displays (left and right of my main monitor) to 1920x1080 @ 165 Hz.

You also managed to make a Frankenstein’s monster of the metamodes:sweat_smile:

Will not try to decipher it, so please try to make the layout without mixing nvidia-auto-select with fixed resolution. Is either one or the other; also do not add 8 different options for each port.

From Nvidia X Settings, get the Preview of it, do not save it yet to nvidia.config, do not reboot, and share that Preview changes.

Edit: - In principle, this is all you need:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
Section "Files"
Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Acer XB271HU"
    HorizSync       34.0 - 240.0
    VertRefresh     30.0 - 165.0
    Option         "DPMS"
Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "NVIDIA GeForce GTX 1080 Ti"
    Option  "ConnectToAcpid"    "Off"
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-0"
    Option         "metamodes" "DP-0: 1920x1080_165 +0+580, DP-4: 2560x1440_165 +1920+0 {rotation=right}, DP-2: 1920x1080_165 +3360+580"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
Section "Extensions"
    Option         "COMPOSITE" "Enable"
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"

I didn’t do any of that. The only thing I changed in the nvidia-settings GUI is the position, resolution and refresh rate of my monitors.

How do I turn off nvidia-auto-select? Also I can’t find any preview functionality in the nvidia-settings GUI.

After the changes you do, and click to save


You get the pop-up window and instead of saving, you preview it


Enlarge the pop-up window and you can see how it looks and what you changed, and you can copy that text.

1 Like

Ahh thanks :slight_smile:

Well I can’t seem to get rid of the nvidia-auto-select. Resetting the config doesn’t work and also renaming the /etc/xorg.conf file doesn’t work. Where does nvidia-settings take it’s default values from when loading the GUI?

I am guessing all those meta options are from my previous tries to get the displays working.

Delete that please …
A general default is provided when installing the driver and is the /etc/X11/mhwd.d/nvidia.conf
That one is done so it will work in a default mode for all Nvidia GPUs.
When you tweak the conf file is suppose to know that changing it only makes sense if you want a fixed layout, aka no nvidia-auto-select. In order to have that fixed layout, the position and resolution is Absolute.


If you want Advanced config, you should only touch the Force Composition or Force Full Composition (never both of those) and the rest keep them. Once you start changing values it will add a lot of entries for the same port in Section "Screen" as it did for you in this config

Just search for DP-0 and you will get 8 of them. Same with the other 2 ports.

The one i cleaned up here should work:

Once you do those changes, run from terminal:
sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf

1 Like

I actually meant /etc/X11/xorg.conf. Should I delete this one as well?

As expected after the reboot everything went back to how it was.

The thing is when I change the resolution from off to anything this happens:


and the display doesn’t turn on.

For anyone experiencing the same issue: A workaround is to start with the lowest resolution possible in nvidia-settings and slowly move your way up to the highest possible and hit apply each time.

I tried downgrading the nvidia-drivers to 520.56.06-4 (linux60-nvidia 520.56.06-4) but I ran into problems starting the X server due to probably other nvidia packages not being compatible with this version. Will continue with this at some point.