[Stable Update] 2022-01-02 - Kernels, Systemd, KDE Frameworks, Mesa, Xorg-Server, Wine, Python 3.10

Works, but manjaro hello release info is now mentioning 21.1. :slight_smile:

Refresh your mirrors and update to 3.5.7-1.

The devs must have had a reason for downgrading the package and I’m sure they will sort it all out soon. Also downgrading the package will get rid of the error and force the local system to match the repos. That being said, if the package is causing no issues, it is OK to keep the newer package installed locally if one desires. I did downgrade myself and can confirm that “Release Info” now refers to the prior release. No worries!

1 Like

Thanks for that. All good. :slightly_smiling_face: :ok_hand:

Almost Everything went smoothly, and a HUGE thank you for updating kicad to version 6.0!

The only problem I’m having is that gestures are no longer working with touchegg and the Synaptics touchpad on my laptop. Looks like libinput was part of this update, and systemd displays the following daemon status message:

Jan 02 17:39:55 hostname touchegg[4318]: libinput error: event5 - SynPS/2 Synaptics TouchPad: libinput bug: invalid gesture event GESTURE_EVENT_PINCH in state GESTURE_STATE_NONE

EDIT: False alarm, touchegg and libinput are both working fine. Looks like the kicad major version update sets the default zoom in / zoom out to null, for whatever reason. Manually setting them to ctrl + and ctrl - respectively makes everything function as expected.

A post was split to a new topic: X wouldn’t start properly after upgrade

perhaps this post near the beginning of this thread would help?

I also noticed a second experience and suggestion…

Issues with AUR packages are off topic in Announcement threads.

ah, I’m an AMD user myself, so was not aware the nvidia optimus-manager was an AUR package

I had the Kodi-python problem on 3 HTPCs. I deleted the youtube addon folder from


and Kodi now works fine. Easy fix since I no longer use the youtube addon anyway.
The Endeavor post listed above goes into more detail. Downgrading python doesn’t seem to be necessary.

1 Like

== Update Fail ==

Why does the package core/filesystem complain about /usr/local/share/man, and by complain I mean:

error: extract: not overwriting dir with file /usr/local/share/man
error: problem occurred while upgrading filesystem
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.
===> pacman -Fx /usr/local/share/man
usr/local/share/man is owned by core/filesystem 2021.01.19-1

# pacman -Fy usually runs after a successful install, so had to run it manually
===> pacman -Fx /usr/local/share/man
usr/local/share/man is owned by core/filesystem 2021.12.07-3

I use /usr/local/share/man/ directory tree for local man pages.

I created this directory some time ago, and have done updates with no problems.

== Update Success ==


I moved our man pages from /usr/local/share/man to /usr/local/man.

A post was split to a new topic: After the update gnomecast stopped working

I get stuck here in updating sway on x86_64:

Download of greetd-tuigreet (0.7.1-2) finished                                       
Checking keyring...                                                         [256/256]
Checking integrity...                                                       [256/256]
Error: greetd-tuigreet: signature from "Jonas Strassel <info@jonas-strassel.de>" is invalid
Removing invalid files and retrying...
Resolving dependencies...
Checking inter-conflicts...
Download of greetd-tuigreet (0.7.1-2) started                                        
Download of greetd-tuigreet (0.7.1-2) finished                                       
Checking keyring...                                                         [256/256]
Checking integrity...                                                       [256/256]
Error: greetd-tuigreet: signature from "Jonas Strassel <info@jonas-strassel.de>" is invalid
Error: Failed to commit transaction: invalid or corrupted package:```

greetd-tuigreet is a package from a 3rd party repository. Open an issue here: Issues · Manjaro-Sway/manjaro-sway · GitHub

I seem to be running more python reliant addons, as this didn’t work for me.

Since Arch enabled LTO by default, this driver is broken. Revision 2 in testing branch should fix that: upgpkg: amdvlk 2021.Q4.3-2: disable lto, that should fix segfaults · archlinux/svntogit-packages@7ce9dd7 · GitHub

1 Like

A few interesting observations, but everything was fixable and I could explain with confidence what was going on.

== 1 ==

I have seen the warning message below before, sometimes it is Firefox. The file did and does exist. Wondering if this is a real warning or just a missing leading slash?

checking available disk space...
warning: could not get file information for usr/lib/thunderbird/distribution/distribution.ini
:: Running pre-transaction hooks...

== 2 ==

I missed the 5.13 preset file when I cleaned up the 5.13 kernel awhile back, causing the messages below. I ran into some bumps along the way. At this point in time, all I needed to do was remove linux513.preset file.

==> Building image from preset: /etc/mkinitcpio.d/linux513.preset: 'default'
  -> -k /boot/vmlinuz-5.13-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.13-x86_64.img
==> ERROR: specified kernel image does not exist: `/boot/vmlinuz-5.13-x86_64'

== 3 ==

I don’t think I have ever installed a Manjaro update without seeing these messages. So far, they seem harmless :slight_smile:

warning: dependency cycle detected:
warning: bashrc-manjaro will be installed before its bash dependency
warning: dependency cycle detected:
warning: freetype2 
warning: mesa
warning: lib32-mesa 
warning: lib32-harfbuzz 

This is what I get when I ran this:

Total Download Size:     63.60 MiB
Total Installed Size:  1972.47 MiB
Net Upgrade Size:         0.00 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 libreoffice-fresh-7.2.4-1-x86_64 is up to date
 Total (  1/170)                                                                                     63.6 MiB   225 MiB/s 00:00 [#############################################################################] 100%
error: failed retrieving file 'libreoffice-fresh-7.2.4-1-x86_64.pkg.tar.zst.sig' from manjaro.lucassymons.net : The requested URL returned error: 404
warning: failed to retrieve some files
error: failed to commit transaction (failed to retrieve some files)
Errors occurred, no packages were upgraded.
 -> error installing repo packages

I had three Latte docks on my desktop - after the update only one shows up (the two others are just gone). Any kind of help how to get them back without starting from scratch is highly welcome!

I bumped into this one:
FS#73208 - Systemd-homed fails with systemd-250

Trying to solve it now, hopefully quickly. :slight_smile:

EDIT: Seems like the link states, downgrading to 249 solves the issue. So, I ran

pacman -U /var/cache/pacman/pkg/systemd-249.7-2-x86_64.pkg.tar.zst

and now I could login to that system.

As a further detail, this didn’t happen on my laptop yesterday where the LUKS encrypted storage doesn’t have a dedicated drive, only on my two desktops that have dedicated disk storage for my user home.