Windows not found after update

Hello,

Since the update I’ve been debugging my system for over 4 hours, and I cannot for the life of me get the system to find windows 10 again.

I read through the update post about adding the GRUB_DISABLE_OS_PROBER=false to /etc/default/grub, but this did absolutely nothing for me.

Also, os-prober does not print anything when run, so I’m guessing this is where the problem is?

From what I know I do use efi to load my system but the /sys/firmware/efi folder does not exist and efibootmgr complains about efi variables not being supported. I’m fairly sure this was not the case before the update. So this update has really screwed my system over, and I cannot find anyone with the same problems as me.

How would I go about debugging this further?

Did you updated grub after editing?

OS prober should detect Windows nonetheless.
Do you see the Windows partition in Gparted?

OS prober has been disabled in the latest grub
You can re enable it in “/etc/default/grub” then “sudo update-grub”

# Uncomment this option to enable os-prober execution in the grub-mkconfig command
GRUB_DISABLE_OS_PROBER=false
2 Likes

Did you do sudo update-grub like it says in that same post?

Welcome to the forum! :slight_smile:

If only people were to actually use the search function, just like it says before you create a new thread, eh?

:arrow_down:

1 Like

Yes I did use that command. Still does not show up

Thanks for the hostility, all the post I’ve read got solved by adding the GRUB_DISABLE_OS_PROBE=false flag, and this did not work for me. Despite also updating grub. Would you rather me post on those instead, even when those are solved?

If this community is this toxic, I might as well jump ship tbh. Jesus

Yes it is still there, for some reason I cannot post images of gparted. But there are two of them, one Microsoft reserved partition and one basic data partition.

Hey Thraix,
Could you look into this comment.

As I am not that expert, let other people comment on this, if they say this is safe you can do this.
Thanks,

I did search and these didn’t come up. But thanks for posting them, they are helpful.

Cheers.

1 Like

Hm… Are you able to select the Windows Bootloader and boot into it? Just to see if it broke somehow or not.

And just to confirm, this is 100% in the file and saved right?

Alternatively… stop using grub and use rEFInd instead :stuck_out_tongue:

I like rEFInd because you never have to use something like update-grub. It just scans for all bootable systems at boot.

Though this might be the issue. You can try to reinstall grub.

https://wiki.manjaro.org/index.php/GRUB/Restore_the_GRUB_Bootloader

Another thing you can check is if ntfs-3g is still installed or not, you need that for os-prober to detect it.

Not sure how I would do that if grub is not recognizing it.

Yes I’ve copy-pasted the command multiple times just to make sure.

I don’t even know how I would go about doing this.

I’ve already tried reinstalling grub using a bootable usb. and ntfs-3g does exist on my system.

This is looking more like the windows partition is broken or something. Maybe this is a combination of windows update and the manjaro update causing problems. I will see if the bootable windows usb can see if something is wrong with the partionion maybe.

Can you browse to your Windows partition and access to your data?

Yes, I can mount and browse the data perfectly.

Odd odd odd… OS prober alone should at least give something.

What’s the actual output of sudo os-prober?

It gives no output what so ever. Which is why I think the windows partition is broken

Let the below comment as a last resort, but save all your data from Windows and reinstall it.

In the meantime, let’s wait for other suggestions.

ye, its a weird problem. But I really appreciate your help!

Could you post the result of lsblk --output NAME,SIZE,TYPE,FSTYPE,MOUNTPOINT ?

NAME     SIZE TYPE FSTYPE MOUNTPOINT
    sda    931.5G disk        
    ├─sda1   300M part vfat   /boot/efi
    ├─sda2 672.4G part ext4   /
    ├─sda3    16M part        
    ├─sda4 249.5G part ntfs   /mnt/harddrive
    ├─sda5   529M part ntfs   
    └─sda6   8.8G part swap   [SWAP]

the windows partition is the sda4, mounted to /mnt/harddrive currently. I’ve tried running update-grub with it mounted and not.

Have you the ability to boot on Windows directly from BIOS or when typing F… (F12 for my Dell) at manufacturer’s logo?

Just a total guess, I don’t know if it’s possible (apart from Grub) to boot from another partition of the same disk.

I have myself Windows installed on a second HDD and can boot from BIOS if Grub doesn’t work as recently anf if the need would arise (which won’t).