[Stable Update] 2021-03-08- Kernels, Plasma 5.21.2, Haskell, Kodi, Grub, KDE-Dev

Weird, changing mirror list and updating DB in pamac resolve the issue.

All fine with Xfce, Kernel 5.10.19-1 - but I wonder that Kernel 5.10 is still not marked as LTS. thanks for your good work!

1 Like

RAS kernel 5.11.2 , nvidia , cinnamon

Thanks

Amazing update & big thanks to the whole team, including those who run non-Stable for the rest of us!

More power to you all.

Ruziel :slight_smile:

5 Likes

Thank you for encouraging women against the smell of hatred around them.

10 Likes

For now i solved reinstalling the previous package of GRUB with sudo pacman -U /var/cache/pacman/pkg/grub-2.04-16-x86_64.pkg.tar.zst and after running sudo update-grub it works again.

3 Likes

Finally, able to remove python2… great work everyone :slight_smile:

Through a recent patch, os-prober seems to have been disabled by default. See here for details: https://gitlab.manjaro.org/packages/core/grub/-/commit/991784fbecb814a14651e1ccbd0dd6b08de2a129

I had the same issue and could resolve it by manually adding the line GRUB_DISABLE_OS_PROBER=false
to /etc/default/grub.

22 Likes

Which clock is that, a third party widget?

That’s an Event Calendar. Ok, it’s fixed: all you have to do is to update that plasmoid. :+1:

1 Like

The update went smooth on all my GNOME machines.

Keep up the good work!

Everything is fine here :smiley::smiley::+1::+1:…Gnome…5.11 & 5.10 LTS

Thank you very much for the info. I added that line to my Grub config with the new package installed and now it works.

Thanks Hefty!!!

That worked :slight_smile:

But:
I’m on stable branch to NEVER experience such issues!!!

Even grub.pacnew doesn’t contain
“GRUB_DISABLE_OS_PROBER=false”

Every one with multiboot is in a really bad situation!

Very bad, really!

5 Likes

Hi @Hefty !

Can you include your solution to the problem in " Known issues and solutions" (above)? I think it is quite important and it would make easier to people find it.

Cheers.

1 Like

I found a small bug:
my Windows 10 installation is not found.

2 Likes

My grub didn’t recognize my Windows 10 installation either after this update. The os-prober setting and then running update-grub added it back.

1 Like

If your multiboot Manjaro grub does not include other OS as Windows … see post from Hefty (down)

Hi @Keruskerfuerst,

Have a look at @Hefty solution:

2 Likes

I got

npm: /usr/lib/node_modules/npm/node_modules/which/bin/node-which exists in filesystem
npm: /usr/lib/node_modules/npm/scripts/bundle-and-gitignore-deps.js exists in filesystem
npm: /usr/lib/node_modules/npm/scripts/resetdeps.sh exists in filesystem
Errors occurred, no packages were upgraded.

And so on, what to do.