After update, grub doesn't find windows install

Hi,

I’ve been using both Manjaro and windos for a couple years through dual boot without issue. Today Manjaro asked me to run some updates, like it often does, but when I finished work and rebooted to launch windows and get some gaming done, grub wasn’t showing at all and Manjaro would launch without asking me for input at all. I looked around, modified /etc/default/grub to set GRUB_TIMEOUT_STYLE=menu (it was hidden for some reason), and now I see it… but the option to boot windows was gone.

I’m not too knowledgeable on these topics, so I don’t know what to do. I googled around and found that I should look at the output of some commands, but I can’t make heads or tails of what they mean. Just in case, here’s the output of them:

lsblk

NAME   MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
loop0    7:0    0  99,2M  1 loop /var/lib/snapd/snap/core/10859
loop1    7:1    0 150,2M  1 loop /var/lib/snapd/snap/git-cola/136
loop2    7:2    0  98,4M  1 loop /var/lib/snapd/snap/core/10823
sda      8:0    0   1,8T  0 disk 
├─sda1   8:1    0    50M  0 part 
├─sda2   8:2    0   1,8T  0 part 
└─sda3   8:3    0   513M  0 part 
sdb      8:16   0 931,5G  0 disk 
└─sdb1   8:17   0 931,5G  0 part /

sudo parted -l

Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  53,5MB  52,4MB  primary  ntfs         boot
 2      53,5MB  2000GB  2000GB  primary  ntfs
 3      2000GB  2000GB  538MB   primary  ntfs         msftres


Model: ATA Samsung SSD 860 (scsi)
Disk /dev/sdb: 1000GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  1000GB  1000GB  primary  ext4         boot

efibootmgr -v
EFI variables are not supported on this system.

sudo os-prober
/dev/sda1:Windows 10:Windows:chain

test -d /sys/firmware/efi && echo efi || echo bios
bios

sudo update-grub

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.9-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.9-x86_64.img
Found initrd fallback image: /boot/initramfs-5.9-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.7-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.7-x86_64.img
Found initrd fallback image: /boot/initramfs-5.7-x86_64-fallback.img
Found linux image: /boot/vmlinuz-5.4-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.4-x86_64.img
Found initrd fallback image: /boot/initramfs-5.4-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
done

I don’t understand why windows disappeared all of a sudden, for no apparent reason, or how to bring it back. Can anyone help me?

2 Likes
4 Likes
1 Like

I reinstalled GRUB 15 minutes ago and noticed it wasn’t looking for Windows partition anymore, and I had to add to my grub config file /etc/default/grub the following line

# OS Prober
GRUB_DISABLE_OS_PROBER=false

and then I ran sudo update-grub and it detected and added the Windows Grub menu entry.

5 Likes

You, my good sir, just saved my day.

THANK YOU. That’s been driving me crazy for like an hour.

I see, at least on Testing branch, that there is a new .pacnew file for GRUB that adds the parameter to GRUB config file, so if people look after their .pacnew files it is now kinda fixed, or taken care of. People still need to manually do it to enable it but it is there now.

# Uncomment this option to enable os-prober execution in the grub-mkconfig command
#GRUB_DISABLE_OS_PROBER=false

Thanks a lot! I had the same issue after Manjaro update and adding GRUB_DISABLE_OS_PROBER=false fixed Windows back.

Worked for me as well, thank you!!

I wanted to drop a quick thanks myself. I didn’t expect to have a reply so fast and went on investigating, and had managed to add a manual windows entry to grub to get by. But now I updated my laptop and had the same issue, remembered to come over to check for replies and it really helped.

So thanks.

Thank you man
شكرا لك

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.