Windows not found after update

No, since they are on the same drive. I cannot change the order of partitions.

Alright, so I finally solved my problems I think. Whenever I did the boot-repair through the usb, I don’t think I booted the USB through EFI, so the /sys/firmware/efi didn’t exist, meaning I think did the guide for BIOS. Which I guess somehow broke my system since I was now forced to boot into BIOS and not efi. And I guess my windows was on the efi boot system (not entirely sure what is happening here tbh).

So my solution:
Boot manjaro on USB using UEFI and repair grub using the EFI guide. Then update-grub finally finds my windows partition!

Thanks for trying to help anyways @Falav


You’d go into your BIOS and put the Windows Bootloader as the top priority in the boot sequence. Or at the BIOS bootup screen, there should be an F key to select what to boot from. Same way you would boot from a LiveISO to install Manjaro or Windows.

But it looks like you’ve solved your issue already so that’s great!

Had the same problem, and this is the first time I have had to do this and I have been using dual boot on that very same compute for probably about 2 years. But this solved it for me. Thank you.

And I forgot to mention that this line was missing in the /etc/default/grub file so it had to be added, maybe that is the problem, got removed in the latest update by accident, third option would be alien conspiracy from planet 9.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.