Windows 10 does not boot after installing Manjaro

Hi,
i’ve my laptop with two ssd, i’ve installed windows 10 in one and i installed manjaro in the other one.
The thing is that after installing manjaro, it works perfectly but i can’t boot on windows.
The system is UEFI GPT, and in the GRUB shows manjaro and windows, but windows did not boot.
I did the GRUB update, and try to repair the bootloader from the windows troubleshoot, but still nothing.
any ideas?

 lsblk  :heavy_check_mark:
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINTS
nvme1n1 259:0 0 476,9G 0 disk
├─nvme1n1p1 259:1 0 512M 0 part /boot/efi
├─nvme1n1p2 259:2 0 170G 0 part /
├─nvme1n1p3 259:3 0 300G 0 part /home
└─nvme1n1p4 259:4 0 6,4G 0 part [SWAP]
nvme0n1 259:5 0 476,9G 0 disk
├─nvme0n1p1 259:6 0 300M 0 part
├─nvme0n1p2 259:7 0 128M 0 part
├─nvme0n1p3 259:8 0 275,6G 0 part /run/media/facundo/Windows
├─nvme0n1p4 259:9 0 900M 0 part
├─nvme0n1p5 259:10 0 183,5G 0 part /run/media/facundo/DATA
└─nvme0n1p6 259:11 0 16,6G 0 part

Model: KBG30ZMV512G TOSHIBA (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Warning: failed to translate partition name
Number Start End Size File system Name Flags
1 1049kB 316MB 315MB fat32 EFI system partition boot, esp
2 316MB 450MB 134MB Microsoft reserved partition msftres
3 450MB 296GB 296GB ntfs Basic data partition msftdata
4 296GB 297GB 944MB ntfs Basic data partition hidden, diag
5 297GB 494GB 197GB ntfs Basic data partition msftdata
6 494GB 512GB 17,8GB ntfs hidden, diag

Model: KBG30ZMV512G TOSHIBA (nvme)
Disk /dev/nvme1n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
1 1049kB 538MB 537MB fat32 bios_grub
2 538MB 183GB 183GB ext4
3 183GB 505GB 322GB ext4
4 505GB 512GB 6909MB linux-swap(v1) swap

Hi @gordotito, and welcome!

Not using, having or caring about Windows, the only thing I can point you to is this :point_down:


Tip:

When posting terminal output, copy the output and paste it here, wrapped in three (3) backticks, before AND after the pasted text. Like this:

pasted text

This will just cause it to be rendered like this:

Sed
sollicitudin dolor
eget nisl elit id
condimentum
arcu erat varius
cursus sem quis eros.

Instead of like this:

Sed sollicitudin dolor eget nisl elit id condimentum arcu erat varius cursus sem quis eros.

Thereby increasing legibility thus making it easier for those trying to provide assistance.

Please edit your post accordingly.


Also a good idea would be to work through this:

Hope you manage!

paste output of those

sudo efibootmgr 
sudo update-grub

Given that you have a bios-grub partition in your Linux drive, I suspect you are using BIOS boot. If that’s the case you can’t boot Windows, as it is installed in UEFI mode. You will need to reinstall Manjaro or change Manjaro to UEFI mode (not hard to do, but also not trivial)

You can check what mode your Manjaro is using with:
test -d /sys/firmware/efi && echo UEFI || echo BIOS

Have you disabled “Fast Startup” in W10? It is activated by default and needs to be switched off manually.

I had followed all these steps before installing manjaro but still windows 10 did not boot.
Finally i tried to boot windows a few times and at some point windows did repared it boot loader by it self. Now everithing works perfectly.

Thanks!

1 Like

i did it, really do not understand what the problem was

i did it, manjaro was using UEFI mode.