What is the keyboard combination for SysRq on a Thinkpad T400p?

Does anyone have any idea what the keyboard combination for sysreq is on a t400p thinkpad?

I get complete freezes a couple of times a week that need a hard reset :slightly_frowning_face: it would be nice to get REISUB to work.

It should be Alt+PrtSc.

You can also try with Fn+S.

Thanks Yochanan, unfortunately this does not work for me.

A stupid question: How do I type the “S” of REISUB if I am already holding the S (Fn + S)?

You don’t hold down the S. You would press and hold Alt, then press Fn+S (your SysRq key), and release both. While still holding Alt, press the REISUB sequence.

2 Likes

:flushed:

to release both what? a or b variant below?

a) 1st item: (Alt) and 2nd item: (Fn+S)
OR
b) 1st item (Fn) and 2nd item: (S)
?

The same in another words: Does Alt should be uninterruptedly pressed fro the very start of SysRq call and all the time 'till the end of REISUB phrase typing?

Remember, Fn+S = SysRq. Treat it as such. :wink:

Thanks Yochanan for a great explanation.

Unfortunately Holding Alt then Fn + S, releasing Fn + S (whilst still holding Alt) and entering REISUB does not work for me.

Found the manual:

Fn+PrtSc Has the same function as the SysRq key.

2 Likes

That was a really cool thing to do, thank you.

Holding Fn+PrtScr whilst entering REISUB does not work for me. Is there a way REISUB could have been disabled?

This is a video of I am doing when I enter REISUB:

Why do you still hold your SysRq while typing REISUB??? As i undestand you need to call it and to release then.
Are you tried to type REISUB keys with 0.5-1 seconds delay or typed whole 6 chars during a single second?

It’s not enabled by default.

Or…

1 Like

I managed to get a different distro on another machine to REISUB once by holding the SysRq key whilst typing out REISUB.

That being said:
if I press Fn + PrtSc, release both and type REISUB it does not work;
if I press Fn + PrtSc, release the PrtSc key and type REISUB it does not work.

Hold Alt the whole time while you…

I have entered the following terminal command:

    ~  echo kernel.sysrq=1 | sudo tee --append /etc/sysctl.d/99-sysctl.conf
Swipe your finger across the fingerprint reader
kernel.sysrq=1

I tried holding alt the whole time, pressing Fn + PrtSc, releasing Fn + PrtSc, then entering REISUB. I could not get this to work

That doesn’t take effect immediately, did you reboot after doing that?

1 Like

I have rebooted but it is still the same as before.

Output of

cat /etc/sysctl.d/99-sysctl.conf

please?

1 Like

Just FYI; you can test it by running journalctl -f and then do Alt+SysRq+h.

If it’s working you’ll get sysrq help output into journal:

kernel: sysrq: HELP : loglevel(0-9) reboot(b) crash(c) terminate-all-tasks(e) memory-full-oom-kill(f) kill-all-tasks(i) thaw-filesystems(j) sak(k) show-backtrace-all-active-cpus(l) show-memory-usage(m) nice-all-RT-tasks(n) poweroff(o) show-registers(p) show-all-timers(q) unraw(r) sync(s) show-task-states(t) unmount(u) force-fb(v) show-blocked-tasks(w) dump-ftrace-buffer(z)

Edit to expand on this:

If you can’t find SysRq key and still want to test if functionality is enabled, you can instead try:
echo h | sudo tee /proc/sysrq-trigger

3 Likes