Wayland crashing on Ryzen 7 PRO 6850U with Radeon Graphics

my new Laptop crashes when I’m using Gnome on Wayland within minutes after booting. It seems to happen especially often right after something new appears on the screen.

I’m not happy with the workaround of using Xorg. journalctl doesn’t give me any hints why this might happen, so any help with either the problem or creating a proper bugreport would be appreciated.

Hi @ghutz, and welcome!

I don’t know anything about Wayland, but the output of the following might help:

journalctl --no-pager --grep='wayland' --priority=4

As well as:

mhwd --list


mhwd --listinstalled


inxi --admin --verbosity=7 --filter --width

Please also see:

Hope you manage!

:bangbang: Tip: :bangbang:

To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:

pasted text

Or three (3) tilde signs, like this:

pasted text

This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Alternatively, paste the text you wish to format as terminal output, select all pasted text, and click the </> button on the taskbar. This will indent the whole pasted section with one TAB, causing it to render the same way as described above.

Thereby improving legibility and making it much easier for those trying to be of assistance.

:bangbang::bangbang: Additionally

If your language isn’t English, please prepend any and all terminal commands with LC_ALL=C. For example:

LC_ALL=C bluetoothctl

This will just cause the terminal output to be in English, making it easier to understand and debug.

With regards to

Normally I’d agree that this would be the right way to do things and to rather fix the problem than avoid it. However, given that Wayland is under active development and known to have problems, this might be the only solution at the moment…

Also see:


Section 7.2, Slow motion, graphical glitches, and crashes, states:

Gnome-shell users may experience display issues when they switch to Wayland from X. One of the root cause might be the CLUTTER_PAINT=disable-clipped-redraws:disable-culling set by yourself for Xorg-based gnome-shell. Just try to remove it from /etc/environment or other rc files to see if everything goes back to normal.

Thank you.

Relevant parts:

Kernel: 6.2.8-1-MANJARO

Correct driver used:

$inxi --admin --verbosity=7 --filter --width
  Device-1: AMD Rembrandt [Radeon 680M] vendor: Lenovo driver: amdgpu v: kernel
    arch: RDNA-2 code: Navi-2x process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4
    speed: 16 GT/s lanes: 16 ports: active: DP-2,eDP-1 empty: DP-1, DP-3,
    DP-4, DP-5, DP-6, HDMI-A-1 bus-ID: 04:00.0 chip-ID: 1002:1681
    class-ID: 0300 temp: 51.0 C

Doesn’t seem to be used anyway:

$mhwd --listinstalled
Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

This is probably just from logging out:

-- Boot a701b3279fbb43619e6380859cf47962 --
Mär 28 15:11:23 localhost gnome-shell[3237]: Connection to xwayland lost

Section 7.2, Slow motion, graphical glitches, and crashes, states:

not present

1 Like

There’s more parts relevant than just this. Please post the complete output of the command.

Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the command.

Not having or using AMD, I might be wrong, but I think that is the name of the correct driver.

That’s good. Apparently.

But that is the limit of my knowledge, sorry.


I suppose I did find an error after all:
kernel: amdgpu 0000:04:00.0: [drm] *ERROR* [CRTC:67:crtc-0] flip_done timed out