[Unstable Update] 2022-11-25 - Mkinitcpio, NVIDIA, Qt, Gtk, SDL, LibreOffice, Cinnamon

All sorts of weird glitches in steam (steam) with update to lib32-libx11 1.8.3-1 and major stuttering in steam game L4D2. Also reported here: Team Fortress 2 Crash with newest lib32-libx11 / Multimedia and Games / Arch Linux Forums

I’ve just built lib32-libx11 1.8.3-1.0 with 0001-Revert_Update_XPutBackEvent.diff applied. Let me know if that resolves the issue. I’ll also test myself and see if that resolves the lag I was having with GreedFall.

EDIT: It does indeed resolve the lag.

1 Like

:warning: binutils 2.4.0 toolchain rebuilds are coming in along with virtualbox 7.0.6. It will be a few hours at least before the kernel rebuilds are done. I advise delaying updating until you see the kernel rebuilds available.

2 Likes

be very careful on new grub version r416

dont know what ysou talk about: Packages

In ARCH core there is at time: v415 afaik?!
https://ftp.fau.de/archlinux/core/os/x86_64/grub-2:2.06.r415.g1a241e050-1-x86_64.pkg.tar.zst

1 Like

Phil is right, as I remember we have rollback grub to stable version/revision because something was not stable enough.
And we have a separate thread for package updates.:

kernel rebuilds are not in repos yet

Neues Thema / New topic
@pheiduck @koshikas

make: Verzeichnis „/usr/lib/modules/5.15.88-1-MANJARO/build“ wird betreten
warning: the compiler differs from the one used to build the kernel
  The kernel was built by: gcc (GCC) 12.2.0
  You are using:           gcc (GCC) 12.2.1 20230111

Extra modul error! kernel 5.15.88-1 is build with gcc 12.2.0
whereas installed gcc version is 12.2.1

kernel requires a rebuild as koshikas told…

Another machine:

Compiling OpenRazer kernel modules
:================================
make -C /lib/modules/5.15.88-1-MANJARO/build M=/var/lib/dkms/openrazer-driver/3.5.1/build/driver modules
make[1]: Verzeichnis „/usr/lib/modules/5.15.88-1-MANJARO/build“ wird betreten
warning: the compiler differs from the one used to build the kernel
  The kernel was built by: gcc (GCC) 12.2.0
  You are using:           gcc (GCC) 12.2.1 20230111
  CC [M]  /var/lib/dkms/openrazer-driver/3.5.1/build/driver/razerkbd_driver.o
cc1: Fehler: incompatible gcc/plugin versions
cc1: Fehler: Plugin ./scripts/gcc-plugins/structleak_plugin.so kann nicht initialisiert werden
make[2]: *** [scripts/Makefile.build:289: /var/lib/dkms/openrazer-driver/3.5.1/build/driver/razerkbd_driver.o] Fehler 1
make[1]: *** [Makefile:1902: /var/lib/dkms/openrazer-driver/3.5.1/build/driver] Fehler 2
make[1]: Verzeichnis „/usr/lib/modules/5.15.88-1-MANJARO/build“ wird verlassen
make: *** [Makefile:41: driver] Fehler 2

Bildgcc-ding

Reason… <==> solved in the meantime, everything o.K. :innocent:
@koshikas you where right…


Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

kernel requires a rebuild with new binutils released, and to lesser degree newer gcc release also in the update (as per the warning you quoted) . if you have updated already, postpone reboot till you get the update for the new kernel re-release. this has nothing to do with supposed update to grub

Reboot could come with sudden power loss, better to rollback to prev. state for each updated machine.

How hard to implement a fix of update procedure: to postpone of releasing partial incompatible updates. To introduce a release condition to release only whole batch of packages updates if all of them are ready to prevent release of partial / incompatible updates OR it is OK to let it be on unstable branch?

They are now. :wink:

2 Likes
got some 'usr/lib/locale/' warnings during installation
...
Total Download Size:    437.07 MiB
Total Installed Size:  1180.34 MiB
Net Upgrade Size:        18.48 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 nerd-fonts-noto-sans-mono-2.3.0-1-any                                                               7.3 MiB  1461 KiB/s 00:05 [############################################################################] 100%
 binutils-2.40-1-x86_64                                                                              7.1 MiB  1069 KiB/s 00:07 [############################################################################] 100%
 git-2.39.1-1-x86_64                                                                                 6.6 MiB  1463 KiB/s 00:05 [############################################################################] 100%
 glibc-2.36-7-x86_64                                                                                 9.8 MiB   796 KiB/s 00:13 [############################################################################] 100%
 qt5-tools-5.15.8+kde+r1-3-x86_64                                                                    5.3 MiB   945 KiB/s 00:06 [############################################################################] 100%
 qt5-base-5.15.8+kde+r165-1-x86_64                                                                  13.0 MiB  1030 KiB/s 00:13 [############################################################################] 100%
 libva-mesa-driver-22.3.3-2-x86_64                                                                   4.8 MiB  1510 KiB/s 00:03 [############################################################################] 100%
 libelf-0.188-2-x86_64                                                                             550.0 KiB   593 KiB/s 00:01 [############################################################################] 100%
 gpgme-1.18.0-2-x86_64                                                                             447.1 KiB   828 KiB/s 00:01 [############################################################################] 100%
 mpfr-4.2.0-2-x86_64                                                                               427.4 KiB   460 KiB/s 00:01 [############################################################################] 100%
 wildmidi-0.4.5-1-x86_64                                                                            91.8 KiB   382 KiB/s 00:00 [############################################################################] 100%
 libtool-2.4.7+4+g1ec8fa28-1-x86_64                                                                412.4 KiB   443 KiB/s 00:01 [############################################################################] 100%
 libinput-1.22.1-1-x86_64                                                                          279.8 KiB   471 KiB/s 00:01 [############################################################################] 100%
 libxpm-3.5.15-1-x86_64                                                                             71.6 KiB   447 KiB/s 00:00 [############################################################################] 100%
 libsysprof-capture-3.46.0-3-x86_64                                                                 45.3 KiB   174 KiB/s 00:00 [############################################################################] 100%
 mesa-22.3.3-2-x86_64                                                                               31.6 MiB  1281 KiB/s 00:25 [############################################################################] 100%
 llvm-libs-15.0.7-1-x86_64                                                                          29.3 MiB  1102 KiB/s 00:27 [############################################################################] 100%
 gcc-libs-12.2.1-1-x86_64                                                                           33.9 MiB  1181 KiB/s 00:29 [############################################################################] 100%
 gcc-12.2.1-1-x86_64                                                                                44.6 MiB  1319 KiB/s 00:35 [############################################################################] 100%
 firefox-109.0-1-x86_64                                                                             64.7 MiB  1591 KiB/s 00:42 [############################################################################] 100%
 linux62-6.2.0rc4-2-x86_64                                                                         176.8 MiB  3.26 MiB/s 00:54 [############################################################################] 100%
 Total (21/21)                                                                                     437.1 MiB  8.04 MiB/s 00:54 [############################################################################] 100%
(21/21) checking keys in keyring                                                                                               [############################################################################] 100%
(21/21) checking package integrity                                                                                             [############################################################################] 100%
(21/21) loading package files                                                                                                  [############################################################################] 100%
(21/21) checking for file conflicts                                                                                            [############################################################################] 100%
(21/21) checking available disk space                                                                                          [############################################################################] 100%
warning: could not get file information for usr/lib/locale/C.UTF-8/
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_ADDRESS
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_COLLATE
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_CTYPE
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_IDENTIFICATION
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_MEASUREMENT
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_MESSAGES/
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_MESSAGES/SYS_LC_MESSAGES
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_MONETARY
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_NAME
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_NUMERIC
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_PAPER
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_TELEPHONE
warning: could not get file information for usr/lib/locale/C.UTF-8/LC_TIME
:: Running pre-transaction hooks...
(1/3) Creating Timeshift snapshot before upgrade...
...

Latest “mesa” update broke picom/glx.

Broke it how?

Okay. It was just a rebuild. Nothing should have changed.

1 Like

After the update and the reboot sddm was strange, no background image,
then I iogin.
Conky was not transparent.
I run “picom --diagnostics” and appears in the terminal that no GLX extensions was found.

Some reboots and updates later everything was good.

A post was merged into an existing topic: Update requests for packages built by Manjaro developers

A post was split to a new topic: Boost and boost-libs updated to 1.81 break electricsheep