[Unstable Update] 2022-11-25 - Mkinitcpio, NVIDIA, Qt, Gtk, SDL, LibreOffice, Cinnamon

not the only, the protocol also:
in my case the
Protocols = https

as a long ago I used the
❯ sudo pacman-mirrors -a -P https -B unstable

Basically the package gets replaced and all our configs are not kept (being used). Not good. Also the mirror list got reset.

Not on my system: /etc/pacman.d/mirrorlist is still the same.

Maybe depends if mirrors happen to update with the new settings?

Yep that’s it, maybe the time trigger happened between when package got replaced and when I noticed messages about the config file being changed.

If you’re referrig to that awful pamac-mirrorlist.timer: that will mangle your mirrorlist when triggered (which is why I’ve disabled that one as I’m able to manage mirrors myself).

That’s what I’m talking about. It doesn’t mangle my mirror list as I set it manually initially, then the trigger should not destroy my list, I mean it never did as I initially configured pacman-mirrors to use HTTPS and only Global mirrors, then the trigger executes pacman-mirrors -f8 according to my settings, not mangling my list, but as pacman-mirrors got replaced, its config too, then this happened:

[omano@omano-nvme ~]$ systemctl status pamac-mirrorlist.timer
* pamac-mirrorlist.timer - Generate mirrorlist weekly
     Loaded: loaded (/usr/lib/systemd/system/pamac-mirrorlist.timer; enabled; preset: disabled)
     Active: active (waiting) since Thu 2022-12-22 22:23:03 CET; 16h ago
      Until: Thu 2022-12-22 22:23:03 CET; 16h ago
    Trigger: Thu 2022-12-29 14:57:15 CET; 6 days left
   Triggers: * pamac-mirrorlist.service

As I guessed it happened right at the ‘perfect’ time :ok_hand:

pacman-mirrors has been renamed to manjaro-mirrors, but

Replace manjaro-mirrors with core/pacman-mirrors? [Y/n]

I think the problem has already been solved and the package was migrated back.

(The solution is (1) give the repository packages a higher priority and (2) ask the author to rename their package.)

Recent btrfs-progs-6.1-1 breaks grub-btrfs and snapshots are not detected.

Upstream issue: kdave/btrfs-progs#562

1 Like

It should be tested enough until it’s available on stable maybe waiting for a patched version

It seems there’s a patch for btrfs-progs on queue:

1 Like

A post was split to a new topic: Pinta errors after today’s update

A post was split to a new topic: Is suspend / resume broken on manjaro as well?

pix in cinnamon does not start error from terminal below

(pix:355570): GLib-GObject-WARNING **: 14:53:35.777: g_type_class_add_private() called multiple times for the same type

** (pix:355570): CRITICAL **: 14:53:35.785: Could not load the mandatory extension 'cairo_io': Could not open the module `cairo_io`: libtiff.so.5: cannot open shared object file: No such file or directory
Aborted (core dumped)

Fixed with pix 2.8.9-2.

1 Like

Manjaro Tools Broken after todays update see

It’s fixed with r3004.dc48e4e-2.


:information_source: PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.