[Unstable Update] 2021-03-27 - Gnome 40, Kernels, Browsers, Haskell, Pipewire, AMDVLK, Wine

The aur package I’m using has already been updated…

1 Like

My pamac gui is with this:

2021-03-28_15-03

I have gtk3-classic and gtk3-nocsd installed.
Normal gtk3 does the same.

You may want to reenable CSD as this is the way forward. XFCE will add more CSD in future anyway. Maybe took also a look at libxfce4ui-nocsd.

1 Like

This is mine

Also we are in the process to port Pamac to GTK4 so we match upcoming Gnome changes better.

4 Likes

I removed gtk3-nocsd but kept gtk3-classic, I don`t like the dialogs of normal gtk3 because it is too long.

You can still have “gt3-nocsd” with “gtk3_classic” no conflicts.
This for me fixes pamac.

1 Like

Did you use another window manager? Openbox?

no just standard.
Top bar is “cinnXP-Embedded” (AUR)

1 Like

You are using cinnamon :slight_smile:
I am on XFCE

yes I am I love it.

You can try to execute this command in a Terminal:
xfconf-query -c xsettings -p /Gtk/DialogsUseHeader -s false

Then reboot.

I’m so glad that you mentioned this @philm. I’ve been dying to ask you this ever since I saw your post, “After looking at it again, it was one of the best decision by XFCE team to do it. I would even liked they did the full switch IMHO.” I felt it was too late to ask then and decided I’d watch and learn.

I want to get on the happy-csd-train too :slight_smile: What was the technical lightbulb moment for you, when you got onboard with CSD and the direction GTK is going?

Thank you.

1 Like

Possible typo in ISO build workflow

Wine 6.5-1 and 6.5-2 do not work for me. I downgraded to 6.4-1 and it works again (xfce). Can anybody confirm?

Thanks

I am using wine-staging 6.5-2 and is working.

The two Windows apps that I run through Wine (version 6.5-2) both open and perform as expected.

1 Like

Latest fontconfig-update changed the location of the 11-lcdfilter*.conf files from /etc/fonts/conf.avail to /usr/share/fontconfig/conf.avail/.
If anybody has symlinked one of those in /etc/fonts/conf.d/ - the symlinks will need to be adjusted accordingly.


edit: Just “found” the noto-fonts-compat package on one of my systems, which probably wants to adopt those path changes as well @philm?

3 Likes

I installed wine-staging 6.5-2 to see if it would make a difference. It does not launch, however, via command line I do get the program (QuickPar) to launch. Here is the output from terminal:

./QuickPar.exe                                                                                                               
002c:fixme:winediag:LdrInitializeThunk wine-staging 6.5 is a testing version containing experimental patches.
002c:fixme:winediag:LdrInitializeThunk Please mention your exact version when filing bug reports on winehq.org.
MESA-INTEL: warning: Ivy Bridge Vulkan support is incomplete
0024:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION

If this is related to the Mesa-Intel warning, I am uncertain how to fix it. Any ideas?

edit:
It might be related to 1924933 – mesa 21 breaks some wine programs
WineHQ Bugzilla – Bug 50869 – Killing Wine process in Wine 6.5 doesn't terminate the application because of the new use of start.exe

edit#2: I get the same error when running via CLI in 6.4-1, but the program launches.

I found the fix:
cp -a ~/.wine/drive_c/windows/command/start.exe ~/.wine/drive_c/windows/

That blue in pamac-gtk is a little too strong and a bit “off” in my opinion, the eye “falls” on that instead of the program’s icon. I would prefer something from Manjaro’s turquoise palette.

1 Like