Unable to connect to wifi after update. Ethernet works fine

I opened up the package manager to update my system. After the update finished I restarted the computer and now wifi doesn’t work. If i boot into windows 10 it works fine. And if i use ethernet it works fine. If i got to see what networks are available i see none.

inxi -Fazy output:
Kernel: 5.17.0-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-x86_64
root=UUID=9d2c7fa0-65d5-4c50-9752-f7f8408ce991 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma 5.23.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Manjaro Linux base: Arch Linux
Type: Laptop System: Hewlett-Packard product: HP ProBook 6560b v: A0001D02
serial: Chassis: type: 10 serial:
Mobo: Hewlett-Packard model: 1619 v: KBC Version 97.4A
serial: BIOS: Hewlett-Packard v: 68SCE Ver. F.22
date: 12/22/2011
Illegal division by zero at /usr/bin/inxi line 7512.

Thanks in advance.

Hi @random, and welcome!

That isn’t the complete output. If it was, it’d be a lot longer. Please see:

Have you tried with a different kernel?

Similar problem. Tried with different kernels 5.15.21-1 and 5.10.98-1. Also tried to connect in console mode via wpa_supplicant everything works.
I suspect that the problem is not in the driver or the kernel, but in Metwork-Manager. Otherwise, I would not be able to connect using wpa_supplicant.

$ sudo dmesg | grep wl

wl: loading out-of-tree module taints kernel.
wl: module license ‘MIXED/Proprietary’ taints kernel.
wl: module verification failed: signature and/or required key missing - tainting kernel
wlan0: Broadcom BCM4727 802.11 Hybrid Wireless Controller (r587334)

Hi @meow,

I recommend you open a new #support thread with the info requested above, because without it there’s very little to nothing anyone can do to help: