Touchpad not working out of the box

I have just installed Manjaro Linux on a Lenovo Ideapad 3 laptop.

The touchpad doesn’t work, it’s just like it didn’t exist. The USB mouse works fine.

If I go to System Settings → input devices → Touchpad it says “touchpad not found”.

Any ideas?

$ inxi --full --admin --verbosity=7 --filter --no-host                                                                                       ✔ 
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "",
        LC_ALL = (unset),
        LC_ADDRESS = "en_US.UTF-8",
        LC_IDENTIFICATION = "en_US.UTF-8",
        LC_MEASUREMENT = "en_150.UTF-8",
        LC_MONETARY = "es_ES.UTF-8",
        LC_NAME = "en_US.UTF-8",
        LC_NUMERIC = "en_US.UTF-8",
        LC_PAPER = "en_US.UTF-8",
        LC_TELEPHONE = "en_US.UTF-8",
        LC_TIME = "en_150.UTF-8",
        LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
  Kernel: 5.15.65-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=1a215379-e21a-47c1-9171-67e1681ddbdf rw quiet
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 81WE v: IdeaPad 3 15IIL05
    serial: <superuser required> Chassis: type: 10 v: IdeaPad 3 15IIL05
    serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN
    serial: <superuser required> UEFI: LENOVO v: EMCN14WW date: 05/11/2020
  ID-1: BAT0 charge: 42.1 Wh (100.0%) condition: 42.1/45.0 Wh (93.6%)
    volts: 12.6 min: 11.3 model: Celxpert L19C3PF7 type: Li-poly
    serial: <filter> status: full cycles: 12
  RAM: total: 7.33 GiB used: 3.98 GiB (54.3%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake
    gen: core 10 level: v4 built: 2019-21 process: Intel 10nm family: 6
    model-id: 0x7E (126) stepping: 5 microcode: 0xB2
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 3826 high: 3900 min/max: 400/3900 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3899 2: 3801 3: 3803
    4: 3803 5: 3900 6: 3802 7: 3800 8: 3807 bogomips: 23968
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 avx512_bitalg avx512_vbmi2
    avx512_vnni avx512_vpopcntdq avx512bw avx512cd avx512dq avx512f
    avx512ifma avx512vbmi avx512vl bmi1 bmi2 bts clflush clflushopt cmov
    constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb
    ept ept_ad erms est f16c flexpriority flush_l1d fma fpu fsgsbase fsrm
    fxsr gfni ht hwp hwp_act_window hwp_epp hwp_notify hwp_pkg_req ibpb ibrs
    ibrs_enhanced ida intel_pt invpcid invpcid_single lahf_lm lm mca mce
    md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx ospke pae pat pbe
    pcid pclmulqdq pdcm pdpe1gb pebs pge pku pln pni popcnt pse pse36 pts
    rdpid rdrand rdseed rdtscp rep_good sdbg sep sgx sgx_lc sha_ni smap smep
    split_lock_detect ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm
    tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer tsc_known_freq umip vaes
    vme vmx vnmi vpclmulqdq vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves
    xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: Enhanced IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Iris Plus Graphics G7 vendor: Lenovo driver: i915 v: kernel
    arch: Gen-11 process: Intel 10nm built: 2019-21 ports: active: HDMI-A-1
    off: eDP-1 empty: none bus-ID: 00:02.0 chip-ID: 8086:8a52 class-ID: 0300
  Device-2: Syntek Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-5:4 chip-ID: 174f:118d class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 506x285mm (19.92x11.22")
    s-diag: 581mm (22.86")
  Monitor-1: HDMI-A-1 mapped: HDMI-1 pos: primary model: Samsung S24D330
    serial: <filter> built: 2019 res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2
    size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 note: disabled model: BOE Display 0x0812 built: 2018
    res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: Mesa Intel Iris Plus Graphics (ICL GT2) v: 4.6 Mesa
    22.1.7 direct render: Yes
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
    bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.65-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.57 running: yes
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:34f0 class-ID: 0280
  IF: wlp0s20f3 state: down mac: <filter>
  Device-2: TP-Link UE300 10/100/1000 LAN (ethernet mode) [Realtek RTL8153]
    type: USB driver: r8152 bus-ID: 1-9:5 chip-ID: 2357:0601 class-ID: 0000
    serial: <filter>
  IF: enp0s20f0u9 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB
    driver: btusb v: 0.8 bus-ID: 1-10:6 chip-ID: 8087:0aaa class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 476.94 GiB used: 24.54 GiB (5.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix
    model: HFM512GDHTNI-87A0B size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 11010C00 temp: 36.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 476.64 GiB size: 468.09 GiB (98.21%) used: 24.54 GiB
    (5.2%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: 1a215379-e21a-47c1-9171-67e1681ddbdf
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 312 KiB
    (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: NO_LABEL
    uuid: D3B1-36E9
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 12 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-1:2 info: EzKEY USB to PS2 Adaptor v1.09 type: Keyboard,Mouse
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 0518:0001 class-ID: 0301
  Device-2: 1-2:3 info: Logitech Wireless Receiver type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s
    power: 50mA chip-ID: 046d:c542 class-ID: 0301
  Device-3: 1-5:4 info: Syntek Integrated Camera type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 174f:118d class-ID: 0e02 serial: <filter>
  Device-4: 1-9:5 info: TP-Link UE300 10/100/1000 LAN (ethernet mode)
    [Realtek RTL8153] type: Network driver: r8152 interfaces: 1 rev: 2.1
    speed: 480 Mb/s power: 180mA chip-ID: 2357:0601 class-ID: 0000
    serial: <filter>
  Device-5: 1-10:6 info: Intel Bluetooth 9460/9560 Jefferson Peak (JfP)
    type: Bluetooth driver: btusb interfaces: 2 rev: 2.0 speed: 12 Mb/s
    power: 100mA chip-ID: 8087:0aaa class-ID: e001
  Hub-2: 2-0:1 info: Super-speed hub ports: 6 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 62.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 261 Uptime: 20h 24m wakeups: 11 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: pm: pacman pkgs: 1328 libs: 356 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.21

Hi @teo8976,

In order for us, or anyone for that matter, to be able to provide assistance, more information is necessary. To that end, please see:

Hope you manage!


To provide terminal output, copy the text you wish to share, and paste it here, surrounded by three (3) backticks, a.k.a grave accents. Like this:


pasted text


This will just cause it to be rendered like this:

Portaest sed
cursus nisl nisi
hendrerit ac quis
tortor sit leo commodo.

Instead of like this:

Portaest sed elementum cursus nisl nisi hendrerit ac quis sit adipiscing tortor sit leo commodo.

Thereby improving legibility and making it much easier for those trying to be of assistance.

Please edit your post accordingly.

Thank you, I’ve added the output of inxi to the post.

This :point_up: needs to be sorted as well. Please see:

Also, please provide the output of:


I know but that has nothing to do with the touchpad not working, right?

lsusb                                                                                                                                  INT ✘ 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 005: ID 2357:0601 TP-Link UE300 10/100/1000 LAN (ethernet mode) [Realtek RTL8153]
Bus 001 Device 004: ID 174f:118d Syntek Integrated Camera
Bus 001 Device 003: ID 046d:c542 Logitech, Inc. Wireless Receiver
Bus 001 Device 006: ID 8087:0aaa Intel Corp. Bluetooth 9460/9560 Jefferson Peak (JfP)
Bus 001 Device 002: ID 0518:0001 EzKEY Corp. USB to PS2 Adaptor v1.09
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

No, that is why I asked for the additional information. But it’s always nice and good to have everything set properly.

Some more information inspired by whay I saw in other posts about the same issue:

sudo dmesg | egrep -i '(hid|i2c|syna|elan)'                                                                                            1|1 ✘ 
[sudo] password for teo: 
[    1.330342] hid: raw HID events driver (C) Jiri Kosina
[    2.522146] i2c i2c-0: 2/2 memory slots populated (from DMI)
[    2.522581] i2c i2c-0: Successfully instantiated SPD at 0x50
[    3.242572] hid-generic 0003:0518:0001.0001: input,hidraw0: USB HID v1.10 Keyboard [Plus More Enterprise LTD. USB-compliant keyboard] on usb-0000:00:14.0-1/input0
[    3.306684] hid-generic 0003:0518:0001.0002: input,hidraw1: USB HID v1.10 Mouse [Plus More Enterprise LTD. USB-compliant keyboard] on usb-0000:00:14.0-1/input1
[    3.308950] hid-generic 0003:046D:C542.0003: input,hidraw2: USB HID v1.11 Mouse [Logitech Wireless Receiver] on usb-0000:00:14.0-2/input0
[    3.308976] usbcore: registered new interface driver usbhid
[    3.308977] usbhid: USB HID core driver
[25130.835182] i2c_dev: i2c /dev entries driver

See my previous comment for lsusb.

[[SOLVED] Lenovo ideapad 3 15iil05 - Touchpad not working]

Is that safe? When googling I found several posts by people who tried that and were unable to boot afterwards.

Is it safe? I don’t know. Found a couple of answers offering the same solution which, in my opinion, makes it worth a try.

Would be easy to fix by reinstalling grub. Having either a manjaro usb or a second device ready is as essential as having backups.

1 Like

It worked!!

Thank you. I absolutely hate using the touchpad, but it’s nice to know I can use it in an emergency.

Now I have a few curiosities:

  • Is it known why/how exactly this fixes the issue?
  • are there any side effects that I may expect or should watch for?
  • Is this the “correct” fix, i.e. is it just what one needs to do if they have this touchpad or this hardware, or is this just a workaround to a bug, and in this case, whose bug is it?

Glad it worked.
Most of your questions can be answered by browsing the results of this search string:

Some are almost comically detailed: - Linux on Lenovo Ideapad 3
Still, always a good idea to know your hardware, especially the tricky bits.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.