Touchpad mouse flings to the bottom left on click

So ive started having an issue within the past week where the mouse will fling itself to the bottom left when clicking with the left button, usually highlighting or dragging something with it. it seems to happen almost every other click and i have no clue what is causing it or how to fix it

How to increase your chances of solving your issue:

Please provide Information:

upon closer inspection, it seems that its caused by the x11 gestures extension and touchegg, but im not too sure for now, i have disabled x11 gestures and restarted the gnome shell and im currently waiting for it to happen again. as for the system infomation bit, while yes i know thats helpful, its not always needed for certain cases, ive seen others have a similar issue that always has the inxi info but it just never explains anything and doesnt help, but in case im wrong

System:
  Kernel: 5.16.2-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    Desktop: GNOME 41.3 Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X570ZD_K570ZD
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: X570ZD v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X570ZD.312 date: 02/25/2020
Battery:
  ID-1: BAT0 charge: 28.9 Wh (73.4%) condition: 39.4/48.1 Wh (82.0%)
    volts: 11.7 min: 11.7 model: ASUSTeK ASUS Battery status: Charging
CPU:
  Info: quad core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
    bits: 64 type: MT MCP arch: Zen rev: 0 cache: L1: 384 KiB L2: 2 MiB
    L3: 4 MiB
  Speed (MHz): avg: 1393 high: 1445 min/max: 1600/2000 boost: enabled
    cores: 1: 1389 2: 1393 3: 1373 4: 1435 5: 1370 6: 1372 7: 1370 8: 1445
    bogomips: 31952
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Graphics:
  Device-1: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: ASUSTeK
    driver: nvidia v: 495.46 bus-ID: 01:00.0
  Device-2: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series] vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 05:00.0
  Device-3: IMC Networks USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
    bus-ID: 3-2.2:4
  Display: x11 server: X.org 1.21.1.3 driver: loaded: modesetting,nvidia
    unloaded: nouveau resolution: <missing: xdpyinfo>
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.44.0
    5.16.2-1-MANJARO LLVM 13.0.0)
    v: 4.6 Mesa 21.3.4 direct render: Yes
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
    v: kernel bus-ID: 05:00.1
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
    v: kernel bus-ID: 05:00.6
  Sound Server-1: ALSA v: k5.16.2-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.20 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.43 running: yes
Network:
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter vendor: AzureWave
    driver: rtw_8822be v: N/A port: e000 bus-ID: 03:00.0
  IF: wlp3s0 state: up mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel port: d000 bus-ID: 04:00.0
  IF: enp4s0 state: down mac: <filter>
Bluetooth:
  Device-1: IMC Networks Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-2.1:3
  Report: hciconfig ID: hci0 rfk-id: 0 state: down
    bt-service: enabled,running rfk-block: hardware: no software: yes
    address: <filter>
Drives:
  Local Storage: total: 387.53 GiB used: 212.82 GiB (54.9%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-00000
    size: 238.47 GiB temp: 34.9 C
  ID-2: /dev/sda vendor: Hitachi model: HTS543216A7A384 size: 149.05 GiB
Partition:
  ID-1: / size: 39.11 GiB used: 32.12 GiB (82.1%) fs: ext4
    dev: /dev/nvme0n1p2
  ID-2: /boot/efi size: 512 MiB used: 288 KiB (0.1%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 188.35 GiB used: 103.75 GiB (55.1%) fs: ext4
    dev: /dev/nvme0n1p4
Swap:
  ID-1: swap-1 type: partition size: 5.57 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p3
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A gpu: amdgpu temp: 47.0 C
  Fan Speeds (RPM): cpu: 2200
Info:
  Processes: 316 Uptime: 4h 26m Memory: 6.79 GiB used: 3.39 GiB (50.0%)
  Init: systemd Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1639
  Shell: Zsh v: 5.8 inxi: 3.3.12

Just happened again, so im not sure what it is at this point, for all i know its just an issue with some manjaro driver or something

@Lillie This reply won’t solve your problem, but might point you in a better direction …

I’ve had similar issues (albeit on an older MacBookPro that I’m now happily dual-booting with Manjaro) where the touchpad cursor would fly all over the place and “do it’s own thing” - including clicking on various menu choices. :roll_eyes:

After much research and trial and error I concluded it was a hardware thing - not a software (or operating system) thing. At least this got me heading in the right direction.

In your case, your ASUS laptop from 2020 vintage seems quite a bit too young to begin to show such malfunctions. Have you checked out ASUS support and/or forums to see if other owners are having related issues?

Yes that is true, but you only know afterwards.

Please have a look at: Trying to modify /etc/fstab getting save error - #55 by omano to see why asking for information ist needed
:footprints:

im not too sure what would the issue hardware wise outside a bad connection, but i havent open this laptop in months, but its actually from 2018 and i dont have warranty or anything as im not the original owner. as for contacting asus, im not sure whether or not they would just say for me to use windows or try updating a bios. At some point i may test if it happens in the bios (since i cant afford to install windows on this just to test a mouse issue)

1 Like

Boot a Hiren Boot CD, or a Windows installation USB/disk, and you can try Windows without installing it.

Ah, sorry - I googled the model and it came up 2020, not 2018. At 4 yrs old and second hand, it’s a little more likely what you’re describing is a misbehaving piece of hardware. The contacts within trackpads can get persnickety over time.

A few quick thoughts:

1- Have you got any other operating systems on this laptop? If so, you might see if they produce the same result - indicating it’s hardware, not software.

2- You might buy a cheap USB-trackpad and connect it to see if it misbehaves, too. If not, it would point to your native trackpad being the culprit, since the same pointer instructions would be sent to the software/operating system through either input device.

Best wishes.

How to boot from USB into live Manjaro (for repair):

You may try an other DE like XFCE to test this without changing anything on your install

Tried this and there were no issues whatsoever, so im lead to believe its a software issue. but im not entirely sure what it could be outside something in gnome or a driver

Try a LTS kernel like 5.15 or 5.10.

https://wiki.manjaro.org/index.php/Manjaro_Kernels/en

Neither 5.15 or 5.10 change anything

Did you try to boot an ISO with the same desktop to see if the live environment has the same behavior?

Also you can try to create a new user on your current system, and login with the new user to see if the new user has the issue.

If both of the above confirm no issue, then the issue is probably a misconfiguration somewhere for your current user and/or system.

I know that it started at some point a week or so ago and the mouse will sometimes change how it moves, but im not sure what is causing it, im wondering if its just a gnome 41 bug

Takes one minute and will get you a starting point of troubleshooting.

added a new user and no issue to speak of, and upon switching back to my user it very clearly shows that the mouse has an issue in software as it is being perceived differently, and is more of a sluggish smoothed movement versus a precise quick one

So if a new user doesn’t have any issue (you could try again to make sure) then the issue is probably is some configuration file in your user folder or some customization to the desktop. I don’t know GNOME at all but to me all the tests you have done seem to indicate that (different OS no issue, different kernels same issue, different user no issue).

If you don’t care about your desktop settings you may simply move your files to the new user and call it a day. You will need to reconfigure the desktop to your liking, and maybe install some customization you did like GNOME extensions (do everything in steps in case you stumble again on the issue, you may have a clue what caused it, don’t do everything at once to speed up the process, do changes one by one, maybe reboot in between).

If you want to keep everything in your user configuration, then you’ll have to dig deeper and find what’s wrong in the desktop configuration, what is conflicting, what is broken (application, extension, and so on…) or whatever the issue is.

i made this topic to see if someone else has seen this and knows a quick solution so i dont have to migrate everything, but i guess its just a weird quirk or bug that isnt common in gnome 4x, maybe ill try a different DE and see if its just a gnome thing

did a quick try with kde and it still persists, so its not the DE, its some config somewhere, but that doesnt make any sense as ive never touch mouse settings after the initial setup. So my guess is that somewhere, something got messed up or broken