Thinkpad x1c8 Pulseaudio

Hello, any thinkpad user? i have a thinkpad x1 carbon gen8 and it is well known that this model come out of the box with sound issues in linux, i’m new at this so its a little difficult to me to understand all the documentation about this, so i want to know if any manjaro thinkpad user has solved this thing already.
first i installed sof-firmware and my sound card was finally detected, but i still need to deal with the bad sound quality, as not all the channels are enabled.

also one of the options to solve this is to use the development version of PulseAudio14, which is PulseAudio13.99, available on the aur repositories, i tried to install this version via the manjaro software manager to automatically uninstall the pulseaudio13 version installed by default, which is part of the official repos, but it shows me the following messages and warnings

could not satisfy dependencies:

  • removing libao breaks dependency ‘libao’ required by cdrdao,
  • if possible, remove cdrdao and retry
  • removing fluidsynth breaks dependency ‘fluidsynth’ required by gst-plugins-bad,
  • if possible, remove gst-plugins-bad and retry
  • removing fluidsynth breaks dependency ‘fluidsynth=2.1.5’ required by lib32-fluidsynth,
  • if possible, remove lib32-fluidsynth and retry
  • removing fluidsynth breaks dependency ‘fluidsynth’ required by manjaro-pulse,
  • if possible, remove manjaro-pulse and retry

and then the manager offers me in the summary to remove fluidsynth, libao and mdp as their dependencies are broken if libpulse is removed during the process, i dont know if removing this packages will harm my system, and if intsalling pulseaudio 13.99 manually in the terminal is a valid alternative, hope somebody can help me

PulseAudio v13.99 is now also available in Manjaro testing branch

If you change to testing branch and update system, PulseAudio will update to v13.99 without need to remove packages

see this previous discussion - Problems with audio on laptop

1 Like

i’m really new at this lol, can i only update pulseaudio that way? i’ll have to update the whole system? will i be subject to other kind of errors?
i have also been trying to also a kernel error with acpi, i have tried kernels from 5.4-5.9 and all of them have the same error, i’m a little bit afraid of not being able to solve that thing that may seem more serious

Hey i updated the whole system to the testing branch and pulseaudio seems to work better but i can no longer connect to wifi LOL
In the bottom bar says “limited connectivity” and if i open too much things, my computer freezes for like 5 seconds, how do i revert all this thing while keeping pulseaudio, also kde 5.2 is great but i think im risking stabillity, also i need to connect to the internet to work :cry::cry::cry:

The previous generation of this laptop needed PulseAudio v13.99 to get the 4 speakers and 4 microphone array working
Lenovo ThinkPad X1 Carbon (Gen 7) - ArchWiki
and PulseAudio v13.99 was needed to get most other Intel laptops with digital microphone array working and this was the ‘lead case’

If you want to get back to stable branch packages, change branch back

sudo pacman-mirrors --api --set-branch stable

and refresh mirrors, but use an extra u in the update command to downgrade packages

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyuu

changing to testing branch is an easier option than installing pulseaudio-git that does not require other packages are removed

You can also remain on stable branch and future updates will have a new version of Pulseaudio
v14.0 might be released soon

This model also have this issue, and i tried to follow the instructions for pulse audio13 and apparently it does not work anymore, thats why i need pulseaudio 13.99, Is it possible to only install pulseaudio without having to update the whole system? I know it will be released soon but it is also unclear when.
Can i change to the test branch and only install that software?

Using testing branch and only allowing only PulseAudio to update is not a viable option for a rolling release distribution

It is possible to only install pulseaudio without having to update the whole system
by installing pulseaudio-git from AUR , that you attempted originally

Another user has confirmed this works if packages are removed and reinstalled

HP Envy - Sound does not work in Manjaro 20.1 PLASMA
I had first to remove libao, fluidsynth, lib32-fluidsynth and manjaro-pulse - after that I could install
pulseaudio-git - having installed pulseaudio-git I added libao, fluidsynth, lib32-fluidsynth and manjaro-pulse

PulseAudio v13.99 is included in latest stable branch update - [Stable Update] 2020-11-04

so changing branches is not needed - just update all stable packages