Problems with audio on laptop

Laptop - HP PROBOOK G7
On manjaro (and actually arch too) audio drivers doesn’t work correctly.
I tried to use sof-firmware (because on Mint 20 it works), and with it micro works, and sound actually goes somewhere (PulseAudio shows audio output on volume meter), but laptop doesn’t output any sound from speakers/headset.
I also tried to use dsp-git driver, with it sound output works cirrectly, but micro isn’t detected at all…

AUR package dsp-git is not a driver
GitHub - bmc0/dsp: An audio processing program with an interactive mode.
and it is usually used only for the PulseAudio Sink (output) not the Sources (inputs)
System Wide DSP (Equalizer)

Please post more information about your system

inxi -Fazy

and more information about the sinks and sources in PulseAudio

pacmd dump 
1 Like

The inxi -Fazy output is:

 Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A 
 parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
 root=UUID=9bc784e8-1372-4ed1-9280-b8455c4a6d0c rw quiet apparmor=1 
 security=apparmor udev.log_priority=3 
 Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
 dm: LightDM 1.30.0 Distro: Manjaro Linux 
 Type: Laptop System: HP product: HP ProBook 430 G7 v: N/A serial: <filter> 
 Chassis: type: 10 serial: <filter> 
 Mobo: HP model: 869B v: KBC Version 02.24.00 serial: <filter> UEFI: HP 
 v: S71 Ver. 01.03.01 date: 03/02/2020 
 ID-1: BAT0 charge: 44.9 Wh condition: 44.9/44.9 Wh (100%) volts: 13.0/11.6 
 model: Hewlett-Packard Primary type: Li-ion serial: <filter> status: Full 
 Topology: Quad Core model: Intel Core i5-10210U bits: 64 type: MT MCP 
 arch: Kaby Lake family: 6 model-id: 8E (142) stepping: C (12) microcode: D6 
 L2 cache: 6144 KiB 
 flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
 bogomips: 33615 
 Speed: 800 MHz min/max: 400/4200 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 
 4: 800 5: 800 6: 800 7: 800 8: 800 
 Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
 Type: l1tf status: Not affected 
 Type: mds status: Not affected 
 Type: meltdown status: Not affected 
 Type: spec_store_bypass 
 mitigation: Speculative Store Bypass disabled via prctl and seccomp 
 Type: spectre_v1 
 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
 Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
 Type: srbds mitigation: TSX disabled 
 Type: tsx_async_abort status: Not affected 
 Device-1: Intel UHD Graphics vendor: Hewlett-Packard driver: i915 v: kernel 
 bus ID: 00:02.0 chip ID: 8086:9b41 
 Device-2: Lite-On HP HD Camera type: USB driver: uvcvideo bus ID: 1-2:2 
 chip ID: 04ca:7095 
 Display: x11 server: X.Org 1.20.9 driver: intel unloaded: modesetting 
 alternate: fbdev,vesa display ID: :0.0 screens: 1 
 Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
 s-diag: 582mm (22.9") 
 Monitor-1: eDP1 res: 1920x1080 hz: 60 dpi: 168 size: 290x170mm (11.4x6.7") 
 diag: 336mm (13.2") 
 OpenGL: renderer: Mesa Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.1.8 
 direct render: Yes 
 Device-1: Intel vendor: Hewlett-Packard driver: sof-audio-pci 
 alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
 chip ID: 8086:02c8 
 Sound Server: ALSA v: k5.8.16-2-MANJARO 
 Device-1: Intel Wireless-AC 9462 driver: iwlwifi v: kernel port: 4000 
 bus ID: 00:14.3 chip ID: 8086:02f0 
 IF: wlp0s20f3 state: up mac: <filter> 
 Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
 vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 01:00.0 
 chip ID: 10ec:8168 
 IF: enp1s0 state: down mac: <filter> 
 Local Storage: total: 238.47 GiB used: 39.52 GiB (16.6%) 
 SMART Message: Required tool smartctl not installed. Check --recommends 
 ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLQ256HAJD-000H1 
 size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
 lanes: 4 serial: <filter> rev: HPS4NFXV scheme: GPT 
 ID-1: / raw size: 46.57 GiB size: 45.58 GiB (97.89%) used: 9.85 GiB (21.6%) 
 fs: ext4 dev: /dev/nvme0n1p2 
 ID-2: /home raw size: 182.12 GiB size: 178.26 GiB (97.88%) 
 used: 29.67 GiB (16.6%) fs: ext4 dev: /dev/nvme0n1p4 
 Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
 ID-1: swap-1 type: partition size: 9.31 GiB used: 0 KiB (0.0%) priority: -2 
 dev: /dev/nvme0n1p3 
 System Temperatures: cpu: 57.0 C mobo: 0.0 C 
 Fan Speeds (RPM): N/A 
 Processes: 240 Uptime: 5h 14m Memory: 15.48 GiB used: 1.83 GiB (11.8%) 
 Init: systemd v: 246 Compilers: gcc: 10.2.0 clang: 10.0.1 Packages: 
 pacman: 1196 lib: 346 flatpak: 0 Shell: Bash v: 5.0.18 
 running in: xfce4-terminal inxi: 3.1.05 

The pacmd dump output is:

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="pci-0000_00_1f.3-platform-skl_hda_dsp_generic" card_name="alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-rescue-streams
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-x11-publish display=:0.0
load-module module-x11-xsmp display=:0.0 session_manager=local/vlad-probook:@/tmp/.ICE-unix/1182,unix/vlad-probook:/tmp/.ICE-unix/1182
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_5__sink 0x10000
set-sink-mute alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_5__sink no
suspend-sink alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_5__sink yes
set-sink-volume alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_4__sink 0xfecd
set-sink-mute alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_4__sink no
suspend-sink alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_4__sink yes
set-sink-volume alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_3__sink 0xffff
set-sink-mute alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_3__sink no
suspend-sink alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_3__sink yes
set-sink-volume alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink 0x10000
set-sink-mute alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink no
suspend-sink alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink yes

set-source-volume alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_5__sink.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_5__sink.monitor no
suspend-source alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_5__sink.monitor yes
set-source-volume alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_4__sink.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_4__sink.monitor no
suspend-source alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_4__sink.monitor yes
set-source-volume alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_3__sink.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_3__sink.monitor no
suspend-source alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_3__sink.monitor yes
set-source-volume alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink.monitor 0x10000
set-source-mute alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink.monitor no
suspend-source alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink.monitor yes
set-source-volume alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__source 0x10000
set-source-mute alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__source no
suspend-source alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__source yes
set-source-volume alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_6__source 0x10000
set-source-mute alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_6__source yes
suspend-source alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_6__source yes

set-card-profile alsa_card.pci-0000_00_1f.3-platform-skl_hda_dsp_generic HiFi

set-default-sink alsa_output.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp__sink
set-default-source alsa_input.pci-0000_00_1f.3-platform-skl_hda_dsp_generic.HiFi__hw_sofhdadsp_6__source

inxi data for the Audio device is showing a Chip ID: 8086:02c8 and should also be showing the name of this device as Comet Lake PCH so audio device may not be detected correctly
but system is trying to use the driver sof-audio-pci so sof-firmware package is installed and recognised

on Mint 20 it works

Mint 20 has a later version of PulseAudio (v13.99)
they are following Ubuntu 20.04 and using the development version of PulseAudio

Manjaro stable branch is still using the official release version of PulseAudio (v13.0) which does not have recent patches added for sof-firmware

PulseAudio v14 was expected to be released months ago but developers still have some problems to resolve - 14.0 · Milestones · PulseAudio / pulseaudio · GitLab
Manjaro team may not release the development to stable branch because it may cause problems for some users, but if your system was working on Mint it should also work on Manjaro if the later
version of PulseAudio is added

I suggest you switch to Testing branch to get the similar PulseAudio version as Mint

sudo pacman-mirrors --api --set-branch testing

and then refresh-mirrors and get updates

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

then reboot system

Oh, it really helped! Thanks a lot!
With PulseAudio v.13.99.2-13-g7f4d7 both microphone and headphones works nice.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.