[Stable Update] 2020-11-04 - Kernels, Nvidia 455.38, LibreOffice, Plasma5, Frameworks, Apps, Gnome 3.38, Deepin

Hello community,

Another stable branch update with some interesting updates for you!


Europe Shipping has started! You might get yours earliest this Friday. Not ordered one yet? They are still in stock!: Grab yours! #stayhome, #staysafe, #stayhealthy

  • Our Kernels got renewed. 5.8 is now marked EOL
  • We started development cylce of the upcoming LTS kernel 5.10
  • We pushed out a lot more of KDE-git packages
  • Nvidia is now at 455.38 incl. support for RTX 3070
  • More Deepin and PulseAudio updates
  • Qt 5.15.1 got a proper multi-monitor fix
  • Some Browsers got updated including Firefox 82.0.2)
  • Gnome is now at 3.38
  • More updates to KDE Software: KDE Apps 20.08.2, KDE Frameworks 5.75, Plasma 5.20
  • Mesa is now at 20.2.1
  • Pamac got another point-release with needed fixes
  • Calamares supports now Swap-files
  • VirtualBox is at 6.1.16
  • KODI is now at 18.9
  • AMDVLK brings new features with 2020.Q4.1
  • The second point-release of Plasma 5.20 got out
  • LibreOffice is now at 6.4.7 and 7.0.3
  • Wine is at 5.20

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Nibia 20.2 release candidate! KDE, XFCE and Gnome


Our current supported kernels

  • linux44 4.4.241
  • linux49 4.9.241
  • linux414 4.14.203
  • linux419 4.19.153
  • linux54 5.4.73
  • linux57 5.7.19 [EOL]
  • linux58 5.8.18 [EOL]
  • linux59 5.9.3
  • linux510 5.10-rc2
  • linux54-rt 5.4.69_rt39
  • linux56-rt 5.6.19_rt12
  • linux59-rt 5.9.1_rt19

Packages Changes (Mon Nov 2 08:30:01 CET 2020)

  • testing community x86_64: 893 new and 872 removed package(s)
  • testing core x86_64: 9 new and 9 removed package(s)
  • testing extra x86_64: 107 new and 107 removed package(s)
  • testing multilib x86_64: 6 new and 6 removed package(s)

A detailed changelog of all packages you may find here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

45 Likes

Known issues and solutions

For TL3s and up: This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

nvidia-450xx-utils and nvidia-440xx-utils are in conflict

Please click the ► at the beginning of this line to view this solution
  • If you get the following error message:

    resolving dependencies...
    looking for conflicting packages...
    :: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
    :: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils=440.100' required by linux58-nvidia-440xx
    

Warning: do not reboot until this procedure tells you to starting from the next step!

  • Please note the exact nVidia driver you have running by executing:

    mhwd --listinstalled
    
  • Please note the kernel(s) you’ve got installed and remove anything 440-related, including CUDA by executing:

    pamac remove nvidia-440xx-utils linuxZZ-nvidia-440xx cuda nvtop
    

    where ZZ is/are the kernel version(s) you’re running.

  • Repeat for all the kernel versions you have

    How do I know which kernel versions I have?
    • execute ls /boot/linux*
    • any nulber after linux before the - (minus sign) are the kernel(s) you have installed
  • If you would have any other old nVidia drivers that you don’t need any more because your card is supported by the 450 series get rid of them as well.

  • now install the same family of 450 driver you had for the 440 driver, by executing:

    mhwd --install pci Your450Family
    

    where Your450Family is obviously one of video-hybrid-amd-nvidia-440xx-prime OR video-nvidia-440xx that you noted above

  • And finally:

    sudo reboot
    

If this would not have solved your issue, please open a new issue here and state that you followed this procedure already.


Warning: directory permissions differ on /var/lib/dhcpcd/

followed by:

filesystem: 700 package: 755

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod 755 /var/lib/dhcpcd/
    
  • The explanation:
    The DHCP Daemon expects the security permissions to be 755 but your system is set to 700. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.


virtualbox NS_ERROR_FAILURE (0x80004005)

Please click the ► at the beginning of this line to view this solution
  • The solution:
  1. You need to add your user back into the virtualbox user group

    sudo usermod --append --groups vboxusers $USER
    

    (Change $USER to the correct user name if not for yourself)

  2. Upgrade the VirtualBox extension pack to the latest version by executing:

    pamac build virtualbox-ext-oracle
    

PAM and PAMBASE got updated, which might prevent you from login

Please click the ► at the beginning of this line to view more detailed information

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”


Bad font rendering after freetype2 upgrade

Please click the ► at the beginning of this line to view more detailed information

There were some changes in the freetype2 version 2.10.3 which enable subpixel rendering.
This might look ugly without enabling lcdfilter at the same time.

You can create a symlink in /etc/fonts/conf.d/ to enable “lcddefault” as filter.

sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/


Older Issues

Please click the ► at the beginning of this line to view the older issues

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable org.cups.cupsd.service
systemctl enable org.cups.cupsd.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

5 Likes

@philm: Thanks for the stable updates.

A question for you. When do you plan to release Manjaro Nibia 20.2 stable version ? In one or two weeks, or more ?

2 Likes

Much speed
Such snappy

2 Likes

Error:

error: failed to commit transaction (conflicting files)
libsynctex: /usr/include/synctex/synctex_parser.h exists in filesystem
libsynctex: /usr/include/synctex/synctex_parser_utils.h exists in filesystem
libsynctex: /usr/include/synctex/synctex_version.h exists in filesystem
libsynctex: /usr/lib/libsynctex.so exists in filesystem
libsynctex: /usr/lib/libsynctex.so.2 exists in filesystem
libsynctex: /usr/lib/libsynctex.so.2.0.0 exists in filesystem
libsynctex: /usr/lib/pkgconfig/synctex.pc exists in filesystem
libsynctex: /usr/share/man/man1/synctex.1.gz exists in filesystem
libsynctex: /usr/share/man/man5/synctex.5.gz exists in filesystem
Errors occurred, no packages were upgraded.

Fix:
sudo pacman -Syyu --overwrite '*'

5 Likes

I just used powerpill to perform this update as it was really huge and now I see that after this Stable update that powerpill has been dropped from the Manjaro repositories.

Is it safe to upgrade to the powerpill version in the AUR?

2 Likes

Before I update, I have a question regarding the kernel since 5.8 is now EOL. So what are we Nvidia users are supposed to do now? Has the Nvidia support been fixed in 5.9, or is it still broken because of the politics and we have currently no supported kernel newer than 5.4?

5 Likes

I’m running Manjaro GNOME on a Lenovo ThinkPad T14s (Intel model) and after this update my audio stopped working. Specifically, no audio devices (neither input nor output) were listed in the GNOME audio settings menu and the audio icon failed to appear in the status bar at the top of the screen.

Upon closer inspection, it seems that pulseaudio is no longer being launched when GNOME starts. Launching pulseaudio subsequently in a terminal window has the desired effect of enabling sound, after which all my audio devices are visible in the GNOME settings panel. However, I’m unsure as to why it’s not starting automatically and welcome fixes or suggestions on how to re-enable the desired/expected behavior.

One other potentially relevant detail: Audio on this model laptop relies on the sof-firmware package.

Edit: Fix was simple:

$ systemctl --user enable pulseaudio.socket
$ systemctl --user enable pulseaudio.service

Voila! Sound is fixed.

7 Likes

Thanks for the update. At last.

3 Likes

Yes, I removed it. Xyne designed it for reflector which we don’t use. I tested the new version and it did not seem viable to keep it. Also, pacman-mirrors does not support Rsync.

3 Likes

The update was seamless, but after the update all my desktop effects are stopped, I am on Manjaro KDE, with blur, translucent desktop effects turned on, but after this update, every desktop effect stopped working.
I am using Intel 620U GPU. Witn intel-media-driver as gpu driver. Do I need to some thing else ?

EDIT: I found that the compositor was disabled, and then figured out kwinft (I was using it instead of Kwin) is breaking the opengl (both 3.1 and 2), I reverted back to Kwin now it is working.

Regards,
Sparsa

2 Likes

The update went fine on three computers:
1 * KDE and 2 * XFCE.

I had to reboot KDE installation with “reboot” on console.

This is caused by the Nvidia graphics driver.

1 Like

Another good update from manjaro team…working fine in my manjaro gnome…ram usage has been improved …though its much higher than kde…but does not matter to me…

1 Like

All went fine on my main machine via TYY update, GNOME, 5.4 Kernel and NVIDIA 440.

I got this warning message tho:

Warning: gnome-wallpapers: local (20201023-1) is newer than community (20201020-1)

I do not switch branches on my main machine. As an observation wine 5.20-1 does not seem to support ESYNC.

Keep up the good work!

1 Like

Also the RC is not uploaded yet ?

1 Like

Small update:

computer with XFCE and kernel 5.8.18 does not want to boot to GUI (graphical login) anymore.

I did a boot and reboot of the computer and now this problem does not occur anymore. ???

2 Likes

Pretty big 1.5GB update, updated via TTY, no issues. Kernel 5.9, Cinnamon DE, Intel video.

1 Like

Received several update errors for global npm modules, along the line of
npm: /usr/lib/node_modules/npm/node_modules/cacache/node_modules/mississippi/node_modules/concat-stream/node_modules/typedarray/.travis.yml exists in filesystem

Sorted by first explicitly forcing updates for npm using sudo pacman -S npm --overwrite='*' and retrying system updates again.

2 Likes

Super smooth update. The Gnome flavor looks and feels better than ever :heart:

2 Likes

If you look at the announcement post and the following one listing known issues, this time you do not have the gigantic message telling you “nvidia 455.28 is incompatible with linux >= 5.9” so it is OK to assume that either they removed it by mistake, or that there is no more issue. Spoiler alert: there is no more issue :stuck_out_tongue_winking_eye:

No official news about it but multiple users confirmed it on the Testing branch thread, and I myself switched to kernel 5.9 with Nvidia 455 and can still play games like before so it seems to work. Tested quickly NVENC with OBS, it works. Safe to assume everything works at that point.

4 Likes