HP Envy - Sound does not work in Manjaro 20.1 PLASMA


I am now using Manjaro for over 2 years and I love it - until now I had no noteworthy trouble with the hardware detection, particularly when I installed the last time Manjaro on the device I installed it today. This time it is a little bit different, there are some “problems” I will focus on in the next few days (WLAN-Password, graphics) but one issue I need to get solved today - that is the sound… I tried some tipps mentioned here in the forum, but until now nothing worked.

The problem:
There are as far as I can see / assess that no error-messages or something in that way - I just don’t get any sounds (neither system sounds nor sounds of videos / audios / etc.).

What a little bit “annoying” is, that Manjaro 19 worked everything out of the box on that device - I had nothing to configure concerning sound and so on. When I first booted the system from USB, I was not very “attentive”, so even there is no sound, but I ignored that - that means for me, that the hardware-detection does not work properly concerning my device.

The “setting”:

HP ENVY i7-10510u, Intel onboard sound.
Kernel: 5.8.6-1-MANJARO x86_64 (64bit)
    00:00.0 Host bridge: Intel Corporation Device 9b61 (rev 0c)
    00:02.0 VGA compatible controller: Intel Corporation UHD Graphics (rev 02)
    00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 0c)
    00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
    00:12.0 Signal processing controller: Intel Corporation Comet Lake Thermal Subsytem
    00:13.0 Serial controller: Intel Corporation Comet Lake Integrated Sensor Solution
    00:14.0 USB controller: Intel Corporation Device 02ed
    00:14.2 RAM memory: Intel Corporation Device 02ef
    00:14.3 Network controller: Intel Corporation Wireless-AC 9462
    00:15.0 Serial bus controller [0c80]: Intel Corporation Serial IO I2C Host Controller
    00:15.1 Serial bus controller [0c80]: Intel Corporation Comet Lake Serial IO I2C Host Controller
    00:16.0 Communication controller: Intel Corporation Comet Lake Management Engine Interface
    00:17.0 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode]
    00:1c.0 PCI bridge: Intel Corporation Device 02b8 (rev f0)
    00:1c.4 PCI bridge: Intel Corporation Device 02bc (rev f0)
    00:1d.0 PCI bridge: Intel Corporation Device 02b0 (rev f0)
    00:1d.4 PCI bridge: Intel Corporation Device 02b4 (rev f0)
    00:1f.0 ISA bridge: Intel Corporation Device 0284
    00:1f.3 Multimedia audio controller: Intel Corporation Device 02c8
    00:1f.4 SMBus: Intel Corporation Device 02a3
    00:1f.5 Serial bus controller [0c80]: Intel Corporation Comet Lake SPI (flash) Controller
    02:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX250] (rev a1)
    03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
    04:00.0 Non-Volatile memory controller: Toshiba Corporation BG3 NVMe SSD Controller (rev 01)

inxi -Fza (just audio related output)
  Device-1: Intel vendor: Hewlett-Packard driver: sof-audio-pci 
  alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 
  chip ID: 8086:02c8 
  Sound Server: ALSA v: k5.8.6-1-MANJARO 

What I did until now based on discussions here in forum concerning similar “problems” with sound:

  1. sudo pacman -S sof-firmware alsa-ucm-conf
  2. blacklist snd_hda_intel + snd_soc_skl
  3. add load-module module-alsa-sink device=hw:0,0 channels=4
  4. add load-module module-alsa-source device=hw:0,6 channels=4

Many thanks for all help in that matter!

Kind regards,

Hi @all,

I switched back to kernel 5.4.6-1 and reversed my changes concerning blacklisting and also the module-alsa-sink / module-also-source - the sound works now.

What I am not sure of is, whether I will get other problems with the “older” kernel - we will see :wink:

Kind regards,


The changes mentioned in OP appear to relate to an older solution from Archwiki
Lenovo ThinkPad X1 Carbon (Gen 7) - ArchWiki

Steps 3 and 4 may not work on a HP Envy model laptop unless it has similar audio hardware with a 4 way speaker system and a 4-way digital array microphone

The best current solution for support of Intel SST digital microphone array is to install sof-firmware and pulseaudio-git from AUR. The development version of Pulseaudio (v13.99) has most of the bug fixes incorporated for Sound Open Firmware
(Pulseaudio v14.0 should have been released to get this working, but release of that version has been delayed)

Kernel v5.4 does not support sof-firmware for internal DMIC, but the internal microphone can be disabled so the rest of the audio system will work

If you do not need use of the internal microphone, suggest you stick with v5.4 kernel until Pulseaudio v14.0 is released

Hi Nikgnomic,

thanks a lot for your very helpful reply.

You are right, the microfone does not work - I didn’t check that because I rarely use the microfone - however, I would like to “repair” that - just to ensure that my understanding of your input is correct:

  • Kernel 5.4 will not work with both sound + microfone together.
  • Kernel 5.8 will work with sound and microfone provided the sound-matter in kernel 5.8 is repaired in pulseaudio (probably already repaired in current pulseaudio-git (v13.99) and probably will be repaired in pulseaudio v14).
  • If I want to have sound and microfone working together I can give kernel 5.8 together with pulseaudio-git (v13.99) a try.

Is the above correct?

Many thanks!

Kind regards,


1 Like

Hi Nikgnomic,

I gave it a try - kernel 5.8 together with pulseaudio-git (v13.99) made it - sound and microfone work now with kernel 5.8.

Many thanks for your support!

Kind regards,


P.S.: I had first to remove libao, fluidsynth, lib32-fluidsynth and manjaro-pulse - after that I could install pulseaudio-git - having installed pulseaudio-git I added libao, fluidsynth, lib32-fluidsynth and manjaro-pulse (seems to be a bug in the dependencies of pulseaudio-git).


Well done on working it out
A couple of new users have had problems with the dependencies before, so it is good to know they can be removed and reinstalled OK

This is the latest development version from Github and has more dependencies and conflicting packages than a normal release version

(I am surprised that jack2 is shown as a dependency and wondering if that will be required when v14.0 is released)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.