[Testing Update] 2022-12-19 - Qemu 7.2.0, Firefox 108.0.1, Linux Firmware, KDE-git, Haskell, Python

Hello community,

Another testing branch update with some usual package updates for you.

Recent News:

Notable Package Updates:

  • Firefox got renewed to 108.0.1
  • Qemu is at 7.2.0
  • Linux-Firmware got renewed
  • Usual KDE-git, Haskell and Python updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Info about GNOME 43

GNOME 43 is here! :partying_face:

New in Manjaro GNOME:

Lonely leftover orphan packages that have been removed from the Arch / Manjaro repositories:

  • adwaita-maia
  • dynamic-wallpaper-editor
  • firefox-gnome-theme-maia
  • gtkhash-nautilus
    (Not compatible with Nautilus 43)
  • manjaro-dynamic-wallpaper
  • manjaro-gdm-tweak
  • nautilus-terminal
    (Not compatible with Nautilus 43 & EOL)

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux419 4.19.269
  • linux54 5.4.227
  • linux510 5.10.159
  • linux515 5.15.83
  • linux60 6.0.13
  • linux61 6.1.0
  • linux515-rt 5.15.79_rt54
  • linux60-rt 6.0.5_rt14

Package changes ( Mon Dec 19 01:07:55 CET 2022 )

  • testing community x86_64: 749 new and 743 removed package(s)
  • testing core x86_64: 10 new and 10 removed package(s)
  • testing extra x86_64: 125 new and 225 removed package(s)
  • testing kde-unstable x86_64: 187 new and 187 removed package(s)
  • testing multilib x86_64: 3 new and 3 removed package(s)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

4 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-12-19

KDE Wayland sometimes hangs with mesa 22.3.1 and AMD GPU

2022-12-16

dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

So far XFCE Classic project hasn’t updated yet to 4.18 series. We pushed 4.17.0 version of the package, but don’t know if that helps in that situation. It is recommended to install the regular libxfce4ui package to avoid issues and comment on this issue: libxfce4ui 4.18.0 released · Issue #15 · Xfce-Classic/libxfce4ui-nocsd · GitHub

2022-12-04

python-cairo 1.23.0-2 update requires manual intervention

The python-cairo package prior to version 1.23.0-2 was missing the compiled python module. This has been fixed in 1.23.0-2, so the upgrade will need to overwrite the untracked pyc file that was created. If you receive this error

python-cairo: /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/\*

to perform the upgrade.

2022-11-08

Pop Shell issues with Xorg session with Mutter 43.1 (fixed with mutter 43.1-1.0)

Gnome 43 (X11) GTK4 windows failed to render · Issue #1541 · pop-os/shell · GitHub

Windows not updated after non-interactive resize on X11 (#6054) · Issues · GNOME / gnome-shell · GitLab

2022-10-28

signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.

2022-10-27

Kernel 6.1-rc# might break backlight control on old/weird laptops

2022-10-18

Firefox 106.0 may have issues with screen sharing on GNOME with Wayland

2022-09-23

Nvidia 3060RTX cards may have issues with the 515.76 driver (fixed with 520.56.06)
Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported

2022-08-27

Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.

2022-08-23

electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

Release electron v19.0.0 · electron/electron · GitHub

2022-08-12

element-desktop dependency error (fixed with 1.11.4)
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rebuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su

2022-08-04

Glibc 2.36 update will break EasyAntiCheat within Proton (should be fixed with glibc 2.36-2)

Temporary workaround for now is to use the flatpak version of steam:

sudo pacman -S flatpak --needed --noconfirm
sudo flatpak install com.valvesoftware.Steam -y

You can use flatseal (another flatpak app) to grant it access to your existing game library so you don’t have to re-download your games (add the game library install path under “Other files” under “Filesystem”).

sudo flatpak install com.github.tchx84.Flatseal -y

For advanced users (not recommended by us): patched glibc and lib32-glibc are available here. They remove the commit that broke EAC.

2022-07-27

Fixed: Pamac shows archlinux-keyring (20220713-2) and manjaro-keyring (20220514-2) as orphans
sudo pacman -D --asexplicit archlinux-keyring manjaro-keyring

Resolved: w/ base 3-2 Revert changes:

sudo pacman -D --asdeps archlinux-keyring manjaro-keyring

2022-07-16

wxWidgets 3.2 update may need manual intervention

Packages have been renamed from wxgtk- to wxwidgets-. The GTK2 frontend is no longer provided. If you have wxgtk2 installed, the upgrade will fail with:

In such case, uninstall wxgtk2 first and then proceed with the upgrade.

2022-07-13

Linux518: could not insert 'amd_pstate': No such device

With Kernel 5.18.11 there was added a regression to AMD P-State driver preventing it from loading.

2022-07-08

Wireplumber 0.4.11 may crash for GDM users

Currently there is an issue with 0.4.11 and GDM crashing on boot-up. More in the upstream bugtracker issue: wireplumber segfault: system boot and could see in my dmesg (#305) · Issues · PipeWire / wireplumber · GitLab

2022-06-07

Locale file changes

C.UTF8 locale is now included in glibc:

Credits @diabonas for this change. Systemd wants us to include C.UTF8 by default and it seems the locale may be in included by glibc upstream in the future. To fix building and avoid nasty fixing in devtools, we include the locale in the package. See systemd/systemd#23252 (comment) FS#74864 : [systemd] >= 251 breaks devtools' locale

There is a pacsave for /etc/locale.conf as it has been removed from the filesystem package.

UPDATE: With filesystem 2022.06.08-2, it will automatically restore /etc/locale.conf if it did not already exist.
Uploading: image.png…

There is a pacnew for /etc/locale.gen. Please review it and regenerate your locale if necessary.

With this update manjaro-gnome-settings is orphaned.

> pacman -Qdt
manjaro-gnome-settings 20221218-2

Looking at the depenedencies:

> pactree -d 1 manjaro-gnome-settings
manjaro-gnome-settings
├─adw-gtk-theme
├─manjaro-gnome-backgrounds
├─manjaro-base-skel
├─manjaro-gdm-branding
├─papirus-icon-theme
├─ttf-hack
└─xcursor-breeze

Looks to me like I need to mark this as explicitly installed.

P.S. The name of this package is a bit misleading, was expecting it to be the settings editor, a better name and description would be:

manjaro-gnome-config-and-branding

Custom setup files, scripts and assets for the 
Manjaro specific Linux look and feel.

or something like this.

had this issue as well, fixed it by restoring /etc/mkinitcpio.conf to the version from the snapshot from 2022-12-10 (before switching from stable to testing) and then regenerating the initramfs

1 Like

I am not affected by this issue. Possible reasons:
I do not use btrfs
My mkinitcpio.conf doesn’t lack some hooks, files or modules that yours might lack

I can not reproduce this issue when using Btrfs with encryption LUKS.

Do you use UEFI or Legacy boot?

See:

UEFI,
but I think that it was due to the testing-update from 2022-12-01 which had a pacnew for /etc/mkinitcpio.conf., which I applied using the pacnew.shscript specified there. But that doesn’t explain why it is still booting with snapshots until 2022-12-10, but not after.

Symptoms sound like an improper merge (forgot some HOOKS?) to me-

Sure it does: did you regenerate all initramfs after merging?
They probably were generated by a hook during the update still using your old (unmerged) /etc/mkinitcpio.conf.

As the one bringing it up from the beginning: Yes, it was HOOKS which we with encrypted root-partition should have had. To be precise, it was encrypt that was missing. After adding it again and doing mkinitcpio -P all worked. Now the only thing left is to see if the next update will replace /etc/mkinitcpio.conf again or if it now is solved.

Any “replacement” of /etc/mkinitcpio.conf would have been a user action as it’s marked as backup:

Just take care when merging pacnew files.

Under normal circumstances, configuration files are never replaced by force. The new configuration files are saved as .pacnew files, and users check and make the changes as needed. You might just have forgot to add needed hooks. Oops, oh well, it can happen to anybody.

But hey, glad that the mystery is finally solved.

Don’t use scripts blindly if you don’t know what those do …

On the wayland session of kde plasma, notifications now get stuck and sometimes pop up in their own window instead of a proper notification “bubble”. Anyone else experiencing this? (AMDGPU)

Does pressing the Meta/Window-key work to open KDE menu?
I noticed that it is blocked by something, when your mouse cursor is in some app’s window.

I don’t use the menu but I just added it to the panel and pressing Meta opens it, so works for me. Do you have the notification problem?

Yes, I can reproduce this issue on my two separated systems with KDE wayland (the second system uses native vanilla KDE theme).

  1. Issue:
    Try to run:
$ notify-send "test"

Then wait 1 sec without moving your mouse cursor. The notification popup, all widgets (with animations) and pressing the Meta-key are frozen or blocked by something or kwin Wayland.
When moving your mouse cursor outside the window of app or in the Desktop screen, they are unlocked and free.

  1. Issue:

Open any Steam game, try to press the Meta-key to minimize this game to the panel, but it does not work, I have to close Game manually.

I am sure it happens after some update.
Xorg has no issue.


Edit://

Solution:

:white_check_mark: Downgrade to mesa 22.2.3, it fixed the issue. :astonished:

The known issue: AMD GPU is affected. Intel GPU not.

1 Like

I’m getting the notification hang where the “countdown circle” only appears to move with mouse cursor movement. Also, volume buttons not reacting while in-game unless I Alt-Tab out of the game. amdgpu

Logging in takes longer, too. I once got up to make coffee after entering my password and came back to a black screen, only after moving my mouse did the UI finish displaying. This isn’t consistent.

If I set pamac to Allow Downgrading and downgrade whatever package (ie; perhaps, mesa), should updates to said package still appear when published? Thank you.

  1. Install downgrade
$ sudo pacman -S downgrade
  1. Run sudo downgrade mesa to select mesa version 22.2.4

  2. Reboot, done.

1 Like