[Testing Update] 2022-11-08 - Kernels, GNOME 43, OpenSSL 3.0, Firefox, Thunderbird, Mesa, KDE Gear 22.08.3, LibreOffice, LXQt 1.2.0

Hello community,

Another testing branch update with some usual package updates for you.

  • Most of our Kernels got updated
  • Systemd 252
  • OpenSSL 3.0
  • Firefox 106.0.5
  • Thunderbird 102.4.2
  • LXQt 1.2.0
  • Some KDE-git, Haskell and Python updates as usual

GNOME 43 is here! :partying_face:

New in Manjaro GNOME:

Lonely leftover orphan packages that have been removed from the Arch / Manjaro repositories:

  • adwaita-maia
  • dynamic-wallpaper-editor
  • firefox-gnome-theme-maia
  • gtkhash-nautilus
    (Not compatible with Nautilus 43)
  • manjaro-dynamic-wallpaper
  • manjaro-gdm-tweak
  • nautilus-terminal
    (Not compatible with Nautilus 43 & EOL)

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.264
  • linux54 5.4.223
  • linux510 5.10.153
  • linux515 5.15.77
  • linux519 5.19.17 [EOL]
  • linux60 6.0.7
  • linux61 6.1.0rc4
  • linux515-rt 5.15.76_rt53
  • linux60-rt 6.0.5_rt14

Package changes (Tue Nov 8 08:58:41 CET 2022)

  • testing community x86_64: 2237 new and 2201 removed package(s)
  • testing core x86_64: 66 new and 65 removed package(s)
  • testing extra x86_64: 1083 new and 1175 removed package(s)
  • testing kde-unstable x86_64: 407 new and 407 removed package(s)
  • testing multilib x86_64: 66 new and 67 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-11-08

GNOME: Pop Shell issues with Xorg session with Mutter 43.1

Gnome 43 (X11) GTK4 windows failed to render · Issue #1541 · pop-os/shell · GitHub


signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.


Kernel 6.1-rc# might break backlight control on old/weird laptops


Firefox 106.0 may have issues with screen sharing on GNOME with Wayland


Nvidia 3060RTX cards may have issues with the 515.76 driver (fixed with 520.56.06)
Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported


Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.


electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

Release electron v19.0.0 · electron/electron · GitHub


element-desktop dependency error (fixed with 1.11.4)
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rebuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su


Glibc 2.36 update will break EasyAntiCheat within Proton (should be fixed with glibc 2.36-2)

Temporary workaround for now is to use the flatpak version of steam:

sudo pacman -S flatpak --needed --noconfirm
sudo flatpak install com.valvesoftware.Steam -y

You can use flatseal (another flatpak app) to grant it access to your existing game library so you don’t have to re-download your games (add the game library install path under “Other files” under “Filesystem”).

sudo flatpak install com.github.tchx84.Flatseal -y

For advanced users (not recommended by us): patched glibc and lib32-glibc are available here. They remove the commit that broke EAC.


Fixed: Pamac shows archlinux-keyring (20220713-2) and manjaro-keyring (20220514-2) as orphans
sudo pacman -D --asexplicit archlinux-keyring manjaro-keyring

Resolved: w/ base 3-2 Revert changes:

sudo pacman -D --asdeps archlinux-keyring manjaro-keyring


wxWidgets 3.2 update may need manual intervention

Packages have been renamed from wxgtk- to wxwidgets-. The GTK2 frontend is no longer provided. If you have wxgtk2 installed, the upgrade will fail with:

In such case, uninstall wxgtk2 first and then proceed with the upgrade.


Linux518: could not insert 'amd_pstate': No such device

With Kernel 5.18.11 there was added a regression to AMD P-State driver preventing it from loading.


Wireplumber 0.4.11 may crash for GDM users

Currently there is an issue with 0.4.11 and GDM crashing on boot-up. More in the upstream bugtracker issue: https://gitlab.freedesktop.org/pipewire/wireplumber/-/issues/305


Locale file changes

C.UTF8 locale is now included in glibc:

Credits @diabonas for this change. Systemd wants us to include C.UTF8 by default and it seems the locale may be in included by glibc upstream in the future. To fix building and avoid nasty fixing in devtools, we include the locale in the package. See systemd/systemd#23252 (comment) FS#74864 : [systemd] >= 251 breaks devtools' locale

There is a pacsave for /etc/locale.conf as it has been removed from the filesystem package.

UPDATE: With filesystem 2022.06.08-2, it will automatically restore /etc/locale.conf if it did not already exist.

There is a pacnew for /etc/locale.gen. Please review it and regenerate your locale if necessary.

Running gem outdated or gem update results in:

ERROR:  While executing gem ... (Gem::Exception)
    OpenSSL is not available. Install OpenSSL and rebuild Ruby (preferred) or use non-HTTPS sources
	/usr/lib/ruby/3.0.0/rubygems/request.rb:47:in `configure_connection_for_https'
	/usr/lib/ruby/3.0.0/rubygems/request/https_pool.rb:6:in `setup_connection'
	/usr/lib/ruby/3.0.0/rubygems/request/http_pool.rb:39:in `make_connection'
	/usr/lib/ruby/3.0.0/rubygems/request/http_pool.rb:20:in `checkout'
	/usr/lib/ruby/3.0.0/rubygems/request.rb:129:in `connection_for'
	/usr/lib/ruby/3.0.0/rubygems/request.rb:188:in `perform_request'
	/usr/lib/ruby/3.0.0/rubygems/request.rb:154:in `fetch'
	/usr/lib/ruby/3.0.0/rubygems/remote_fetcher.rb:309:in `request'
	/usr/lib/ruby/3.0.0/rubygems/remote_fetcher.rb:209:in `fetch_http'
	/usr/lib/ruby/3.0.0/rubygems/remote_fetcher.rb:248:in `fetch_path'
	/usr/lib/ruby/3.0.0/rubygems/remote_fetcher.rb:285:in `cache_update_path'
	/usr/lib/ruby/3.0.0/rubygems/source.rb:187:in `load_specs'
	/usr/lib/ruby/3.0.0/rubygems/spec_fetcher.rb:256:in `tuples_for'
	/usr/lib/ruby/3.0.0/rubygems/spec_fetcher.rb:222:in `block in available_specs'
	/usr/lib/ruby/3.0.0/rubygems/source_list.rb:94:in `each'
	/usr/lib/ruby/3.0.0/rubygems/source_list.rb:94:in `each_source'
	/usr/lib/ruby/3.0.0/rubygems/spec_fetcher.rb:216:in `available_specs'
	/usr/lib/ruby/3.0.0/rubygems/spec_fetcher.rb:90:in `search_for_dependency'
	/usr/lib/ruby/3.0.0/rubygems/commands/update_command.rb:142:in `fetch_remote_gems'
	/usr/lib/ruby/3.0.0/rubygems/commands/update_command.rb:167:in `highest_remote_name_tuple'
	/usr/lib/ruby/3.0.0/rubygems/commands/update_command.rb:307:in `block in which_to_update'
	/usr/lib/ruby/3.0.0/rubygems/commands/update_command.rb:303:in `each'
	/usr/lib/ruby/3.0.0/rubygems/commands/update_command.rb:303:in `which_to_update'
	/usr/lib/ruby/3.0.0/rubygems/commands/update_command.rb:102:in `execute'
	/usr/lib/ruby/3.0.0/rubygems/command.rb:323:in `invoke_with_build_args'
	/usr/lib/ruby/3.0.0/rubygems/command_manager.rb:185:in `process_args'
	/usr/lib/ruby/3.0.0/rubygems/command_manager.rb:149:in `run'
	/usr/lib/ruby/3.0.0/rubygems/gem_runner.rb:51:in `run'
	/usr/bin/gem:13:in `<main>'

I’ve tried re-installing openssl and ruby / rubygems but that did not help.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Maybe your ruby install needs openssl-1.1?

Update error : failed to satisfy dependencies:

  • cannot satisfy the “openssl-1.1” dependency, which the **** package needs
1 Like

Maybe your ruby install needs openssl-1.1?

Maybe. But my ruby is the default ruby package from the official community repo. And it only says:

Depends On : gdbm openssl libffi libyaml libxcrypt gmp zlib rubygems ruby-stdlib ruby-bundledgems

Clicking on openssl in pamac links to the new openssl 3.0.7-2.

If that ruby package were incompatible with openssl 3 I would have expected pacman to check that before upgrading openssl.

Is downgrading to openssl 1.1 possible just by uninstalling 3.0.7-2 and re-installing 1.1.1.s-2? There’s a whole bunch of other core packages that seem to depend on openssl.

You don’t even need to uninstall openssl 3. Just install openssl-1.1 and it should install besides it.

This is a package we get from Arch and it has been flagged out of date since July. So I would imagine that this issue is also present on Arch installs.

1 Like

Just install openssl-1.1 and it should install besides it.

Thanks. I did not know that was possible. It seems to have worked.

It would be nice if there was some kind of warning before the upgrade. For example, pacman asked if I wanted to replace some pulseaudio lib with a pipewire lib with this upgrade.

Something similar for openssl would be helpful, I think. Or maybe add it to the known issues section.

The package manager cannot take un-updated packages into account.

My bet is that if ruby gets updated, it will get it’s dependency corrected.

Cannot sync calendar with nextcloud after upgrading to gnome 43

Do not push it into the stable branch, it would broke many workstations when using Gnome and nextcloud.

Kernel 6.0.x still has the issue with hibernation and suspend when using AMD GPU. But the path would fix Kernel 6.1.x.rc only.

My system hang on starting service PCR TPM2 Barrier (Initialization), y have to reboot with the installation disk to move the service file /usr/lib/systemd/systemd-pcrphase to another location to be able to boot.

This look like the problem but I don’t know for sure: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=1023515

1 Like

Just upgraded and mostly ok except it no longer wants to connect to the Wi-Fi network I always use. After I’ve launched Gnome Settings and go to the Wi-Fi section, then click the network (its name or the cog icon) to try and re-configure that connection (under Visible Networks), the Gnome settings application crashes with no error message displayed.

I found this the logs right after it crashes and I think it’s related but am not too sure what to try next to troubleshoot this.

settings object created with schema 'org.gnome.nm-applet.eap' and path '/org/gnome/nm-applet/eap/d0c3b23d-de76-4e4e-abb7-075fef1de7c5/', but path '/org/gnome/nm-applet/eap/' is specified by schema

minor update… I removed (“forgot”) the connection, started again, adding it anew, and the settings tool no longer crashed however it still doesn’t connect and I think it’s the same issue as this person reported.

issue appears to be fixed with last updates.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

1 Like

For real, removing tpm2-abrmd resolved the issue. I did it before updating systemd to 252 and on next boot there was no indefinite “Starting TPM2 PCR Barrier” message of the respective service preventing system from booting.

1 Like

Well my system is not using systemd-boot nor grub, is starting with a Unified kernel image on EFI. I will try to removing tpm2-abrmd package and enabling the pcrphase to test it.

Confirmed after removing the above package the system boot now.

On pamac update I get many ruby warnings. Last time an update on ruby before the system update solved this, but this time I still get warnings.

And pamac wants to download 2.1 GB of updates. Is this right? I update my system daily.

This update appears to have broken most of the Appearance settings for me…

Logs from running systemsettings5 from command line:

 "Error loading QML file.\n145: Type NewStuff.Action unavailable\n184: Type NewStuff.Page unavailable\n487: Type NewStuff.EntryDetails unavailable\n163: Type Kirigami.UrlButton unavailable\n21: Kirigami.LinkButton - Kirigami is neither a type nor a namespace\n"
qml: The item SubCategoryPage_QMLTYPE_113(0x55a998529150) is already in the PageRow


A post was split to a new topic: I am unable to connect to wifi on 802.1x profiles on KDE

Please check/reinstall packages

neither gdm or gnome-shell starts, oops crap is shown. Switched to lightdm/Cinnamon…

Is that still relevant for v252.1 release of Systemd? Also was it reported upstream? There are some TPM issues also reported for 251: systemd-cryptsetup times out (?) before TPM device is found · Issue #25099 · systemd/systemd · GitHub