[Unstable Update] 2022-10-31 - GNOME 43

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Unstable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!


Possible issues with Wayland and NVIDIA (fixed with Mutter 43.1)

FS#76368 - [gnome-shell] doesn’t display after upgrade to 43 / gstreamer related

Pop Shell issues with Xorg session with Mutter 43.1 (fixed with mutter 43.1-1.0)


Windows don't render correctly when using tiling extensions (#6054) · Issues · GNOME / gnome-shell · GitLab

1 Like

If someone test it on a Touchscreen Device , let me know if the bug with the OSK is fixed . I test 43 on Tumbleweed and Ubuntu 22.10 Beta and had the same bug : you can typ only one Number or symbol and it turned back for typing Letters . On Solus with xorg the same , so it isn’t a problem with Wayland . I use Gnome on a Tablet too and with this bug is typing my password not really comfortable .

greetings and thx for the great work on manjaro :slight_smile:

@Yochanan: Thanks.

Is there a way to have the terminal in nautilus without nautilus-terminal (for example via a gnome extension ) ?

Have you got an idea when gnome 43 will be available in the stable branch of Manjaro (2 weeks ?) ?

Looking forward to seeing manjaro theming back on Gnome. I really liked Manjaro color more than the default blue one.

Nautilus 43.01 - list-view - starred cannot be removed via dconf-editor.
The usual incompatuibilities with gnome-shell-extensions installed via “extensions.gnome.org”.

Just tested with an MS Surface Go 2, the keyboard behavior is still there. Not entirely sure this is a bug, but a change in how the OSK behaves in general. Might be useful to give feedback upstream.

Wayland freezes/crashes when I try to play video in fullscreen mode in browsers (Chrome and Firefox). Wayland also freezes when some apps enter fullscreen mode, e.g., gradience. Xorg works fine.

Update: Seems to be fixed by adding “options i915 enable_psr=0” to /etc/modprobe.d/20-intel.conf, following link

a whole hoard of packages rebuilt with OpenSSL fixes are incoming, 800+ packages currently in arch testing repos.

1 Like

Those would be result of the long awaited transition to openssl 3.0 branch (from openssl 1.1).


Careful, new systemd 252 may render your system unbootable. Some TPM -related service keeps trying to start indefinitely. This is on TPM 2 which supports SHA1 PCRs only + systemd-boot. Grub-controlled booting process with no Secure Boot on another machine worked fine.


Loading is stuck on “Starting TPM2 PCR Barrier…” – no idea what is that.
My setup is similar to yours but I use both systemd-based and udev-based unified images to boot, and generate them with sbupdate, not mkinitcpio.

This machine has a lot of firmware limitations that make it hard to use with new tech, for instance, all kernels starting from 5.19 fail to initialize TCTI context if booting with systemd-based image – this is why I usually boot using udev-based UKI.

I have no time to actively dig into it so I just downgraded for the time being as I’m busy migrating to a newer laptop which I hope would be a better fit for all recent shiny technologies built into systemd – not because of systemd itself, of course, but because I’ve just managed to work around another annoying bug that had been blocking me from using it before.

After updating I can no longer connect to my university’s PEAP WiFi. It just continuously asks for password and never connects.
Had a similar problem before with Fedora, which was solved thus: Changes/StrongCryptoSettings2 - Fedora Project Wiki
Might this current problem be related? Were cryptography settings changed on Manjaro?

1 Like

Pipewire audio backend support has been added to mpv. (Github)

Issue after update 15-Nov-2022: (journalctl)
pipewire[903]: mod.x11-bell: XOpenDisplay() failed
pipewire-media-session[904]: spa.bluez5: GetManagedObjects() failed: org.freedesktop.DBus.Error.NameHasNoOwner

did you withhold migration into wireplumber (pipewire-media-session->wireplumber)?

Yes, indeed, you are right… :sweat_smile:
Now I get one line instead:

pipewire[902]: mod.x11-bell: XOpenDisplay() failed

<==> Running Wayland…
<==> running xorg
same error - but audio working, so I will ignore the error :innocent:

systemd gnome-session-x11-services-ready.target: Job gnome-session-x11-services-ready.target/verify-active failed with result 'dependency'.
But which dependency???
something in connection with: gnome-session 43.0-1 @Yochanan

Moderator edit: Removed heftig’s email address. He’s not a member of this forum and can’t be tagged here

7 posts were split to a new topic: Pacman is trying to install youtube-dl

A post was split to a new topic: My current update list is a bit unusual

A post was split to a new topic: Pipewire-pulse.service not starting