[Testing Update] 2022-10-30 - Kernel, Firefox, Alsa, Haskell

Hello community,

Another testing branch update with some usual package updates for you. If the feedback is positive, we may snap it over to our stable branch …

  • Most of our Kernels got updated
  • Alsa is now at 1.2.8
  • Firefox got renewed to 106.0.2
  • Some KDE-git, Haskell and Python updates as usual

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.262
  • linux54 5.4.221
  • linux510 5.10.151
  • linux515 5.15.76
  • linux519 5.19.17 [EOL]
  • linux60 6.0.6
  • linux61 6.1.0rc2
  • linux515-rt 5.15.73_rt52
  • linux519-rt 5.19.0_rt10

Package changes (Sun Oct 30 09:15:00 CET 2022)

  • testing community x86_64: 451 new and 449 removed package(s)
  • testing core x86_64: 13 new and 13 removed package(s)
  • testing extra x86_64: 98 new and 195 removed package(s)
  • testing kde-unstable x86_64: 241 new and 241 removed package(s)
  • testing multilib x86_64: 5 new and 5 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-10-28

signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.


Kernel 6.1-rc# might break backlight control on old/weird laptops


Firefox 106.0 may have issues with screen sharing on GNOME with Wayland


Nvidia 3060RTX cards may have issues with the 515.76 driver (fixed with 520.56.06)
Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported


Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.


electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

Release electron v19.0.0 · electron/electron · GitHub


element-desktop dependency error (fixed with 1.11.4)
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rebuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su


Glibc 2.36 update will break EasyAntiCheat within Proton (should be fixed with glibc 2.36-2)

Temporary workaround for now is to use the flatpak version of steam:

sudo pacman -S flatpak --needed --noconfirm
sudo flatpak install com.valvesoftware.Steam -y

You can use flatseal (another flatpak app) to grant it access to your existing game library so you don’t have to re-download your games (add the game library install path under “Other files” under “Filesystem”).

sudo flatpak install com.github.tchx84.Flatseal -y

For advanced users (not recommended by us): patched glibc and lib32-glibc are available here. They remove the commit that broke EAC.


Fixed: Pamac shows archlinux-keyring (20220713-2) and manjaro-keyring (20220514-2) as orphans
sudo pacman -D --asexplicit archlinux-keyring manjaro-keyring

Resolved: w/ base 3-2 Revert changes:

sudo pacman -D --asdeps archlinux-keyring manjaro-keyring


wxWidgets 3.2 update may need manual intervention

Packages have been renamed from wxgtk- to wxwidgets-. The GTK2 frontend is no longer provided. If you have wxgtk2 installed, the upgrade will fail with:

In such case, uninstall wxgtk2 first and then proceed with the upgrade.


Linux518: could not insert 'amd_pstate': No such device

With Kernel 5.18.11 there was added a regression to AMD P-State driver preventing it from loading.


Wireplumber 0.4.11 may crash for GDM users

Currently there is an issue with 0.4.11 and GDM crashing on boot-up. More in the upstream bugtracker issue: wireplumber segfault: system boot and could see in my dmesg (#305) · Issues · PipeWire / wireplumber · GitLab


Locale file changes

C.UTF8 locale is now included in glibc:

Credits @diabonas for this change. Systemd wants us to include C.UTF8 by default and it seems the locale may be in included by glibc upstream in the future. To fix building and avoid nasty fixing in devtools, we include the locale in the package. See systemd/systemd#23252 (comment) FS#74864 : [systemd] >= 251 breaks devtools' locale

There is a pacsave for /etc/locale.conf as it has been removed from the filesystem package.

UPDATE: With filesystem 2022.06.08-2, it will automatically restore /etc/locale.conf if it did not already exist.

There is a pacnew for /etc/locale.gen. Please review it and regenerate your locale if necessary.

1 Like

Update went wonderfully.


Firefox keeps crashing when playing YouTube videos midway for me.

This is the video I’m trying to play: SPIDER-MAN REMASTERED All DLCs FULL Walkthrough - NO Commentary (PS5 4K UHD) - YouTube

After around 2 minutes (in 4K) FireFox crashes. What’s weird is that other 4K videos play fine for me.

I watched from a little before 2 minutes to after 3, no problem. i7-8700K, 6800XT, Kernel 6.0.6-1, KDE, Wayland. Tried running and watching journalctl -f to see if any errors pop up when it occurs?

Acer Spin 3 and 5 also updated no problem.

journalctl is for system service errors isn’t it? I tried running with log flag in Firefox, but I can’t seem to find where the issue is. Since this is the only video that is being affected, I guess something is wrong with codecs probably.


$ man journalctl

Hi! Given the difficulties many seemed to have faced with the move from Plasma 5.24.x to the 5.25.x series, I was wondering what the testing folks have been seeing/feeling about Plasma 5.26.2. I myself have had some strange problems with the 5.25 series. My favorite was the lockups I would get of the entire desktop when installing a new software package and then hitting the application menu to launch it. When the menu tried to refresh to add the new package, BLAMO!, the desktop would become non-responsive.

Anywho, just wondering how testing was coming along for 5.26.2. Thanks!

7 posts were split to a new topic: Difficulties getting the Steam client to start or return from gaming

memtest version 6.0 has been added ,
after update-grub , memtest does not appears on grub list

I assume you’re on EFI. Try to install memtest86±efi


it 's ok with memtest±efi ( all tests passed ) and reboot
it use only acpi cpufreq ( 3700Mhz & DDR4 -2166 )

Installed memtest86±efi 6.00-1 / sudo update-grub ==>

Found memtest86+ EFI image: /boot/memtest86+/memtest.efi
/usr/bin/grub-probe: Warnung: Unbekannter Gerätetyp nvme0n1.