[Testing Update] 2021-10-05 - Kernels, Mesa, Browsers, Python, UKUI, PHP, Thunderbird, Pipewire

Hello community,

Another testing branch update with some usual updates for you.

Don’t miss out on our new merch!

  • We updated our Kernels. Note that 5.13 series is marked EOL and 5.12 got removed!
  • Mesa is now at 21.2.3
  • Pipewire got renewed to 0.3.38
  • We updated browsers like Vivaldi, Brave and Firefox
  • Thunderbird is now at 91.1.2
  • Other regular upstream updates including Python

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.284
  • linux49 4.9.283
  • linux414 4.14.248
  • linux419 4.19.208
  • linux54 5.4.150
  • linux510 5.10.70
  • linux513 5.13.19 [EOL]
  • linux514 5.14.9
  • linux515 5.15-rc3
  • linux510-rt 5.10.52_rt47

Package Updates (Tue Oct 5 09:21:03 CEST 2021)

  • testing community x86_64: 660 new and 648 removed package(s)
  • testing core x86_64: 33 new and 35 removed package(s)
  • testing extra x86_64: 394 new and 553 removed package(s)
  • testing kde-unstable x86_64: 327 new and 322 removed package(s)
  • testing multilib x86_64: 22 new and 21 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

New issues:

  • Nvidia drivers won’t work with GSync with some setups. It is known that some Monitors won’t work with the new 470.74 driver. We recommend to disable that feature for now, until Nvidia will fix it. They are tracking it via internal bug number 3382581.

  • freetype2 update might result in font characters becoming squares. Don’t worry, a relogin to your UI should fix it. We recommend to do the update in a TTY. Affected UIs so far: Gnome, Phosh, Cinnamon.

  • Compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

  • :information_source: Announcement for PipeWire users:

    Re-enable any per-user enabled `pipewire-media-session.service` manually

    You should re-enable any per-user pipewire-media-session.service manually to establish a new service alias for pipewire-session-manager.service added with 0.3.38.

     systemctl --user enable pipewire-media-session

    See the PipeWire Release Notes for more info

Older Issues

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

Arch Linux - News: libtraceevent>=5.9-1 update requires manual intervention

OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

1 Like

Issue with gnucash, current file not opening at startup, no setting changes saved. It seems it has to do with its schema : many messages related to dconf entries when start in debug mode.
I reverted to previous version.

@philm: Thanks. I’ll see if the gdm and auto-rotate screen issues are fixed with the testing updates. :wink:

gnucash 4.8 works for me. 4.7 had configuration related bugs and was rapidly replaced by 4.8

I got 4.8 from the unstable channel

After update I got an issue audio output. When I don’t use audio channel (for example don’t use youtube) than linux audio system after few seconds disabling the channel and my audio speakers are starting to make an unpleasant background sound. When I again enable youtube watch than all ok.

Restart and shutdown entries in Gdm login screen work again after update. This Issue is fixed now.

This update has reintroduced the infamous AMDGPU crash-and-reset bug on my laptop. What made it interesting and frustrating is that it’s now reproducible almost every time I plug it in to AC power, and it has already made it to the point where Manjaro is unusable while plugged in. I’ve posted my observations and attempted workarounds so far in the linked thread. I haven’t applied the update on my desktop yet if it’s affected as well, since it also uses an AMD graphics card.

Edit/update: I narrowed down the cause of the crash-and-reset bugs to TLP, which was upgraded to 1.4.0 in this update. Downgrading it back to 1.3.1 stopped that annoying behavior for now.

Also, I’m happy to see the Manjaro project having their own penguin-like mascot; it’s pretty cute! Does it have a name, and is that mascot brand-new?

Ya, we launched it recently. Also in our Telegram Channel we added it as stickers.


At least my desktop (with Navi21) doesn’t show that behaviour, so maybe it’s just the APUs?

I’m not sure, to be honest, although some of the replies in the linked thread said they’re occurring in some Polaris GPUs as well, but they don’t specify exactly if they’re experiencing that on a laptop or desktop. For what it’s worth, my laptop has a Ryzen 7 3700 APU with RX Vega 10 (Picasso), while my desktop is running a dedicated RX 570 (Polaris) which never had those kinds of issues.

We might update our kernels by tomorrow. Some AMDGPU fixes are in queue …


Did you review and merge the tlp.conf.pacnew? There were a lot of changes. See pacman/Pacnew and Pacsave - ArchWiki

I already did, but even after I applied my old tlp.conf, the crashing still wouldn’t stop

You should try with the new config file for TLP instead of your old config.


Thanks for the suggestion. I replaced the old config file with the .pacnew one, and my system didn’t crash or had a display reset after reloading tlp.service and plugged my laptop back in. Then, I plopped back in my merged tlp.conf, and I found out that the crashes only occurred when RADEON_DPM_PERF_LEVEL_ON_AC is set to "high". I guess I should report this strange behavior in the TLP GitHub repo, even though setting that to the default (auto) solved my issue here.

Edit: I submitted a GitHub issue about this matter on the said repository.


Hi, Code 1.60.2-1 (community repository) stoped working after the last update.

When I check journalctl -p 3 -xb I get a long list which concludes with: Process 101947 (electron) crashed and dumped core.

Solved :white_check_mark: by reinstalling electron 13


Solved by setting XDG_DATA_DIRS=/usr/share/ in my .profile
gnucash 4.8 seems to need this variable to find its schema.
Do you know how XDG_DATA_DIRS is usually set ?

On my system, that is already set.

I don’t know how it gets set though

$ grep -rn XDG_DATA_DIRS /etc 2> /dev/null
/etc/profile.d/flatpak.sh:2:    # set XDG_DATA_DIRS to include Flatpak installations
/etc/profile.d/flatpak.sh:14:                case ":$XDG_DATA_DIRS:" in
/etc/profile.d/flatpak.sh:24:    export XDG_DATA_DIRS
/etc/profile.d/flatpak.sh:25:    XDG_DATA_DIRS="${new_dirs:+${new_dirs}:}${XDG_DATA_DIRS:-/usr/local/share:/usr/share}"
$ pacman -Qo /etc/profile.d/flatpak.sh
/etc/profile.d/flatpak.sh is owned by flatpak 1.11.3-1