Terminal looks different when opened from different places

I am using Deepin desktop environment.

When I open the Terminal from the App menu, The terminal looks like this

When I open it by right clicking in file manager and clicking 'open in terminal' it looks like this

Why is it looking different and how can I make it same

It looks like you have multiple terminals installed. The top image is the Deepin Terminal and the bottom one is something different, maybe the gnome terminal.

Which file manager is that you are using?

1 Like

help>about
will tell you what the second one is

oo. oo. I found a snippet:

ps -o comm= -p "$(($(ps -o ppid= -p "$(($(ps -o sid= -p "$$")))")))"

:grin:

2 Likes

Does this help

[kshitij@hp ~]$ xdg-open .
main.go:63: openFile: "."
main.go:93: desktop file: /usr/share/applications/org.gnome.Nautilus.desktop

How to I change the second one to first one?

So, you are using the gnome file manager and getting the gnome terminal. That makes sense.

Is there a reason you aren't using the deepin file manager?

By 'change' .. I assume you mean how do you set it to be default and use one under all conditions?

I guess it would help to know what you were doing when you opened the second one ?

When I installed this distribution, I was Manjaro Gnome

After some weeks the Settings suddenly stopped opening. I tried my best to dig into old threads to get into settings but could not.

There was some really important data/programs/installed software which I could not afford losing or did not have the time to setup again so I moved to Deepin Desktop Environment in a haste and I have been using that ever since

I was simply initializing a git repository and commiting code.

The terminal works perfectly fine just that it looks ugly.

So will I have to change the file manager or is there a way for me to launch the first terminal from File manager.

Sometimes I launch the first terminal from app drawer and cd into the directory where I want to work but that is tedious and time consuming and I am sure that must be a better way

This returned

[kshitij@hp NodeMongoRest]$ ps -o comm= -p "$(($(ps -o ppid= -p "$(($(ps -o sid= -p "$$")))")))"
gnome-terminal-

Well .. this is a thing.
You should arguable have a dconf setting or similar to flip .. but of course gnome people havent given you one ..
So heres the open issue:


Looks like the best solution might be the custom actions:

Users can add their own context menu entries with FileManager-Actions (formerly nautilus-actions). It'd be good if Nautilus at least offered an option to hide its built-in "Open in Terminal" action, which cannot be changed to use other terminal emulator than Gnome Terminal. With the FileManager-Actions, I can add my own "Open in Terminal" action, but I don't need 2.

1 Like