Stuttering and Laggy monitor on "External Only" mode

When I set my display mode to “External Only”, my cursor moves smoothly but the content continuously stutters.

1 Like

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


  Kernel: 5.10.49-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=492ae27e-45b2-4229-883b-e0dae253ff87 rw quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: GNOME 40.3 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-dk0xxx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 85FC v: 42.42 serial: <filter> UEFI: Insyde v: F.33 
  date: 07/16/2020 
  ID-1: BAT1 charge: 48.8 Wh (100.0%) condition: 48.8/52.5 Wh (93.0%) 
  volts: 12.8 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion 
  serial: <filter> status: Full 
  RAM: total: 15.48 GiB used: 4.84 GiB (31.3%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
  Info: Quad Core model: Intel Core i5-9300H bits: 64 type: MT MCP 
  arch: Kaby Lake note: check family: 6 model-id: 9E (158) stepping: A (10) 
  microcode: EA cache: L2: 8 MiB bogomips: 38408 
  Speed: 804 MHz min/max: 800/2400 MHz Core speeds (MHz): 1: 804 2: 800 3: 815 
  4: 815 5: 846 6: 807 7: 812 8: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon art 
  avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb ept ept_ad erms est 
  f16c flexpriority flush_l1d fma fpu fsgsbase fxsr ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm lm 
  mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat 
  pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts 
  rdrand rdseed rdtscp rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 
  sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Hewlett-Packard 
  driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300 
  Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] 
  vendor: Hewlett-Packard driver: nvidia v: 470.42.01 
  alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1f91 
  class-ID: 0300 
  Device-3: Cheng Uei Precision Industry (Foxlink) HP Wide Vision HD 
  Integrated Webcam 
  type: USB driver: uvcvideo bus-ID: 1-5:4 chip-ID: 05c8:03bc class-ID: 0e02 
  Display: x11 server: 1.20.11 compositor: gnome-shell driver: 
  loaded: modesetting,nvidia alternate: fbdev,intel,nouveau,nv,vesa 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.1.4 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403 
  Sound Server-1: ALSA v: k5.10.49-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.31 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: dynamic noprefixroute scope: global 
  IP v6: <filter> type: noprefixroute scope: link 
  Device-2: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be 
  port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:b822 class-ID: 0280 
  IF: wlo1 state: down mac: <filter> 
  IF-ID-1: docker0 state: down mac: <filter> 
  IP v4: <filter> scope: global broadcast: <filter> 
  WAN IP: <filter> 
  Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb 
  v: 0.8 bus-ID: 1-14:5 chip-ID: 0bda:b00b class-ID: e001 serial: <filter> 
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running 
  rfk-block: hardware: no software: yes address: see --recommends 
  Permissions: Unable to run lvs. Root privileges required. 
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 6060 bus-ID: 00:17.0 chip-ID: 8086.282a rev: 10 class-ID: 0104 
  Local Storage: total: 476.94 GiB used: 24.01 GiB (5.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix 
  model: BC511 HFM512GDJTNI-82A0A size: 476.94 GiB block-size: physical: 512 B 
  logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD serial: <filter> 
  rev: HPS0 temp: 31.9 C scheme: GPT 
  Message: No optical or floppy data found. 
  ID-1: / raw-size: 117.04 GiB size: 114.65 GiB (97.95%) 
  used: 23.94 GiB (20.9%) fs: ext4 dev: /dev/nvme0n1p7 maj-min: 259:7 
  label: N/A uuid: 492ae27e-45b2-4229-883b-e0dae253ff87 
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) 
  used: 80 MiB (31.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: SYSTEM uuid: 56D2-97F7 
  Alert: No swap data was found. 
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: <superuser required> 
  label: N/A uuid: N/A 
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 356.61 GiB 
  fs: <superuser required> label: Windows uuid: A82ED9002ED8C908 
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 534 MiB fs: <superuser required> 
  label: N/A uuid: 605082235081FFD0 
  ID-4: /dev/nvme0n1p5 maj-min: 259:5 size: 500 MiB fs: <superuser required> 
  label: N/A uuid: 0B19-5C84 
  ID-5: /dev/nvme0n1p6 maj-min: 259:6 size: 2 GiB fs: <superuser required> 
  label: N/A uuid: 8a2c3f2a-13f2-4fa5-b9a0-52ca85460762 
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 16 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-2:2 
  info: KYE Systems (Mouse Systems) Scorpion M6-600 Gaming Mouse 
  type: Mouse,HID,Keyboard driver: hid-generic,usbhid interfaces: 3 rev: 2.0 
  speed: 12 Mb/s power: 300mA chip-ID: 0458:0179 class-ID: 0300 
  Device-2: 1-3:3 info: SINO WEALTH Gaming KB type: Keyboard,HID 
  driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s 
  power: 500mA chip-ID: 258a:002a class-ID: 0300 
  Device-3: 1-5:4 info: Cheng Uei Precision Industry (Foxlink) HP Wide Vision 
  HD Integrated Webcam 
  type: Video driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s 
  power: 500mA chip-ID: 05c8:03bc class-ID: 0e02 
  Device-4: 1-14:5 info: Realtek Realtek Bluetooth 4.2 Adapter type: Bluetooth 
  driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA 
  chip-ID: 0bda:b00b class-ID: e001 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 8 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  System Temperatures: cpu: 46.0 C mobo: 29.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 279 Uptime: 12h 45m wakeups: 2 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: note: see --pkg 
  pacman: 1244 lib: 292 flatpak: 0 Shell: Zsh v: 5.8 
  running-in: gnome-terminal inxi: 3.3.05 ```

That looks fine; are you using a converter to hook up the external monitor?

If not, please provide the output to:



Screen 0: minimum 320 x 200, current 3840 x 1080, maximum 16384 x 16384
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 194mm
   1920x1080     60.00*+  59.97    59.96    59.93    40.00  
   1680x1050     59.95    59.88  
   1400x1050     59.98  
   1600x900      59.99    59.94    59.95    59.82  
   1280x1024     60.02  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1440x810      60.00    59.97  
   1368x768      59.88    59.85  
   1280x800      59.99    59.97    59.81    59.91  
   1280x720      60.00    59.99    59.86    59.74  
   1024x768      60.04    60.00  
   960x720       60.00  
   928x696       60.05  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   700x450       59.96    59.88  
   640x480       60.00    59.94  
   720x405       59.51    58.99  
   684x384       59.88    59.85  
   640x400       59.88    59.98  
   640x360       59.86    59.83    59.84    59.32  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
   360x202       59.51    59.13  
   320x180       59.84    59.32  
HDMI-1-0 connected 1920x1080+1920+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080     60.00*+  59.94    50.00  
   1680x1050     59.95  
   1600x900      60.00  
   1440x900      59.89  
   1280x1024     75.02    60.02  
   1280x800      59.81  
   1280x720      60.00    59.94    50.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94  
DP-1-0 disconnected (normal left inverted right x axis y axis)
DP-1-1 disconnected (normal left inverted right x axis y axis)
  1680x1050 (0x49) 146.250MHz -HSync +VSync
        h: width  1680 start 1784 end 1960 total 2240 skew    0 clock  65.29KHz
        v: height 1050 start 1053 end 1059 total 1089           clock  59.95Hz
  1280x1024 (0x50) 108.000MHz +HSync +VSync
        h: width  1280 start 1328 end 1440 total 1688 skew    0 clock  63.98KHz
        v: height 1024 start 1025 end 1028 total 1066           clock  60.02Hz
  1280x800 (0x5a) 83.500MHz -HSync +VSync
        h: width  1280 start 1352 end 1480 total 1680 skew    0 clock  49.70KHz
        v: height  800 start  803 end  809 total  831           clock  59.81Hz
  1024x768 (0x61) 65.000MHz -HSync -VSync
        h: width  1024 start 1048 end 1184 total 1344 skew    0 clock  48.36KHz
        v: height  768 start  771 end  777 total  806           clock  60.00Hz
  800x600 (0x70) 40.000MHz +HSync +VSync
        h: width   800 start  840 end  968 total 1056 skew    0 clock  37.88KHz
        v: height  600 start  601 end  605 total  628           clock  60.32Hz
  800x600 (0x71) 36.000MHz +HSync +VSync
        h: width   800 start  824 end  896 total 1024 skew    0 clock  35.16KHz
        v: height  600 start  601 end  603 total  625           clock  56.25Hz
  640x480 (0x7d) 25.175MHz -HSync -VSync
        h: width   640 start  656 end  752 total  800 skew    0 clock  31.47KHz
        v: height  480 start  490 end  492 total  525           clock  59.94Hz

That’s weird: a GeForce GTX 1650 should be able to run an external monitor on FHD and you have the correct driver version installed.

  • How did you install the nVidia drivers?
  • What are you doing exactly? (E.G. Are you closing the lid of your laptop?)


During Manjaro’s setup for dual boot, I simply selected the “proprietary drivers” option which lead to installing those Nvidia drivers. And no, I use both screens.

If you don’t use a converter: Have you tried changing the HDMI cable already?

If yes: What’s the output of nvidia-smi while the stuttering is happening???


Sun Jul 25 00:26:47 2021       
| NVIDIA-SMI 470.57.02    Driver Version: 470.57.02    CUDA Version: 11.4     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0 Off |                  N/A |
| N/A   37C    P0     6W /  N/A |      5MiB /  3911MiB |      0%      Default |
|                               |                      |                  N/A |
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A      1409      G   /usr/lib/Xorg                       4MiB |

And it’s not a physical problem given that the second monitor works fine on Windows.

That doesn’t mean anything: Windows could be lowering the resolution / colour depth and performing other shenanigans behind the scenes without you knowing.

Having said that, you do have a weird problem, because everything looks OK from a system perspective and a GeForce GTX 1650 should have no issue running an external monitor on FHD so let me try to summarize your system as I understand it:

  • Internal laptop screen + External monitor hooked up directly to the HDMI port without a converter and the HDMI cable has been changed to an HDMI cable known to be working on another system (E.G Blu-ray -TV cable)
  • Both monitors are extended to one huge desktop
  • 5.10 LTS kernel
  • GeForce GTX 1650 with 4G VRAM

When moving a window from the internal laptop screen to the external monitor, the app window start “stuttering” although both monitors are running at 60Hz at the same resolution.

Is my understanding correct?

I’ve got the same (or similar) issue. When connecting to an external monitor only, in my case, a 32" 4k, 60 Hz; GeForce GTX 1650 Mobile, 470 driver.
State: External monitor only, disable laptop screen.
Symptom: Mouse moves smoothly, input and output lag on any mouse click, keyboard press, program execution.
Observations: Lowering resolution or refresh rate of the external monitor has no affect, lag still exists. When I re-enable the laptop screen, it displays a fraction of the higher resolution external monitor, but the lag is gone!

I can’t paste system details, error on posting a weblink. Nor can I paste a screen shot of the text, error stating I can’t embed media.

1 Like

It is against the forum rules to hijack a thread. The better way to get involved in a thread is to:

  • post a solution
  • subscribe to the thread by clicking the Tracking button below the post so you’re still informed of any solutions that are posted to a problem similar to yours.

Although I’m a moderator, this is not an official warning as this is your first post here, just trying to help you become a better forum citizen.


Thanks, Fabby. I considered starting a new thread, but since the OP and I have the same graphics card and apparently the same symptoms, I thought my details were relevant and might help the community find a solution.

The problem only exists when I run the external monitor alone. As clutterking said, the cursor works smoothly but there’s a 3-second lag when clicking or moving anything.
And today, after running system updates, my second monitor doesn’t work at all and when I try to launch the NVIDIA X Server app, it doesn’t execute.

Since you have a hybrid card I would assume you use the bumblebee config?

As I remember correctly, on hybrid cards the nvidia card is hard wired to the external output. Intel is used for the laptop screen. So, to use the second screen, it is needed to use the nvidia card as a sink of the primary (intel) and loop the signal through it.

Bumblebee is in that case a big hack, since Nvidia does not support it. It uses VirtualGL:

In short:

VirtualGL redirects an application’s OpenGL/GLX commands to a separate X server (that has access to a 3D graphics card), captures the rendered images, and then streams them to the X server that actually handles the application.
VirtualGL - ArchWiki

So the shutter comes from frame drops or delay when rendering the second screen with OpenGL.

Use for example optimus to use the nvidia card only. I would say this will stop the shuttering.

Or remove the nvidia driver and stay on open source drivers. There you can use a real kernel based sink and not VirtualGL.

1 Like

@clutterking @Despair
This happens when you are in hybrid mode (the default Manjaro NVIDIA installation),thats a bug that NVIDIA has not fixed yet,the workaround for this is to switch to NVIDIA mode with optimus-manager

Install optimus-manager from the official repositories

pamac install optimus-manager

Since you are using GNOME,you need to follow 2 additional steps

  • The default gdm package from the Archlinux and Manjaro repositories is not compatible with optimus-manager, so you must replace it with this patched version : gdm-prime (also replaces libgdm). The patch was written by Canonical for Ubuntu and simply adds two script entry points specifically for Prime switching. The package is otherwise identical to the official one.
  • Gnome launches Wayland sessions by default, which are incompatible with optimus-manager. To force Xorg sessions, You need to edit the file /etc/gdm/custom.conf and remove the # before the line #WaylandEnable=false.

When finished,reboot the computer,now you can switch between integrated (use intel card only),hybrid (intel + nvidia) (the one you are currently using) and nvidia mode (the one you want for external monitor)

optimus-manager --switch integrated
optimus-manager --switch hybrid
optimus-manager --switch nvidia

Then,logout and login again,you should be now using the nvidia mode,connect to the external monitor and everything should be fluid.

you can verify what mode you are right now with

optimus-manager --print-mode

and you can see what process are currently using the nvidia card


bumblebee are loong deprecated,they are mostly for older cards now,the newer way now is with official nvidia drivers.


It worked, thanks!

I have the same problem as Despair. This is fascinating its necessary completely disable the other GPU.
Hopefully NVIDIA will fix in the future.

KDE seems to have issues with optimus manager. Fix is to run
prime-offload at init.

Unfortunately for me I get stuck
A GPU switch from integrated to nvidia is pending. Log out and log back in to apply. Current GPU mode : integrated

Even after logging out multiple times same, only uses iGPU but dGPU is at 24W.

Got it working after commenting out the two lines in /etc/sddm.conf per

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.