[Stable Update] 2024-05-13 - Kernels, Plasma 6, Gnome 46, LxQT 2.0, Nvidia, Pacman

Is actually most often the default to your normal graphical session. Or ‘modernly’ anyways.
Use a different F key.

This should not be necessary.
But it could be helpful if you dont have a connection.

I also dont know that you need the double-y or the w instead of just running -Syu.
But if you want to download first, I suppose it wouldnt hurt.
The yy will mostly be a waste of resources for you and the servers.

And I still think that clearing the configs and cache is generally good advice.

https://wiki.archlinux.org/title/KDE#Configuration_related

It seems vmware-horizon-client no longer works in KDE Plasma 6 wayland with the new update…
anyone else have the same problem?

OK, I got it to work. The problem was that a tiny switch that configures the function keys on my Microsoft keyboard was in the wrong position.

Thanks to everyone for the patient assistance!

2 Likes

Not true, update was flawless on a 5 years old mate install.

1 Like

Update went relatively smooth following the KDE “set defaults, log out, and update via TTY” advice.

Initial plasma 6 issues discovered:

  1. Desktop icons failed to retain their place on reboot. This is an issue under both Wayland and X11
  2. “KCM => Wifi & Networking => Firewall” (plasma-firewall) is not prompting for credentials, nor displaying proper uwf status/policies in effect like the previous version, and suggests the firewall is disabled. If I try check the box to enable the firewall, it prompts for credentials, passes, and tosses and error Error enabling firewall: An error occurred in command 'setStatus':
    2.1. Might this be related to any of the orphan/foreign packages I uninstalled?
    2.2. Or is it possible I actually didn’t reboot after resolving the /etc/pam.d/kde.pacnew (if that might be related)?
  3. Issues I worked around by reverting from a Wayland to X11 session…
    3.1. Two of the 3 steam/proton games I played regularly on wayland under plasma 5.xx with gamescope failed to launch or launched “empty”/transparent
    3.2. Under Plasma 6 / Wayland… removing the gamescope launch options corrected one, but the other failed to launch
    3.3 Under Plasma 6 / X11… no issues with these games using gamescope
  4. Dolphin forgot the tabs/folders it had opened… easy enough to reload
  5. Primary Monitor, VRR settings, and resolutions (I have 2 displays) were reset to defaults… easy enough to change back
There were several orphans and one "transitioned to" foreign packages (AUR) that I removed post update/reboot
[2024-05-13T12:56:44-0500] [ALPM] transaction started
[2024-05-13T12:56:44-0500] [ALPM] removed python-importlib-metadata (5.1.0-2)
[2024-05-13T12:56:44-0500] [ALPM] removed qqc2-desktop-style5 (5.115.0-1)
[2024-05-13T12:56:44-0500] [ALPM] removed libkdcraw5 (24.02.2-1)
[2024-05-13T12:56:44-0500] [ALPM] removed krunner5 (5.115.0-1)
[2024-05-13T12:56:44-0500] [ALPM] removed libkcddb5 (24.02.2-1)
[2024-05-13T12:56:44-0500] [ALPM] removed libqaccessibilityclient-qt5 (0.6.0-1)
[2024-05-13T12:56:44-0500] [ALPM] removed networkmanager-qt5 (5.115.0-1)
[2024-05-13T12:56:44-0500] [ALPM] removed bluez-qt5 (5.115.0-1)
[2024-05-13T12:56:44-0500] [ALPM] removed grantlee (5.3.1-1)
[2024-05-13T12:56:44-0500] [ALPM] removed web-installer-url-handler (2.3-1)
[2024-05-13T12:56:44-0500] [ALPM] removed python-manjaro-sdk (1:0.1.1-1)
[2024-05-13T12:56:44-0500] [ALPM] removed kirigami-addons5 (0.11.0-7)
[2024-05-13T12:56:44-0500] [ALPM] removed gcab (1.6-1)
[2024-05-13T12:56:44-0500] [ALPM] removed webrtc-audio-processing (0.3.1-4)
[2024-05-13T12:56:44-0500] [ALPM] removed python-pycurl (7.45.2-4)
[2024-05-13T12:56:44-0500] [ALPM] removed kimageannotator-qt5 (0.7.1-3)
[2024-05-13T12:56:44-0500] [ALPM] removed kidletime5 (5.115.0-1)
[2024-05-13T12:56:44-0500] [ALPM] removed kcolorpicker-qt5 (0.3.1-4)
[2024-05-13T12:56:44-0500] [ALPM] removed knotifyconfig5 (5.115.0-1)
[2024-05-13T12:56:44-0500] [ALPM] removed libsmbios (2.4.3-7)
[2024-05-13T12:56:44-0500] [ALPM] removed kactivities-stats5 (5.115.0-1)
[2024-05-13T12:56:44-0500] [ALPM] removed qt5-webengine (5.15.16-6)
[2024-05-13T12:56:44-0500] [ALPM] removed purpose5 (5.115.0-3)
[2024-05-13T12:56:44-0500] [ALPM] removed kpeoplevcard (0.1-2)
[2024-05-13T12:56:44-0500] [ALPM] removed kpeople5 (5.115.0-1)
[2024-05-13T12:56:44-0500] [ALPM] removed kdnssd5 (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed kcontacts5 (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed kfilemetadata5 (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed kquickcharts5 (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed python-systemd (235-3)
[2024-05-13T12:56:45-0500] [ALPM] removed khtml (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed kjs (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed ktexteditor5 (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed syntax-highlighting5 (5.115.0-2)
[2024-05-13T12:56:45-0500] [ALPM] removed python-ply (3.11-13)
[2024-05-13T12:56:45-0500] [ALPM] removed modemmanager-qt5 (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed oxygen-sounds (6.0.4-1)
[2024-05-13T12:56:45-0500] [ALPM] removed kdsoap-qt5 (2.2.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed kholidays5 (1:5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed plasma-framework5 (5.115.0-3)
[2024-05-13T12:56:45-0500] [ALPM] removed kactivities5 (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed python-zipp (3.18.1-2)
[2024-05-13T12:56:45-0500] [ALPM] removed kdesu5 (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed kpty5 (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed threadweaver5 (5.115.0-1)
[2024-05-13T12:56:45-0500] [ALPM] removed poppler-qt5 (24.03.0-1)
[2024-05-13T12:56:45-0500] [ALPM] transaction completed
[2024-05-13T12:56:45-0500] [ALPM] running '30-systemd-udev-reload.hook'...
[2024-05-13T12:56:45-0500] [ALPM] running '30-systemd-update.hook'...
[2024-05-13T12:56:45-0500] [ALPM] running 'dbus-reload.hook'...
[2024-05-13T12:56:45-0500] [ALPM] running 'gtk-update-icon-cache.hook'...
[2024-05-13T12:56:46-0500] [ALPM] running 'update-desktop-database.hook'...
[2024-05-13T12:56:57-0500] [ALPM] transaction started
[2024-05-13T12:56:57-0500] [ALPM] removed prison5 (5.115.0-1)
[2024-05-13T12:56:57-0500] [ALPM] transaction completed
[2024-05-13T12:56:57-0500] [ALPM] running '30-systemd-update.hook'...
[2024-05-13T12:58:06-0500] [ALPM] transaction started
[2024-05-13T12:58:06-0500] [ALPM] removed khotkeys (5.27.11-1)
[2024-05-13T12:58:06-0500] [ALPM] removed kdelibs4support (5.115.0-1)
[2024-05-13T12:58:06-0500] [ALPM] removed kunitconversion5 (5.115.0-1)
[2024-05-13T12:58:06-0500] [ALPM] removed kemoticons (5.115.0-1)
[2024-05-13T12:58:06-0500] [ALPM] removed kparts5 (5.115.0-1)
[2024-05-13T12:58:06-0500] [ALPM] removed plasma-simplemenu (1.0.12-1)
[2024-05-13T12:58:06-0500] [ALPM] removed manjaro-hotfixes (2024.1-2)
[2024-05-13T12:58:06-0500] [ALPM] removed systemd-kcm (1.2.1-8)
[2024-05-13T12:58:07-0500] [ALPM] transaction completed
[2024-05-13T12:58:07-0500] [ALPM] running '30-systemd-update.hook'...
[2024-05-13T12:58:07-0500] [ALPM] running 'dbus-reload.hook'...
ufw is enabled despite what plasma-firewall thinks
systemctl status ufw                                                                     ✔ 
● ufw.service - CLI Netfilter Manager
     Loaded: loaded (/usr/lib/systemd/system/ufw.service; enabled; preset: disabled)
     Active: active (exited) since Mon 2024-05-13 14:16:50 CDT; 6h ago
   Main PID: 425 (code=exited, status=0/SUCCESS)
        CPU: 64ms

May 13 14:16:50 AMD-Ryzen9-7940HS systemd[1]: Starting CLI Netfilter Manager...
May 13 14:16:50 AMD-Ryzen9-7940HS systemd[1]: Finished CLI Netfilter Manager.
1 Like

Snaggin’ that now

I am having issues loading my NVIDIA GPU
I see this error in my supergfxd.service

set_runtime_pm: "/sys/devices/pci0000:00/0000:00:01.0/0000:01:00.1/power/control" doesn't exist, device may have been removed (can be ignored)

1 Like

spectacle not working
when open it, it display Remote peer disconnected

1 Like

Maybe (likely) my fault that I installed “the wrong thing” , but now with the update it also wants to update electron22 and electron25 , just downloaded ~40+ GB (just for electron22 ? … which took a while) now compiling the whole thing … I might need to look into why I have installed it (actually just ~ 3 weeks ago).

Option B : Do a fresh clean version 24 install. Wen ISO ?

I’m only responding in the spirit of the wording of the above question, which is that, yes, there are a few issues, but they are simply Plasma bugs — and mostly 15-minute bugs, I would say. Other than that, everything went smoothly, but then again, I update Manjaro the smart way, and I pay attention to all Announcements threads — including for the Testing and Unstable branches. :wink:


Everything depends on whether these are qt5 or qt6 applications. kvantum was updated to qt6, so if you want continued kvantum support in qt5 applications, then you need to install kvantum-qt5 — it’s an optional dependency of the qt6 version of kvantum now.


Negative. In Plasma 5; those were handled by khotkeys, which was dropped for Plasma 6.


Select — or install, if you don’t have it on your system already — one of the Nerd-flavored fonts, such as Noto Sans Mono Nerd.

3 Likes

My default UI language changed for no apparent reason.
I have English as my UI language and German as my format language:

This has worked for a long time, but since this update my UI is now in German as well.

1 Like

Upgrade worked without problems.
mesa 24.0.6-1 compiled without problems with “-D video-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc” entry in PKGBUILD
SoftMaker Office 2024 crashes at launch - able to submit crash log to SoftMaker ← created manjaro support entry for this under Support - Software & Applications

Have to rebuild the following python3.11 libraries one-by-one with pamac build [lib]:

protonvpn-cli
protonvpn-gui
pyside2
python-jade-application-kit
python-manjaro-sdk
python-proton-client
python-protonvpn-nm-lib
python-shiboken2

Able to rebuild all except:

python-jade-application-kit
python-manjaro-sdk

Used pamac gui to remove those packages and dependencies.

Also recommend to rebuild python-shiboken2 before trying to rebuild pyside2 as the former rebuilds pyside2 also.

Most likely can remove pyside2 and python-shiboken2

I’m using KDE but I still update through Konsole. I didn’t have custom configurations so after reboot twice every thing works fine.

19 posts were split to a new topic: Off-topic dscussion moved from Stable update 2024-05-13

3 posts were split to a new topic: Always read post 2 for potential issues and solutions

This is by far the most broken, frustrating and ugliest update. Plasma 6 looks like crap, all themes are off, the paddings and layouts are off, my login screen is broken, my splash screen is broken, there is a constant lag and stutter every 20-30 seconds, jesus chrirst.

2 Likes

Sounds as if you have things like incompatible themes.
Please review the many related posts on the subject.
(some are even in this thread)

2 Likes

Plasma hangs frequently. Is unresponsive. No reaction for clicks, even in other gui programs started. However my global shortcut for showing a console works. After a minute it gets back to operational.
Here I clicked a link in firefox and moved a mouse, but it did not recognize my mouseup and interpreted it as drag and drop operation. Then plasma froze.

touko 14 09:16:35 x kwin_x11[1069]: kwin_core: XCB error: 3 (BadWindow), sequence: 59650, resource id: 65011927, major code: 129 (SHAPE), minor code: 6 (Input)
touko 14 09:16:19 x systemd[965]: Started Firefox Web Browser - Web Browser.
touko 14 09:14:46 x systemd[1]: packagekit.service: Deactivated successfully.
touko 14 09:14:46 x PackageKit[10748]: daemon quit
touko 14 09:12:11 x kwin_x11[1069]: kwin_core: XCB error: 3 (BadWindow), sequence: 32555, resource id: 60817492, major code: 129 (SHAPE), minor code: 3 (Combine)
touko 14 09:12:11 x kwin_x11[1069]: kwin_core: XCB error: 3 (BadWindow), sequence: 32554, resource id: 60817492, major code: 129 (SHAPE), minor code: 3 (Combine)
touko 14 09:12:11 x kwin_x11[1069]: kwin_core: XCB error: 3 (BadWindow), sequence: 32539, resource id: 60817492, major code: 129 (SHAPE), minor code: 3 (Combine)
touko 14 09:12:11 x kwin_x11[1069]: kwin_core: XCB error: 3 (BadWindow), sequence: 32538, resource id: 60817492, major code: 129 (SHAPE), minor code: 3 (Combine)
touko 14 09:12:11 x kwin_x11[1069]: kwin_core: Failed to focus 0x3a00054 (error 3)

My incompatible theme is called default Breeze :frowning:

1 Like