[Stable Update] 2023-12-23 - Kernels, Grub, Mate, Deepin, Cinnamon, ICU, KDE Frameworks

Looks likely to be a long Christmas evening, so far only oxygen and air bring it back nothing else I have tried works, though to be absolutely honest I have not logged in and out umpteen times, however I have switched back and fourth between list and grid view though really with no such luck. Tried changing accent too. It’s tempting to install a new plasma theme, though concerned that something might break, any recommends thanks in advance & Happy Holidays.

Are you using Kvantum? You can also try all default settings in Appearance. If it was after the update (via tty I hope?) see the pacman log.
You can also try deactivating and reactivating Accent Color in
Startup and Shutdown > Background Services

3 posts were split to a new topic: Problem running nixnote2 after update

This was indeed the problem. I made the correction and it worked so thank you very much!

However in doing that I was faced with another issue. When I restarted, I was greeted with a nice grub rescue screen. I fixed this by changing my boot order in my motherboard BIOS from sda (where Manjaro is installed) to sdb (where my Windows is and where fdisk -l said my comptuer boots from) and that fixed the rescue.

I guess my question is why did I get a grub rescue after doing this? fdisk -l showed sdb was my boot device so I used that for the grub install command, but sda was first on the list for my motherboard’s boot loader.

No I am not using Kvantum, have been through all the default settings with no luck. Currently trying out various themes and returning to my default Manjaro dark to see if it fixes anything and no luck.

You can also try deactivating and reactivating Accent Color in
Startup and Shutdown > Background Services

How would I do that?

On my Manjaro desktop, that was quite enough, apparently: It told me everything was fine and has been rebooting perfectly ever since. No trouble with my two-disk dual boot with Mint, either. My Mabox laptop wanted me to be more specific, though.

sudo update-grub is still working as usual.

Uncheck the tick and hit apply, but…
Seems this is miss and miss. Can you simply roll back before the update and redo it logged-out in tty?
Did you install new themes, window layout or so recently? When they’re old ones, they can mess up things simply by installing I think. Happened the me with the Gruvbox Plasma Style I believe.

1 Like

Have experienced an issue with this as it broke a package. Its an AUR package so I will post in the appropriate forum and link there rather than clutter this announcement

My issue was with icu73. As pointed out by this post the solution was to install it again directly from AUR. Should have done a bit more research :sweat_smile:

You probably should. Everything I’ve read about this seems to point to strongly recommending running the grub-install and grub-mkconfig, plus all of their necessary variables after them.

For sure, Time Shift is a good option, and I may opt to use it again at some point. At the very least I do keep a USB flash drive with Manjaro on it for rescue situations.


It does now with 0.5.7-20 coming along shortly.

1 Like

4 posts were split to a new topic: Can’t access BIOS

Managed to get it back through installing another theme and then returning to my original theme, unfortunately lost my sticky note’s widget and its contents somewhere.

1 Like

A post was split to a new topic: Login gets stuck and missing tray icons

Bluetooth now reports the battery level of my earbuds! Sweet!

2 posts were split to a new topic: Zenity 4.0.0 does not provide gdialog

So, probably the safest option for a common user would be to mark grub as not upgradeable. Is it so? Would that be safe for future? For that sounds logical to me. And probably, if any important improvement, or better, important patch for problems, would be added, probably would be explained properly in the announcement of the update, and so we can unblock this package and take the needed cares…

or install install-grub , as I’ve just read.

anycase, it would be, I think, something interesting to be advised when installing Manjaro at first time, and probably recommended also to existing users.

Install “install-grub” and forget it. It will update automatically in the future.


One curious (though I presume not problematic) new thing after this update: from time to time my journal is getting messages:

Dec 29 14:33:54 antwerp pamac-tray-plasma[3781823]: fatal: not a git repository (or any parent up to mount point /var)
Dec 29 14:33:54 antwerp pamac-tray-plasma[3781823]: Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).

I’m curious ('cos I’m that sort of person) to know what this isreally telling me.

For the grub stuff, I did this:

sudo -i
grub-install --target=x86_64-efi --efi-directory=/boot/efi --recheck --bootloader-id=Manjaro
grub-mkconfig -o /boot/grub/grub.cfg

On one machine, I dual boot windows and Manjaro. I did not have to change anything in Bios.
On another machine, it’s Manjaro only. I got a “grub_is_shimlock_enabled” error.
So I changed the boot order in Bios, and the problem went away.

1 Like