Can't access BIOS

If have Acer SF114 which had secure boot enabled.

I checked that I have EFI and updated grub as per instructions.

Then it wouldn’t boot. I entered the BIOS and noticed that the boot order had changed.
2nd Manjaro

So I changed the boot order and manjaro booted.

However, now I can’t access the BIOS (F2) - I just get a flashing cursor.

I had Secure Boot enabled.

How can I access BIOS again?

efibootmgr                                                       ✔ 
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001,2001,2002,2003
Boot0000* Manjaro	HD(1,GPT,17d00bd3-e87f-4b49-ac20-3a9e04a553eb,0x1000,0x96000)/File(\EFI\Manjaro\grubx64.efi)
Boot0001* HDD: KINGSTON RBUSNS8180DS3128GJ	PciRoot(0x0)/Pci(0x12,0x0)/Sata(0,0,0)/HD(1,GPT,17d00bd3-e87f-4b49-ac20-3a9e04a553eb,0x1000,0x96000)RC
Boot2001* EFI USB Device	RC
Boot2003* EFI Network	RC
sudo inxi -Mxxx                                           ✔  4s  
  Type: Laptop System: Acer product: Swift SF114-32 v: V1.14
    serial: NXGXUEK00391107B7F6600
  Mobo: GLK model: Sapporo_GL_S v: V1.14 serial: NBGXU11001911007186600
    UEFI: Insyde v: 1.14 date: 05/27/2020

I am confused. I am sure BIOS has SecureBoot Enabled.

Yet the following from Manjaro says no SecureBoot

sudo bootctl                                    TSTP ✘  29s    
systemd-boot not installed in ESP.
      Firmware: n/a (n/a)
 Firmware Arch: x64
   Secure Boot: disabled
  TPM2 Support: yes
  Boot into FW: supported

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Since you got “Boot into FW: supported”, this should take you to the BIOS:

sudo systemctl reboot --firmware-setup

Else you could hit ESC / Escape before booting into Manjaro to access grub menu, there you also find an option for going to the BIOS.

No. I tried that.
Same effect. get a cursor (underscore) and won’t allow access to BIOS.
I tried timeshift and recovered okay.
But when rebooting it goes into Grub-recovery. As it seems to want to boot from the HDD rather than Manjaro on the boot order.
I go into the bios and put Manjaro as the top option for boot. and it boots just fine.
however, at that point I can’t access the BIOS anymore.

1 Like

Run efibootmgr before rebooting, identify Manjaro’s entry (e.g. “Boot0000* manjaro …”), use sudo efibootmgr --bootnext XXXX (for “Boot0000” you would insert 0000 instead of XXXX), this will force booting into Manjaro once, reboot using sudo systemctl reboot --firmware-setup, in the BIOS fix the boot order permanently.

Maybe a Cmos reset will help?

Keep in mind that to access your BIOS the F2 keypress should timed precisely as instucted in your Mainboard manual – that is; While the computer logo is being displayed – not the Manjaro logo (if present).

Sometimes it might be difficult to pinpoint the exact time to press the key, in which case repeating the F2 keypress multiple times at one-second intervals will usually work.

This indicates that you’re not pressing F2 early enough.

When changing BIOS settings the BIOS might not be accessible on first boot (after settings have changed) on some older machines. Subsequent reboots usually allow access once again, if the keypress is early enough and assuming your keyboard has initiated fully.

Assuming Manjaro is set first in BIOS, what happens if you shutdown, and perform a cold boot?

I found Acer SF114-32 User Manual at ManualsLib, if this is useful. Manuals for other related models are also available if this isn’t your specific machine.


1 Like