[Stable Update] 2023-12-23 - Kernels, Grub, Mate, Deepin, Cinnamon, ICU, KDE Frameworks

Is it only me or is anyone else confused a little when i read this now.

Because why should only MBR Users keep GRUB in sync, when the update process both systems: MBR/EFI not update/reinstall, it should be equal for both sides or not?

Maybe there is only a little mistake in that info and it should called like this:

And why only the Advanced users? So the unexperienced users can run into trouble? :rofl:

After i read this new Edited changes, i have to revert my view and probably was wrong, i though that pamac will update grub… but after reading this, it looks the opposite.

Anyways, i personally will only reinstall it when i run into issue, i don’t see a big improvement, to always manually reinstall Grub all the time now… im using Manjaro above 3 years now and never reinstalled or keep it in sync and don’t had any issues yet.

1 Like

Doing my updates today including the grub installing. I know that I am MBR and what my device is but when I put the command in I got this error message

sudo grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sdb1
Installing for i386-pc platform.
grub-install: warning: File system `ntfs' doesn't support embedding.
grub-install: error: embedding is not possible, but this is required for cross-disk install.

My boot device is different from where my main Manjaro install is if that is causing an issue (which I am not sure it is or not). Is the error ignorable and did my grub install work properly? If not what can I do to fix it?

EDIT: I restarted and clearly my system is not broken. I would still like assistance though with this issue just so it is not a problem down the road.

I checked both the Arch and Manjaro wikis and my error doesn’t pop up under troubleshooting on the articles about GRUB so I am at a loss.

1 Like

To all who are still struggling:

Accept that you have to somehow learn/understand the differences between BIOS and UEFI mode booting and between a msdos and a gpt parted disk to maintain your OS. There are excellent wiki entries available, e.g. with regard to grub:

Linux is not Windoze. The higher degree of configuration freedom comes with more responsibility. If you refuse to learn these basics then maybe Manjaro and similar distros are not the right choice for you. :wink:


I know pretty well the differences between BIOS and UEFI, thanks.

The problem for me in this situation is: a update was released, and need manual intervention from the user. Well, a Linux user need to understand and be capable to solve problems, yes, that’s true.
But, we are talking about Manjaro, not Arch ou Gentoo. A user that choose Manjaro want a upper level of control and freedom compared to a Ubuntu-like system. But, that same user don’t want all the work that Arch or Gentoo have.

With all that said: the problem here is that we need to manually reinstall Grub, but the instructions about it are loose on 3 different links and 67 comments here. Manjaro meant to be friendly, right? So, why not just say something like this:
“If you use UEFI, use this command; if you use BIOS, use that”.

Honestly, I don’t see the point of having Pamac GUI and others great resources that make the use of the OS simple, to make users that aren’t experts suffer when a manual intervention is required. It’s that hard to make it easier?

Don’t get me wrong: but I just want to do the right thing to prevent spend hours recovering or reinstalling the system because my negligence broke the OS.

Anyway, wish you the best and Merry Christmas.


:christmas_tree:Thanks, also Merry Christmas to you. :comet:

So, I deleted my previous comment.
I am going straight on this one:

I confirmed that I am using MBR/BIOS. So, looking into the documentation:

BIOS System

On a BIOS/GPT system there is no MBR and therefore no place to store the loader. The GPT partition specification allows for an unformatted partition of the BIOS boot partition type (0xEF02). The size of this partition can be as small as 1 mebibyte. The Calamares installer uses a fixed size of 32 mebibyte. On a BIOS/MBR system a part of the bootloader is written to the Master Boot Record for the primary disk.

The device is the disk (not a partition)

root # grub-install --force --target=i386-pc --recheck --boot-directory=/boot /dev/sdy

Make sure the grub configuration is up-to-date

root # grub-mkconfig -o /boot/grub/grub.cfg

So, it’s just update in Pamac and then using that 2 commands, right? Just to be sure.

Certainly, you have to replace /dev/sdy with the correct disk and delete “COPY TO CLIPBOARD” - but I guess you know this.

Double check your disks upfront with

sudo fdisk -l

You must use the disk where your / partition is located.

Yes, of curse :slight_smile:
“COPY TO CLIPBOARD” was part of the page, forget to edit this part.

I did not have a problem updating GRUB on MBR system because I followed the links to ArchWiki
in pamac update messages:

[2023-12-23T09:49:54+0000] [ALPM] installed update-grub (2.12-3)
[2023-12-23T09:49:54+0000] [ALPM-SCRIPTLET] :: Install your bootloader and generate configuration:
[2023-12-23T09:49:54+0000] [ALPM-SCRIPTLET]      UEFI: https://wiki.archlinux.org/title/GRUB#Installation
[2023-12-23T09:49:54+0000] [ALPM-SCRIPTLET]      BIOS: https://wiki.archlinux.org/title/GRUB#Installation_2

For a BIOS/MBR system

wiki.archlinux.org – GRUB - Master Boot Record (MBR) specific instructions

# grub-install --target=i386-pc /dev/sdX

where i386-pc is deliberately used regardless of your actual architecture, and /dev/sdX is the disk (not a partition) where GRUB is to be installed. For example /dev/sda or /dev/nvme0n1, or /dev/mmcblk0

Since I know that grub is installed to /dev/sda/

sudo grub-install --target=i386-pc /dev/sda;
sudo grub-mkconfig -o /boot/grub/grub.cfg

Response from running grub-mkconfig is mostly as expected except for one comment:

Adding boot menu entry for UEFI Firmware Settings …

No new menu entry for UEFI settings on this legacy BIOS system

The old user manual had a good explanation of the differences between BIOS and UEFI mode

But the Wiki section for how to reinstall on a BIOS/GPT or BIOS/MBR system is not very coherent
GRUB/Restore the GRUB Bootloader - Manjaro

I just went this way with my old laptop which has msdos formatting on hdd, mbr and luks-ext4 install. Worked out fine. Merry Christmas all devs & users.

Those are the commands from the Manjaro how-to in the Known Issues post above. ^

1 Like

With every manjaro update I know my system better. Learning is not easy. Somitimes it hurts. But it should be that way, otherwise it’s useless. So thank you manjaro team for forcing me to learn my system.


Regarding Grub

Manjaro is not Arch but we adopt a lot of what Arch Linux is doing. One of it is how grub gets installed similar to Arch. I already spoke about that last time when a config change in grub-git made systems using luks-encryption unbootable as shown here in detail.

Here is why

We normally install grub once via our installer Calamares and forget about it. The best thing is even to put grub to your ignore list of packages you want to update, as actually you never update grub which is booting your system! We never touch your grub install on MBR/EFI. Also Arch is not doing that. If you check Ubuntu or OpenSuse, their post-install scripts have a long list of detection cycles to figure out how grub was installed. When we add encryption to it it gets even harder to figure out. So we went the easy way for us to let the user remember how he installed it. Guess what: the user don’t know cos he never installed grub to begin with: our installer Calamares did that for him when he installed the OS the first time.

What we do to prevent unbootable systems

Well, we have for example update-grub script, which actually updates the grub menu, but NOT the grub on MBR/EFI. The last workaround was to mitigate the issue we had with luks encryption on older installs. Btw. luks encryption is rarely tested or non-tested at all. Same goes for XFS, which might have similar issues for other reasons.

Another way is to point the user to our Wiki when things go downhill to give the user a chance to fix the issue themselves.

Why the topic is now a topic again?

The second post is a wiki post. So any user who has TL2 rights can add some advice to that post. Since I started the post, everybody thinks I wrote that advice there. When I originally put the troubleshoots on there, there was no mention about grub at all. More or less your system will boot even you only update the package only. We normally check outdated grub installs on MBR/EFI if they break and add scripts to fix them, if needed. If you check the Arch announcements, they mentioned to reinstall grub as needed. Back then we had that EFI firmware loop issue: Arch Linux - News: Grub bootloader upgrade and configuration incompatibilities. And in March 2023 there was the luks issue most of our users had an issue with.

Why we not follow what upstream projects want?

Well, first we mostly follow what Arch Linux does. And the monolithic approach was not chosen, but might somewhen in the future. We can try to come up with a tool which remembers how grub was installed and suggest the user to use that same approach or let the user decide if they even want to update grub at all, as long as it works for them.

So what should I personally do?

Well, it is your system. We presented in rich detail the situation. So here it is:

  • grub is complex to maintain correctly
  • as any other software it has security flaws which get fixed with updates. However grub is special, as a regular package update does NOT change the grub installed to your MBR/EFI as explained already
  • You can create an unbootable system when you install grub the wrong way on MBR/EFI, so always keep a bootable USB-Stick with Manjaro on it to rescue your system as needed

Will it be fixed at some point

Well it depends …


But I do wonder why they don’t avoid the problem altogether and do without grub in the future. EndeavourOS has shown the way by switching to systemd-boot. If it’s just about a few colourful background images … pffft …

1 Like

3 posts were split to a new topic: Incorrect cursor displayed in text editors

The information in Restore the Grub Bootloader already does that, under the headings BIOS System and EFI System. Otherwise, you make some valid points.

In fact, several users have made valid points (though sometimes not as obvious when intermingled with a rant of self entitlement).

Manjaro Linux is not an easy OS for new users, despite whatever you have been led to believe. The extent that it is user friendly in comparison to Arch Linux is arguably limited to Desktop Environments being a part of the default install; whereas with Arch, you need to install most things manually.

Basic knowledge and understanding of Linux is as much a requirement for Manjaro as it is for Arch. Using Manjaro only means that some of the work is done for you. If any user is not prepared to take some responsibility, rather than expecting all the work to be done for them, I dare say, Linux (or, at least, Manjaro) is not the distribution for them. Windows, or even macOS might be a better fit.

That is all. Have an enjoyable day/night. :christmas_tree:


Well, people can now test install-grub to keep the updates in-sync: Install-grub: a new way to keep your EFI/MBR in-sync with grub package


From a quick look, your command has one little mistake at the end: you have to specify the disk, not the partition, so the command shouldn’t look like this

... /dev/sdb1

but like this:

... /dev/sdb

at the end.

I have stepped into edit mode zoomed out and in on and I realize that you misunderstand what I am referring to.
There is usually a bar that highlights the name of the app my mouse is sitting over (it is this bar that has disappeared) I call this the menu bar as it appears in the menu as a bar - but perhaps you call it something else. But to be precise I am not referring to the menubar at the bottom of the screen. In the first image is the menu from the launcher (with no visible application menuitem highlighting bar) In the second image and with all other apps the menubar I am referring to is under the arrow pointer (slightly darker shade of green - but visible)

Ok I see what your are talking about and I don’t have this problem. And did you try to reset or create/edit in Appearance → colors, maybe a theme or something like that ?

1 Like

This seems to be a KDE bug. Trial and error now.
-As suggested, try changing the accent color.

  • right click on the button that opens it (opens the Application Launcher).
    there: a) try changing from grid to list in both cases and back. b) try “use compact list item style” and back.

Do you use any widgets on your desktop that are third party, like a temperature monitor or so? If so, try removing those from desktop or panels. You don’t need to uninstall them.

While you are in trial-and-error mode, log out and back in after the steps.