[Stable Update] 2023-06-04 - Kernels, Gnome 44.1, Plasma 5.27.5, Python 3.11, Toolchain, Firefox

Brave colors defaults to “Light” every time Brave is launched even if previously set to “Dark”.

For me it’s not the theme. The browser is unusable. Pages don’t load, there’s flickering and artifacts from other windows.

I saw a note that Qt6 has moved to ffmpeg; used to have gstreamer.
Didn’t know Gstreamer was still available (haven’t upgraded yet).
Gstreamer is a Gnome GTK thing.
FFmpeg is multi-platform and is the backend in mpv player.
Probably either would work.
(For myself I would choose ffmpeg.)

1 Like

Did you miss these posts ?

I think they mean dkms works now …

Pushed them also now to testing: [Testing Update] 2023-05-20 - KDE Frameworks, Python, Haskell, Wine - #25 by philm

You weren’t. :slight_smile:

He was looking at this topic (there’s a link to it in the wiki post),
which does seem to be too complex for most Manjaro users.

Not many old sysadmins around here, who have hundreds of AUR/pip packages and like to be thorough.

I have Manjaro stable + Cinnamon and now even starting System Monitor GUI takes 15-20 sec.
Interestingly starting a Chromium Appimage comes up instantly.
I have no idea what to do now … :frowning:

yeah that guide is really only needed for people who have a lot of pip foreign packages.
Most people have none.

Oh come now …
Its been stated multiple times …
(including in the post your quoted/responded to)
check the wiki post.
xdg-desktop-portal-gnome bug

Unless it is something else … then maybe start a new thread.

1 Like

You may want to check if xdg-desktop-portal-gnome is installed and remove it. It is stated in troubleshoots.

1 Like

I have Manjaro stable + Cinnamon and now after the update (yesterday full update) even starting System Monitor GUI takes 15-20 sec.
Interestingly starting a Chromium Appimage comes up instantly.

Current kernel which is just updated an hour ago :
$ uname -a
Linux xps15 6.1.31-2-MANJARO #1 SMP PREEMPT_DYNAMIC
Changing back to latest 5.15 (also updated an hour ago) , did not change anything …

I have no idea what to do now … :frowning:

Are you intentionally avoiding all the times people have pointed out

… I might have missed a few … :sweat_smile:

1 Like

Sorry, I did not see that message … and firstly thanks a lot for your swift reply. Yes, that fixed it ! :+1:

If so many people have not seen that message, maybe a “known issues” section right under the update announcement may help to save your valuable time ?

… or where would I find it best ?

Like post #2, right under the announcement?


Well … ok, fair enough :wink:
As I am just a Majaro user and luckily everything works smooth, I do not have to check the forum very often … which is a good sign , I would say.
I promise to spend more time reading the posts next time, before posting something.

Another stupid question …
I am on Cinnamon, so its suggested to do ?

sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk

However so far I just have uninstalled the gnome version, rebooted, and so far it’s working (although have not checked much yet).
Should I install the gtk version… or can I live without it ?

1 Like

xdg-desktop-portal-gtk is a dependency of the gnome one. So it is already installed. The Tutorial can be simplified in that regard.

1 Like

Ok thanks, can confirm that after removing the gnome version, not installing the gtk version explicitly, I yet have it …

People with chromium based browser should test the option of running them with disabled gpu acceleration (–disable-gpu).

For me Chrome runs with graphical glitches after the update. Reinstalling doesn’t help, only the disable gpu option from settings. There seem to be some broken links to libraries when running in console. The strange thing is that chromium in the exact same version runs perfectly fine with gpu support.

I can’t go into the settings to disable it. Even the settings page doesn’t show anything.

I don’t use Brave so I don’t know the full command, but try running it from console with the –disable-gpu addition…