[Stable Update] 2022-11-14 - Kernels, GNOME 43.1, Plasma 5.26.3, Systemd 251.8, Firefox 106.0.5, Thunderbird, LXQt

That’s normal. :man_shrugging:

The delay happens the very first time to open nautilus after boot. Subsequent new windows are instant.

If there is some time passed with no nautilus windows open (a few mins) , then the delay will happen again.

1 Like

@Yochanan did someone forgot to build dkms without arch optdepends or was it always like that? :stuck_out_tongue:

Hello, @jpa

Did you check this thread Close, minimize and maximize buttons missing on macOS after using the restart to update option · Issue #161586 · microsoft/vscode · GitHub it seems to be vscode issue…

1 Like

Hello, @GokuSan

Thank you for your response, seems to be electron19’s update based on the last comment in that thread

I will change to native Title Bar Style in the meantime

A post was merged into an existing topic: “Oh no something has gone wrong” error after update

Indeed, it was.

❯ pacman -Si dkms | grep Packager
Packager        : Sébastien Luttringer <seblu@seblu.net>


I had hoped that this kernel update to version 6.0.8-1 would fix the problem I encountered with the 2022-11-02 Stable Update on my desktop system:

Unfortunately it has not, so I have again reverted to the 5.19 kernel for now and remain hopeful that future updates will work.

Running Gnome with the prop nvidia driver, after this update night light is not working, and the pamac update indicator is always hidden in the tray. Firefox is misbehaving a bit as well, had two or three crashes this evening so far.

I at first thought this was a problem, but if you click back on the Nautilus window you can navigate with the arrow keys and sushi will update the preview.

The previously indicated bug has landed in this stable update as well.
I have been able to restore my system from BTRFS snapshot,
to change branch to stable and upgrade without issue till this point,
when the upgrade killed my system again.
([Testing Update] 2022-11-09 - Plasma 5.26.3, Python, KDE-git - #10 by osiixy)

With @openminded we have tried to find the culprit without luck.

The only reappearing pattern is an error about missing libcrypto.so.3 during chroot rescuing before downgrading the system (and of course the “Key slot open failed” error at boot time unlocking) .

Some fact of my system:


MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)
HOOKS=(base udev plymouth autodetect keyboard keymap modconf block plymouth-encrypt filesystems resume keyboard)

luks dump (redacted)

LUKS header information
Version:       	2
Epoch:         	7
Metadata area: 	16384 [bytes]
Keyslots area: 	16744448 [bytes]
UUID:          	<<redacted>>
Label:         	(no label)
Subsystem:     	(no subsystem)
Flags:       	allow-discards 

Data segments:
  0: crypt
	offset: 16777216 [bytes]
	length: (whole device)
	cipher: aes-xts-essiv:sha256
	sector: 512 [bytes]

  0: luks2
	Key:        512 bits
	Priority:   normal
	Cipher:     aes-xts-essiv:sha256
	Cipher key: 512 bits
	PBKDF:      argon2id
	Time cost:  23
	Memory:     1048576
	Threads:    4
	Salt:       <<redacted>> 
	AF stripes: 4000
	AF hash:    whirlpool
	Area offset:32768 [bytes]
	Area length:258048 [bytes]
	Digest ID:  0
  0: pbkdf2
	Hash:       whirlpool
	Iterations: 94568
	Salt:       <<redacted>>
	Digest:     <<redacted>>

seems like it will be fixed next update: Can't move selection up or down when using Sushi (#2556) · Issues · GNOME / Files · GitLab

Ah perfect, good to know it will be fixed. For now a focus shift works alright. :slight_smile:

Night light and Pamac update indicator is working fine for me on Gnome/nvidia driver, but yes Firefox has problems now on nvidia, see here:


Did I bricked my installation? I was trying to do full system update but my idiot self thinks otherwise and try to update openssl and lib32-openssl first instead, it updates successfully but now I can’t do update, some app don’t open and the error I got from terminal is error while loading shared libraries: libcrypto.so.1.1: cannot open shared object file: No such file or directory, so is there a workaround to solve this issue?

In addition to this, I can’t even do sudo ln -s /usr/lib/libcrypto.so /usr/lib/libcrypto.so.1.1 to try to solve it (sudo part can’t be executed)

1 Like

Why you symlink when there are packages for that: openssl-1.1 and lib32-openssl-1.1 @deanrih

No update from my side since months or years and it works apparently perfectly after this update that I have finally made! Thanks for the good work! It is impressive!

1 Like

Because it wasn’t installed yet, and now I can’t do pacman and paru to install openssl-1.1 and lib32-openssl-1.1, as I said, instead of doing full update, I update openssl and lib32-openssl separately, which is a dumb thing to do by me


Currently waiting for the latest ISO to be downloaded before I even shutdown the PC in hope that I can fix it through chroot

I fix the issue by… copying and pasting previous openssl and lib32-openssl version files from old Manjaro version, not the most elegant solution but hey, it works, lmao


I haven’t managed to do proper update yet because I need to go to work, will post an update if I successfully upgrade the system with this approach or not



Upgrade went smoothly, everything seems to be working properly.

1 Like

I can no longer output to my 2 external monitors at 144 Hz. The monitors are connected via docking station. When I login I run a command to extend them both to the right of my laptop display at their native resolution (2560x1440) and both at 144 Hz. This no longer works. The third display remains off and I get xrandr saying “Configure crtc x failed”.

Also this was already a problem, but when I login with the dock and monitors attached, my desktop is shifted one screen. So the wallpaper of display 1 is now on 2, and the wallpaper of display 2 is now on 3, and the wallpaper of 3 is in the void. Among other problems… But at least I could still use them before.

Now I can only use them if I set them to 60 Hz, but this is unacceptable for my uses. I’d also like to know why the monitors no longer turn on immediately when I plug the dock in (this is why I wrote the login script) - but this was a problem before the update too.

But yeah, bottom line: I can no longer use my dock-attached external displays the way I’ve been using them and I don’t know how/why. I’ve looked online relating to this crtc thing but the details are vague. And the only “helpful” resources I’ve found just tell me to lower the refresh rate, but once again they were fine operating at the high refresh rates before my updating today. I really hope I can get this resolved asap! I may try undoing the updates with timeshift to see if it was truly the updates that caused it - let me know if this is safe to do lol.

Edit: now sddm isn’t loading for me. Not sure if related but makes it very hard to debug issues now since I’m stuck in a TTY…

Edit 2: I have restored to yesterday’s files. I can log in again. Still having the same monitor issues though so I guess it wasn’t the updates. But I’m still at a loss. It was working just fine this morning… Anyone got any ideas how to “debug” this new fangled thunderbolt stuff?

Edit 3: It’s not hardware related. Everything works fine on the Manjaro live USB. I’m pretty confident it’s KDE at the point. Would love to clear the relevant settings+cache (i.e. not all of them).

1 Like