[Stable Update] 2022-11-02 - Kernel, Plasma 5.26.2, Plasma Mobile Gear 22.09, LibreOffice, Virtualbox 7.0.2, Systemd, Mesa

Edit: Audio working again after full shutdown and power up instead of reboot.

Pulseaudio no longer recognising bluetooth speakers/headphones after the latest update. I can connect them and bluetooth recognises them as headphones but they are not available in the audio settings.

LibreOffice issue appears to be fixed, my work around is no longer necessary.

The latest version of VirtualBox ignored my out of band hacks. This isn’t a problem with the upgrade, more a problem for my hack which attempts to force a square peg into a round hole. Where I make VBox act as if it’s in Full screen mode.

My KWin shortcut for moving to the next desktop virtual desktops (KDE) doesn’t loop around to the first anymore.

I fixed it by finding a presumably new option called “Navigation wraps around” in Workspace behaviour → Virtual Desktops → Navigation wraps around.

1 Like

cryptsetup seems to have dissappeared from my laptop after the this update. Now I am stuck in failover shell.

After the update my installed snap applications (Spotify and Discord) wont start anymore. Spotify gives me the following error, when trying to start it via terminal:

/snap/spotify/60/usr/bin/spotify: error while loading shared libraries: /snap/spotify/60/usr/lib/x86_64-linux-gnu/libthai.so.0: ELF file's phentsize not the expected size

While I was able to change the Discord-client to the version on “Official Repositories (community)” there’s currently no such alternative for Spotify (or at least I can’t find it).
Also all snap functionality seems to be removed from the “Add/Remove Software” application, even after reinstalling snapd, snapd-glib and libpamac-snap-plugin.
Have I missed an announcement that snap was removed from Manjaro or something like that?

Edit: After installing an update of snapd-glib (1.63-2.0 built 2022.11.04 21:55:19 CET) I’m displayed another error when trying to launch Spotify via terminal:

chmod: chmod: no version information available (required by chmod)
chmod: symbol lookup error: chmod: undefined symbol: 
/snap/spotify/60/usr/bin/spotify: /lib/x86_64-linux-gnu/libuuid.so.1: unsupported version 0 of Verdef record
/snap/spotify/60/usr/bin/spotify: error while loading shared libraries: /snap/spotify/60/gnome-platform/usr/lib/x86_64-linux-gnu/libpsl.so.5: unsupported version 0 of Verneed record

Edit 2:
After another reboot of the system the problem seems to be solved.

System info:

  • Operating System: Manjaro Linux
  • KDE Plasma Version: 5.26.2
  • KDE Frameworks Version: 5.99.0
  • Qt Version: 5.15.6
  • Kernel Version: 6.0.6-1-MANJARO (64-bit)
  • Graphics Platform: X11

As a test I installed the 5.19 kernel and the system boots and runs as normal. This implies to me that the problem, [FAILED] Failed to start Load Kernel Modules, is or related to this particular kernel version 6.0.6-1 for my desktop hardware? Earlier versions of 6 worked ok.

If that is the case then probably my best solution is to wait for the next 6.0.x kernel update.

After updating, I’m unable to login locally (XFCE). No mouse or keyboard. Unable to switch to alternate console.

I’m able to ssh in, and run “shutdown -r”. Default kernel is 5.15.76. Reboot takes a long time, complains about modprobe, system-udevd, rasdaemon, and maybe others.

Booting with fall-back kernel of 5.10 works fine thus far.

I’m out of ideas for today, but will re-visit tomorrow. At least system seems to work with older kernel.

Uninstalling rasdaemon enabled the system to run after the latest update.

This I’ve got the same problems as kippie.

When I tried to reinstall Manjaro via bootable drive, the icons are back up again. But when I’m update it’s all gone. Something the updates is causing my stuff to bad.

Any help by the way?

create a new test user, log out and log in with it, and see if it has also issues…

Minor issue where various KDE apps (Dolphin, Konsole, Kate, KSystemLog) have forgotten window size/position settings. Not a big deal but annoying all the same.

Created a test user and the icons show up. But when I hover on them, they disappear.
Tried also reverting updates via installing from the latest installer Ruach, and didn’t install the following:

No dice. I still get the same no icons problem. The font on some of my windows are also kinda funky.

I think I’m having the same problems as this guy: All desktop and menu icons missing
But I don’t have the same packages installed as his. Tried also the mhwd commands with the top answer, but nothing happens with my case. I’m using AMD radeon rx 6800 xt as graphics card. Not nvidia


the windows/Super L keyboard key is permanently bound to the application menu regardless of what app menu is being used and there’s no obvious way to unbind it

in my case the windows/Super L key is not bound to anything in settings > shortcuts or settings > custom shortcuts

that other user with the exact issue, had installed the wrong drivers… and its not a messed up config, since it didnt work with the test user too…
try switching kernels;
also provide output from:
inxi -G && mhwd -l -li

Inside ~/.config/kwinrc look for


then comment it and see if it unbind the Meta key.

Has anyone experienced blackish Dolphin icon in the Dashboard menu with Breeze theme instead of blue one? How can i change one to regular blue?

I have the same problem.
My extended screen does not work anymore with KDE Plasma.
At login I see both screens, and the only the main screen is usable.
This is my hardware:

inxi -F

  Host: legion5 Kernel: 6.0.6-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.2 Distro: Manjaro Linux
  Type: Laptop System: LENOVO product: 82JU v: Legion 5 15ACH6H
  Mobo: LENOVO model: LNVNB161216 
     UEFI: LENOVO v: 
  ID-1: BAT0 charge: 80.2 Wh (97.0%) condition: 82.7/80.0 Wh (103.4%)
  Info: 6-core model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 3 MiB
  Speed (MHz): avg: 1406 min/max: 1200/4280 cores: 1: 1457 2: 1200 3: 1200
    4: 1200 5: 1200 6: 3300 7: 1197 8: 1200 9: 1197 10: 1200 11: 1266 12: 1264
  Device-1: NVIDIA GA106M [GeForce RTX 3060 Mobile / Max-Q] driver: nvidia
    v: 520.56.06
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.4 driver: N/A
    resolution: 1: 1920x1080~120Hz 2: N/A
  API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce RTX 3060
    Laptop GPU/PCIe/SSE2

Is there a way to diagnose this problem?

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Enabling the second screen did not help. All screens go black and then the revert back to the single screen.

My kernels are already at 5.15. Been staying there kind of the whole time until the update. When I had the issue I tried upgrading to 6.0, and 5.19 and downgrading to 5.10, since I figure it might have been that. Nothing works still.
Here’s my results:

  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu
    v: kernel
  Device-2: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Device-3: Logitech Webcam C310 type: USB driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org v: 21.1.4 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu resolution:
    1: 1920x1080~60Hz 2: 1920x1080~60Hz 3: 1920x1080~60Hz
  API: OpenGL v: 4.6 Mesa 22.2.1 renderer: AMD Radeon RX 6800 XT (navi21
    LLVM 14.0.6 DRM 3.42 5.15.76-1-MANJARO)
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:03:00.0 (0300:1002:73bf) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:0c:00.0 (0300:1002:15d8) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

> 0000:07:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

Oh I tried the command for mhwd again, although it didn’t work, I realized the reason why it isn’t, is that the command isn’t switching to the proprietary drivers. I keep getting the free one. I also looked at the GUI checkbox in case I could change it there, but they’re kinda unclickable,

Yubico Authenticator doesn’t show the codes.
I’ve tried:
sudo systemctl start pcscd
sudo systemctl enable pcscd

My Yubikey is ok.
ykman info
Device type: YubiKey 5 NFC
Serial number: 9264957
Firmware version: 5.1.2
Form factor: Keychain (USB-A)
Enabled USB interfaces: OTP, FIDO, CCID
NFC transport is enabled.
Applications USB NFC
FIDO2 Enabled Enabled
OTP Enabled Enabled
FIDO U2F Enabled Enabled
OATH Enabled Enabled
YubiHSM Auth Not available Not available
OpenPGP Enabled Enabled
PIV Enabled Disabled

Downgrade yubikey-manager to 4.09.-1 and is works fine.
It seems it is bug.

One (very minor) problem I’ve found with this is that XScreenSaver’s GL Slideshow no longer displays any of the chosen images.
This is due to the new version of Perl throwing a fatal error when attempting to use syswrite() on a UTF8 filehandle.
I’ve raised a bug up-stream, but I have found a workaround:
Edit /usr/lib/xscreensaver/xscreensaver-getimage-file and comment out lines 1552 and 1553. This makes it work again, though I don’t know if there are any other implications to doing this.