Firefox keeps completely freezing randomly

To be perfectly honest I’ve also had the idea that disabling hardware acceleration in Firefox doesn’t in fact feel detrimental – but, well, it likely is in specific situation.

Are you also on Nvidia? If so this might be Nvidia specific I guess. I as said don’t have the Downloads issue/trigger available on (very) old Intel integrated graphics.

Yes RTX2060 and driver 520.56.06.

If you’re curious or feel socially inclined towards other users I guess you could try and see whether or not switching to the open-source “nouveau” driver allows to re-enable Firefox’ hardware accel.

No, But i do have 2 Laptops, with AMD K8/Radeon, and AMD Ryzen/Vega, I’ll update them at some point and see if it happens on them.

OK. For someone else possibly interested in testing nvidia/nouveau difference: it seem you can on Manjaro do so easily as per How do I switch between Nvidia and Nouveau drivers on boot? - #4 by stephane

Still would like to know how or why this is happening as it was working fine before today’s update?

I’ve also been having this issue, with firefox freezing at first and then seemingly all of GDM until I switch to a different terminal and restart GDM. I just turned off HW accel and am hoping it helps for the time being.
(I’m on a laptop with a RTX3070 mobile gpu.)


Firefox 107.0 did not fix the problem, Still need to turn off performance and hardware acceleration.

i’ve uptate to 107.0 and no freeze after many hours of using ff .
You can use mozregression to verify .
“mozregression --find-fix --repo=mozilla-release --good 107 --bad 106.0.5”

in my case problem solved .

I have a similar problem about firefox in the KDE. Suddenly, ff got freezed. In fact, the title bar, therefore the closed button, of ff disappears. In fact, the title bar of other applications also disappear. Moreover, the panel of kde also disappears and I can’t change to other applications by shift+tab.

I don’t know wether this is a KDE problem or a ff problem. But it seems very similar to the bugs discussed in this topic.

1 Like

Nope, still immediately freezes after trying to open the Downloads window.

1 Like

Hi, I’m also having the same issue. I’ve tried downgrading firefox from 107 down all the way to 105, and it still froze from time to time. I’ve also tried changing kernels and disabling hardware acceleration to no avail.

For me the freeze didn’t happened when opening the download page, but when copping text either from firefox or to firefox.


I’m also experiencing sporadic freezing issues again as well. For me, the issue is on-again, off-again for weeks now after experimenting with different acceleration options. Some problem correlations are multi-monitors, video streaming, and problems when attempting to open (or switching to) new tabs or instances. Can anyone please post any recent core dumps from journalctl? I still don’t have any items in about:crashes. Maybe (if not hw-related), explore UI/theming issues again?

a recent core dump of mine

systemd-coredump[31550]: [🡕] Process 31548 (firefox) of user 1000 dumped core.

                                           Stack trace of thread 31548:
                                           #0  0x00007fdab8a79874 XDisplayString ( + 0x2b874)
                                           #1  0x00007fdab77f4a1d __vaDriverInit_1_13 ( + 0xda1d)
                                           #2  0x00007fdaab755c9c n/a ( + 0x3c9c)
                                           #3  0x00007fdaab75adf1 vaInitialize ( + 0x8df1)
                                           #4  0x00007fdab4151347 n/a ( + 0x8751347)
                                           #5  0x00007fdab4151f1e n/a ( + 0x8751f1e)
                                           #6  0x00007fdaaff6ccde n/a ( + 0x456ccde)
                                           #7  0x00007fdaaff6a31d n/a ( + 0x456a31d)
                                           #8  0x00007fdaaff5c2b5 n/a ( + 0x455c2b5)
                                           #9  0x00007fdaaff5b46d n/a ( + 0x455b46d)
                                           #10 0x000055db27a84cec n/a (firefox + 0x58cec)
                                           #11 0x00007fdaba83c290 n/a ( + 0x23290)
                                           #12 0x00007fdaba83c34a __libc_start_main ( + 0x2334a)
                                           #13 0x000055db27a94cc5 _start (firefox + 0x68cc5)
                                           ELF object binary architecture: AMD x86-64
1 Like

I’ve problem with Firefox
Its non functional after latest update.
I could tray reinstalling, starting with debugger mode and so on but unfortunately couldn`t get any visual piece of Firefox. Its looks like frezed window contain noting. Catches other window’s visuals. Can be related X11 maybe. Because its renders nothing.

firefox --version
Mozilla Firefox 107.0
██████████████████  ████████   axe@axe-inspiron3585 
██████████████████  ████████   -------------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: Inspiron 3585 1.4.0 
████████            ████████   Kernel: 5.15.78-1-MANJARO 
████████  ████████  ████████   Uptime: 1 hour, 18 mins 
████████  ████████  ████████   Packages: 1871 (pacman) 
████████  ████████  ████████   Shell: bash 5.1.16 
████████  ████████  ████████   Resolution: 1920x1080 
████████  ████████  ████████   WM: i3 
████████  ████████  ████████   Theme: Adapta-Nokto-Eta-Maia [GTK2/3] 
████████  ████████  ████████   Icons: Papirus-Adapta-Nokto-Maia [GTK2/3] 
████████  ████████  ████████   Terminal: urxvt 
████████  ████████  ████████   Terminal Font: 9x15,xft 
                               CPU: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx (8) @ 2.000GHz 
                               GPU: AMD ATI Radeon Vega Series / Radeon Vega Mobile Series 
                               Memory: 2555MiB / 5823MiB 

I couldn’t manage to get coredump file from gdb which I applied these steps.

coredumpctl list|grep firefox
coredumpctl list|grep 1116

Just I`ve following…

cat /proc/1116/cmdline 

Could you clarify more, how can I get it? Because I’ve also problem with firefox

@maxemilian, just take a look if you have any obvious error entries since your last boot: $
journalctl -b -p3 --no-pager --no-hostname

Here it is no notable thing…

Nov 20 14:01:07 kernel: tpm_crb MSFT0101:00: can't request region for resource [mem 0x4f76f000-0x4f772fff]
Nov 20 14:01:07 bluetoothd[484]: src/plugin.c:plugin_init() Failed to init vcp plugin
Nov 20 14:01:07 bluetoothd[484]: src/plugin.c:plugin_init() Failed to init mcp plugin
Nov 20 14:01:07 bluetoothd[484]: src/plugin.c:plugin_init() Failed to init bap plugin
Nov 20 14:01:17 lightdm[729]: gkr-pam: unable to locate daemon control file

We might have different issues. Maybe it’s still worth checking like a week back versus last boot.

journalctl -p2 --no-pager --no-hostname --since 2022-11-13

1 Like

Okay, tested 2 Laptops AMD Powered.

Older HP Laptop, AMD FX with Radeon R7, does this: I have a problem with Mozilla Firefox

And the Newer Laptop, Acer Ryzen 3 with Vega works as it should!!, No problems!!

So not sure whats going on With Manjaro/Firefox?

You know what’s funny about my situation when ff decides to randomly stop? My old friend, the frozen-window desktop snake effect is back if new apps are launched and dragged on the current workspace. I missed seeing this from back in the day, it’s a cool effect. :sunglasses: :cold_face:

P.S. I did a firefox “refresh” and cache blown away, no effect.