[Stable Update] 2022-10-10 - Kernels, Octopi, Deepin, GlibC, Haskell, Python; Nvidia 520.56.06

Hello community,

Another stable branch update with some usual package updates for you.


We partnered up with Slimbook to bring the Titan Gaming Laptop to our Community, including 50 € launch discount!

  • We updated most of our Kernels
    • This includes the release of 6.0 kernel series
    • Note that linux518 got dropped from our repos
  • Nvidia 520.56.06 fixes some regressions on laptops and adds new features to the driver
  • Octopi is now at 0.14.0
  • Deepin gained some updates
  • GlibC fixed some issues, including locale generation
  • Some KDE-git, Haskell and Python updates as usual

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.261
  • linux54 5.4.218
  • linux510 5.10.148
  • linux515 5.15.74
  • linux519 5.19.16
  • linux60 6.0.2
  • linux515-rt 5.15.71_rt51
  • linux519-rt 5.19.0_rt10

Package changes (Fri Oct 7 09:42:23 CEST 2022)

  • stable community x86_64: 687 new and 670 removed package(s)
  • stable core x86_64: 21 new and 24 removed package(s)
  • stable extra x86_64: 315 new and 324 removed package(s)
  • stable kde-unstable x86_64: 355 new and 355 removed package(s)
  • stable multilib x86_64: 3 new and 3 removed package(s)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

:information_source: This is a wiki post; please edit as necessary.
:star: Please, consider subscribing to the Stable Updates Announcements RSS feed

Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:

:arrow_right: 2022-10-28

signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.

NVIDIA 520.56.06 Color banding and animation issues

Current (not so good) Workaround:

  • Open nvidia-settings
  • Select the problematic monitor under the GPU Tab (e.g. DP-0 - (LG ...))
  • Under Controls, change Depth to 6 bpc (or play with the Dithering Controls)

NVIDIA already replied to the Bug-Report, so there is a good chance that this issue will be fixed with the next NVIDIA driver release.


Various Linux Kernel WLAN security issues (RCE/DOS) found

New Kernel versions are out that fix the RCO and DOS vulnerabilities in the WiFi stack published on Wednesday. They can be exploited over the air, so better update to 6.0.2, 5.19.16, 5.15.74, 5.10.148, or 5.4.218 soon!


Removing python2 from the repositories

2022-09-23 - Jelle van der Waa

Python 2 went end of life January 2020. Since then we have been actively cutting down the number of projects depending on python2 in our repositories, and we have finally been able to drop it from our distribution. If you still have python2 installed on your system consider removing it and any python2 package.

If you still require the python2 package you can keep it around, but please be aware that there will be no security updates. If you need a patched package please consult the AUR, or use an unofficial user repository.*

Arch Linux - News: Removing python2 from the repositories

* Note: Unofficial user repositories are not supported

Nvidia 3060RTX cards may have issues with the 515.76 driver
ceph, ceph-libs and ceph-mgr dropped to the AUR

These packages will most likely be orphaned and can be removed. See:

Arch Linux - Todo: Removal of ceph

Fixed: timeshift-gtk dumping core for some setups

ongoing discussion:
Timeshift-gtk dumps core

Update to timeshift 22.06.5-3

Openh264 2.3.1-1 update might prevent some applications from launching

With the latest openh264 update so-file name changed. Some applications however still expect so.6. As a workaround the following symlink can be used for now.

sudo ln -s /usr/lib/libopenh264.so.2.3.1 /usr/lib/libopenh264.so.6


Changes with Back In Time packages
  • backintime has been renamed to backintime-qt
  • backintime-cli has been renamed to backintime

After replacing backintime-cli with backintime, you will need to install backintime-qt manually if you want the Qt frontend installed again.

electron12, electron13, electron14 & electron16 have been dropped to the AUR

Unsupported Electron packages have been dropped from the official repos to the AUR. They no longer receive security updates and nothing in the repos depend on them.

If you have AUR packages depending on those versions, install the binary version from the AUR to replace them; i.e., electron16-bin.

See FS#75490 - electron12, electron13, electron14, electron16 are unsupported and vulnerable packages

End of Support for 15.x.y and 16.x.y

Electron 15.x.y and 16.x.y has reached end-of-support. As per Electron’s new 8-week cadence, we were supporting the latest four versions of Electron until May 2022. With this Electron 19 release, we’ll return to supporting the latest three major versions, as well as the alpha, beta, and nightly releases.

Release electron v19.0.0 · electron/electron · GitHub

element-desktop dependency error
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rekeyringbuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su


Fixed: suil 0.10.16-1 breaks LV2 plugin GUIs in Ardour

Arch removed gtk2 compatibility in suil which is required by Ardour. Best solution is to downgrade to suil-0.10.12-2.

Update to suil 0.10.16-3


element-desktop dependency error
error: failed to prepare transaction (could not satisfy dependencies)
:: installing electron (20.0.0-1) breaks dependency 'electron19' required by element-desktop

The upstream package was already flagged out of date (it needs to be rebuilt against latest electron).

Workaround for now:

sudo pacman -Syy electron electron19 --asdeps
sudo pacman -Su


Glibc 2.36 update will break EasyAntiCheat within Proton (should be fixed with glibc 2.36-2)

The following should no longer be needed:

Temporary workaround for now is to use the flatpak version of steam:

sudo pacman -S flatpak --needed --noconfirm
sudo flatpak install com.valvesoftware.Steam -y

You can use flatseal (another flatpak app) to grant it access to your existing game library so you don’t have to re-download your games (add the game library install path under “Other files” under “Filesystem”).

sudo flatpak install com.github.tchx84.Flatseal -y

For advanced users (not recommended by us): patched glibc and lib32-glibc are available here. They remove the commit that broke EAC.

1 Like

Whoops, I’m too early here, I’ll wait for the votes to fill up before deciding on updating or not

1 Like

Wow, already? It took me 2 days to update last time (because of multiple reeeally slow-building AUR packages and some conflicts) and 5 days later, there’s another one!


4 posts were split to a new topic: Can we have at least 10 days time between the releases?

Seems to be working perfectly. Happy for Kernel 6.0 especially! Thanks for the update.

Is this news service still going to work by the way? Yesterday it sent an announcement about its existing owner discontinuing it and looking for someone else in the Manjaro team to continue Matray.


Telegram Desktop and Texstudio still do not work.

See the discussion in

[Stable Update] 2022-10-05 - Kernels, Systemd, AMDVLK, Deepin, Pamac, QEMU, Thunderbird, Firefox, 0 A.D., Gradience, Linux Firmware, WINE, GNOME, Pipewire

1 Like

Qbittorrent 4.54.5-1 from the official repos still core dumping. Switched back to qbittorrent-qt5.

In XFCE, Panel 0 is set to hide intelligently. When I hover over to where it is while a window is open, it no longer appears unless I hit the super key to bring out the menu.

I guess this only happens in kernel 6.0.0-1? Will have to go back to 5.19.14-1 to double check.

My only issue is now I see “Geoclue Demo Agent” process in KDE System Monitor, but I don’t use any application with location (all maps on my phone and browser), so when I try to uninstall it Pamac says it needs for xdg-desktop-portal which I don’t know what it is… How to disable it at least?

Hi folks,
I have issue using LibreOffice and Samba.
After both updates from 05-10 and today’s one, every LibreOffice file that I opened are stuck on a thin border. I must every time use context menu and Maximize, so I can work on the document.
The problem with samba is that when I browse a smb share folders using Dolphin I saved my password but then when open a LibreOffice document or create a new text file or folder and etc it keep asking me for username and password. And even after I reentered them again it just keeps going asking and didn’t create file or folder. LibreOffice’s files are opening only as read-only, cause can not create a lock file for them in the samba folder. I can copy and paste files and folders, but can not create new one inside the shared folder or to edit office document.
I tried to start dolphin using console to see any error msg or whatever, but there are nothing.
Any suggestions for those issues or command to execute, so I can provide more information ?

1 Like

…no,everything fine here, “intellgently hide” works as expected - linux60

Coming from a newbie so take it with pinch of salt or something. I have been using element from flatpak for sometime now and I was wondering if it would be better to just make it a flatpak package as it, having issues and workarounds probably just makes it not ideal for first time installers. As for the flatpak package it has no big problem. So I was thinking if going with flatpak/flathub element-desktop is going to lessen the the maintaing cost and also be a help in adopting flatpak.

Thank you for this nice update! It went well. I had problems downloading the new kernel, but after a change of mirrors, I’m now running 6.0.

Same problem here!

A post was split to a new topic: After the update I am not getting to the graphical login

Timeshift GUI still crashing after this update.


On my system too. Creating backup with Timeshift GUI would crash and not create the backup. I tested this before update and after update. But the automated weekly backups seems to be created fine I think.

Both work like a charm on my machine. What is texstudio’s output if you try to start it in a terminal window?

very minor issue since updating, my battery status shows as charging whether or not I have the machine plugged in. Anyone else experiencing this?