[Stable Update] 2022-10-05 - Kernels, Systemd, AMDVLK, Deepin, Pamac, QEMU, Thunderbird, Firefox, 0 A.D., Gradience, Linux Firmware, WINE, GNOME, Pipewire

After the update, VLC started showing the “VLC could not identify the audio or video codec” error on all videos and stopped displaying subtitles. When I launch it through the console, I get

VLC media player Vetinari (revision 3.0.13-8-g41878ff4f2)
[000055a203818550] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[000055a2038ee9a0] vlcpulse audio output error: digital pass-through stream connection failure: Not supported
[000055a2038ee9a0] main audio output error: module not functional
[00007f9921229670] main decoder error: failed to create audio output
[00007f99212312f0] main decoder error: could not identify codec
[00007f9914007390] gl gl: Initialized libplacebo v4.208.0 (API v208)
libva error: vaGetDriverNameByIndex() failed with unknown libva error, driver_name = (null)
[00007f9914007390] glconv_vaapi_x11 gl error: vaInitialize: unknown libva error
[00007f9920d699c0] avcodec decoder: Using Mesa Gallium driver 22.1.7 for AMD RENOIR (LLVM 14.0.6, DRM 3.42, 5.15.71-1-MANJARO) for hardware decoding

Looks like the same error as reported for Arch (I’m not allowed to add links, but the post can be googled by “VLC Unidentified codec error”). There it says that the new libebml is the problem.

in my opinion, this is an issue

Well, the PKGBUILDs for 5.24 can been found here: Packages / temp / kde-stable · GitLab. If others still need it they can been build via sudo chrootbuild -l plasma after installing manjaro-chrootbuild.

Hi, I’m having quite a big issue,

I rebooted my machine after updating it and it takes at least 15mins to load sddm, and it’s impossible to log in from here. All I can do is log from a tty (which takes a few minutes as well) and running startx does not work either.
How to fix this ?

I got the same error. It was recommended I update mirrors and update, so I ran sudo pacman-mirrors -f5 && sudo pacman -Syyu

In doing this, I got the following error:

error: failed to commit transaction (conflicting files)
fuse3: /usr/bin/fusermount3 exists in filesystem
fuse3: /usr/bin/mount.fuse3 exists in filesystem
fuse3: /usr/include/fuse3/cuse_lowlevel.h exists in filesystem
fuse3: /usr/include/fuse3/fuse.h exists in filesystem
fuse3: /usr/include/fuse3/fuse_common.h exists in filesystem
fuse3: /usr/include/fuse3/fuse_log.h exists in filesystem
fuse3: /usr/include/fuse3/fuse_lowlevel.h exists in filesystem
fuse3: /usr/include/fuse3/fuse_opt.h exists in filesystem
fuse3: /usr/lib/libfuse3.so exists in filesystem
fuse3: /usr/lib/libfuse3.so.3 exists in filesystem
fuse3: /usr/lib/pkgconfig/fuse3.pc exists in filesystem
fuse3: /usr/lib/udev/rules.d/99-fuse3.rules exists in filesystem
fuse3: /usr/share/man/man1/fusermount3.1.gz exists in filesystem
fuse3: /usr/share/man/man8/mount.fuse3.8.gz exists in filesystem
Errors occurred, no packages were upgraded.

Not sure what to do now. Ideas?

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Subsequent posts have been removed. Thanks for creating your own support thread. :wink:

MKVToolNix is broken again, it’s been broken about 5 times in the last 2 years.

1 Like

KDE issue here - anyone getting xdg-desktop-portal-kde dumping its core when kde loads up? I seem to see a couple of mentions on the arch linux forums from half a month ago (which kind of makes sense) but no solution that I can find. Reinstalling it doesn’t fix it. Anyone have any ideas?

1 Like

indeed the issue is with new libebml, or rather these dependencies of it (vlc, mkvtool*) not being rebuilt and available in stable branch for now. for the time being you can downgrade libebml.


I am seeing that too, but is it actually causing a specific problem for you?

If I check
systemctl --user status plasma-xdg-desktop-portal-kde
I see “Desktop portal registered successfully” about 12 seconds after the core dump, and status is “active (running)”. I haven’t experienced any problems, but I’m not sure that I’m using anything which relies on xdg-desktop-portal-kde.


No, it’s not causing any problems, as far as I can tell. Yeah the service is running. I guess it doesn’t matter if it’s not causing a problem

I did suffer the ceph-lib forever make loop, but many thanks to folks on this forum for making the solution so easy to find - and implement (i.e., uninstalling the ceph-lib legacy code). :+1:

Hi @manyaro01,
I’ve the same matter and it give Me an error message when trying to delete incomplete snapshots:

E: Failed to remove directory

Do You have the same bug?

I hope You take care of You :wink:

strangely, rebooting after applying the update loaded up my BIOS… exited out, got my typical grub boot options, and all seems fine

I also noted the plasma-xdg-desktop-portal-kde crash in the journal, but as the system loaded to desktop fine it was probably an early failure that was recovered from as @Takakage pointed out…

open a terminal and:
sudo timeshift --check
I should fix it

Add/Remove Software didn’t show the stable updates on one of my systems, I was able to update some files using “sudo pacman -Syyu”, but some files didn’t update, like my system still says it’s on Gnome 42.4. I refreshed the databases and the mirrors, made sure there weren’t any .part files under /var/lib/pacman/sync; anything else I should try/check? Thanks!

That’s because gnome-desktop was not updated. There were only minor 42.5 updates for some packages. See https://ftp-osl.osuosl.org/pub/gnome/core/42/42.5/NEWS

1 Like

My updates went fine, but pamac on my GNOME notebook keeps showing its tray icon even though it shouldn’t when fully up to date. My XFCE box is behaving correctly in this regard. It’s really the smallest of annoyances, but is there a way to fix this?

After the update I had no sound from speakers/headphones. The system is 9th gen Intel laptop with Realtek ALC1220 sound card. Also the detection of plugging in the headphones didn’t work.
Fixed by adding a file /etc/modprobe.d/modprobe.conf with contents:

options snd_hda_intel probe_mask=1

Probably the issue appeared with 2022-09-12 update or earlier, but I didn’t notice it because I used the headphone output of the monitor.

1 Like

Three things went wrong for me on Gnome with Wayland:

  1. Wayland was no longer enabled and my system switched back to X11. Managed to fix that by going through the thread about enabling Wayland on Gnome + Nvidia again.
  2. Fractional scaling was disabled for some reason, after the above. I fixed that by enabling fractional scaling again through gsettings.
  3. I can no longer select my primary monitor. The dropdown still works but setting it doesn’t seem to work and my selection does not persist when moving away from the monitor settings. I haven’t found a fix for this.

Aside from these three, I had two other issues which I was able to resolve with the troubleshooting in this thread (electron16 & python2). So thanks for that effort.

It did take my several reboots throughout the update and the fixes above to get everything going again.