[Stable Update] 2022-06-12 - Kernels, Systemd 251, GNOME 42.2, KDE Gear 20.04.2, NVIDIA, Mesa, Pulseaudio, Pipewire, LibreOffice

Hello community,

Another stable branch update with some usual updates for you.

image
Don’t miss out on 20% discount on all Manjaro Merch! Visit one of our stores now!

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You get the latest stable releases of Manjaro from CDN77.


Our current supported kernels

  • linux419 4.19.246
  • linux54 5.4.197
  • linux510 5.10.121
  • linux515 5.15.46
  • linux517 5.17.14
  • linux518 5.18.3
  • linux519 5.19-rc1
  • linux515-rt 5.15.44_rt46
  • linux518-rt 5.18.0_rt11

Package Changes
A detailed list of all changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

24 Likes

Known issues and solutions

:information_source: This is a wiki post; please edit as necessary.
:star: Please, consider subscribing to the Stable Updates Announcements RSS feed


Please don’t post to say everything was great on my side or yes, I have the same error but leave the space for people having issues, or even better: for people having solutions!
Use :beer: :coffee: :heart: instead to let us know you’re suffering from the same so we can respond to the highest impacted issues first! :unicorn: :rainbow: :question:


:arrow_right: 2022-06-12

Akonadi (KMail / Kontact / KOrganizer...) fails to start
touch ~/.local/share/akonadi/db_data/ib_logfile0
akonadictl start
mariadb-upgrade --defaults-file=~/.local/share/akonadi/mysql.conf --socket=/run/user/$(id -u)/akonadi/mysql.socket
Locale file changes

C.UTF8 locale is now included in glibc:

Credits @diabonas for this change. Systemd wants us to include C.UTF8 by default and it seems the locale may be in included by glibc upstream in the future. To fix building and avoid nasty fixing in devtools, we include the locale in the package. See systemd/systemd#23252 (comment) FS#74864 : [systemd] >= 251 breaks devtools' locale

There is a pacsave for /etc/locale.conf as it has been removed from the filesystem package. /etc/locale.conf will automatically be restored if it did not already exist.

There is a pacnew for /etc/locale.gen. Please review it and regenerate your locale if necessary.

2022-05-13

Chromium / Google Chrome cannot save files to most folders (GNOME and Xfce)

This is an upstream bug with the package xdg-desktop-portal-gnome

In the meantime, you can try to remove the package xdg-desktop-portal-gnome (if feasible, without any dependency issues or conflicts), or wait for the bug to be fixed upstream.

Without any xdg-desktop-portal-* packages, Chromium and Google Chrome should correctly detect the environment and present either KDialog (KDE) or GTK file picker (GNOME, Xfce) upon saving and downloading files.

An alternative workaround, for now, is to intentionally click on the filename field, and then press Enter to save / download the file.

GNOME 42: theming and COSMIC packages changes, Bluetooth disabled by default
libkipi: Pamac fails to build the package from AUR
  • libkipi is a deprecated dependency for some KDE applications, and has been moved to AUR.
  • When using Pamac graphically, you can disable the update for libkipi, before removing it from your system.
  • When using Pamac from the terminal, you can proceed the update in multiple steps:
pamac upgrade --no-aur
pamac remove libkipi
pamac upgrade --aur
Timeshift: new rsync snapshots do not show
Wine: cannot be built locally

2022-05-10

QEMU >= 7.0.0 changes split package setup

2022-05-09 - David Runge

With the update to qemu 7.0.0 the package has been turned into a more fine grained split package utilizing meta packages.

  • The qemu package is now virtually provided by the meta packages qemu-base, qemu-desktop and qemu-full.
  • The functionality of qemu prior to 7.0.0 is replaced by qemu-desktop
  • The functionality of qemu-headless is replaced by qemu-base
  • The functionality of qemu-arch-extra and qemu-headless-arch-extra is replaced by qemu-emulators-full
  • The meta package qemu-full provides all QEMU related packages (excluding qemu-guest-agent)

2022-04-15

KeePassXC auto-type does not work

Upgrading KeePassXC from version 2.6.6 to 2.7.0 partially breaks the “auto-type” function. This is fixed upstream in version 2.7.1.

In in the meantime, to have it behave (and work) as it did with version 2.6.6, change the following option:

Tools → Settings → General → Auto-Type → uncheck “Always ask before performing Auto-Type”

Version 2.7.1, which did not make it into this batch of Stable Updates, works correctly, even with the above option enabled.

Desktop Icons (DING) Gnome extention and File Previews stop working due to a crash in sushi.

This has been fixed upstream in sushi version 41.2. To restore functionality you can manually upgrade.

sudo pacman -U https://archive.archlinux.org/packages/s/sushi/sushi-41.2-1-x86_64.pkg.tar.zst

2022-03-14

Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
  • Check the mirror you use is up to date:
sudo pacman-mirrors -f 5 && sudo pacman -Syyu 
  • If you use qt5-styleplugins (AUR), rebuild or remove it:
pamac build qt5-styleplugins
DSL/PPPoE may require downgrading 2 packages

First please check if new bugfix version 1.36.2-1.0 of NetworkManager improves things.

If it does not, downgrade to 1.34.0 (and restart network manager after) :

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

Bug report: FS#73948 - networkmanager 1.36.0 breaks DSL connection

Older dicussion: my-internet-connection-is-no-longer-working

mangohud (AUR) prevents Wine/Proton applications from starting
  • Consider disabling the mangohud overlay until the bug is fixed upstream.
VPN via L2TP might not work anymore

See FS#74089 - networkmanager 1.36 breaks vpn with networkmanager-l2tp

You may need to downgrade to 1.34.0:

sudo pacman -U https://archive.archlinux.org/packages/l/libnm/libnm-1.34.0-1-x86_64.pkg.tar.zst https://archive.archlinux.org/packages/n/networkmanager/networkmanager-1.34.0-1-x86_64.pkg.tar.zst

2022-02-27

Microsoft Teams does not open.

See this thread.

8 Likes

TBD? Interesting…

I was feeling determined, and updated anyway - still alive n kicking too!

Cheers!

:smile:

6 Likes
❯ sudo modprobe r8168          
modprobe: ERROR: could not insert 'r8168': Exec format error

~  
❯ sudo modprobe r8169

~  
❯

It’s my experiments after rebooting without wired connection. r8169 is blacklisted.

Wow, boot and reboot times have been decreased dramatically on my system (with kernel 5.18.3-1), that is the first thing I noticed.

4 Likes

Another problem - akonadi doesn’t start:

❯ akonadictl start
org.kde.pim.akonadictl: Starting Akonadi Server...
org.kde.pim.akonadictl:    done.
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)                                                           
org.kde.pim.akonadiserver: Starting up the Akonadi Server...

~ 
❯ org.kde.pim.akonadiserver: database server stopped unexpectedly
org.kde.pim.akonadiserver: Database process exited unexpectedly during initial connection!
org.kde.pim.akonadiserver: executable: "/usr/bin/mysqld"
org.kde.pim.akonadiserver: arguments: ("--defaults-file=/home/user/.local/share/akonadi/mysql.conf", "--datadir=/home/user/.local/share/akonadi/db_data/", "--socket=/run/user/1000/akonadi/mysql.socket", "--pid-file=/run/user/1000/akonadi/mysql.pid")
org.kde.pim.akonadiserver: stdout: ""
org.kde.pim.akonadiserver: stderr: "2022-06-12 18:33:57 0 [Note] /usr/bin/mysqld (server 10.8.3-MariaDB) starting as process 7442 ...\n"
org.kde.pim.akonadiserver: exit code: 1
org.kde.pim.akonadiserver: process error: "Unknown error"
org.kde.pim.akonadiserver: Shutting down AkonadiServer...
org.kde.pim.akonadicontrol: Application '/usr/bin/akonadiserver' exited normally...
1 Like

Dragons are protectors and one of the Creators/Designers of Man Kind - Ayahuasca and Yopo

(KDE PIM akonadi) Maybe related - here’s how I debugged (and finally reset the databases) after the last update: [Stable Update] 2022-05-23 - Kernels, Toolchain, NVIDIA, Mesa, KDE, Qt, Maui, LibreOffice, Plasma, Firefox, Thunderbird - #45 by jonas.eberle

1 Like

Also:

❯ vim           
vim: error while loading shared libraries: libperl.so: cannot open shared object file: No such file or directory

Also NAS can not be mounted (still have not look closer to it).
Can anybody please explain what’s happening?

That Big Dragon
© @philm - 2022

2 Likes

For now everything runs fine after the upgrade, but there is one message that seems like it should not be there:

Note: locale.conf is not longer tracked by
package management. Restoring /etc/locale.conf ...

From the Wiki post above: :arrow_down:

1 Like

Have found decision working for me:

touch /home/user/.local/share/akonadi/db_data/ib_logfile0

and then start akonadi with akonadictl start (and then kmail).
Source: 454948 – Akonadi server will not start on fresh install; yields "unknown error"

5 Likes

4 posts were split to a new topic: Grub doesnt list my manual btrfs timeshift snapshots anymore

A post was split to a new topic: Failed to load kernel modules at start

All seems fine, except for what concern systemd 251; I encountered this issue:
`systemd-analyze blame` showing way more devices than before · Issue #23629 · systemd/systemd · GitHub which also introduced, for me, a slower boot time.

Related topic:

+1 with Kmail kaput…
I’ve tried solutions posted above, and also:
rm -r ~/.local/share/akonadi/
sudo aa-complain /usr/bin/akonadiserver
sudo aa-enforce /usr/bin/akonadiserver

No success. I’m thinking to switch to Thunderbird…

Everything seems fine, except memory usage at boot went up ~150mb. Is it by design? nvidia-470xx and latest kernel.

A post was split to a new topic: After updating kernel to 5.18.3, system fails to start