Failed to load kernel modules at start

Hi team,
After this update im unable to login to system.
System specs hp 15-dk2096tx, i7 11th gen, rtx 3050 gpu
My system got black screen , showing failed to load kernel modules at start after seeing logs.
Unfortunately i removed 5.17, after installing 5.18.
What to do next… Please help

Moderator edit: Removed useless attached photo

can you boot on USB iso manjaro
open a terminal and browser on this topic
and return

inxi -Fza 

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information. [HowTo] Provide System Information
  2. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.
1 Like

Hi team, I’m facing the same problem for a while now. I tried searching for it a bit, but couldn’t find any solution to the issue. Hence I reverted back to the Kernel 5.17 which is working for me.

As asked, here is the output of the command inxi --admin --verbosity=7 --filter --no-host --width in my terminal.

I figure it might also be beneficial to give you the entry in GRUB for 5.18 kernel.

set gfxpayload=keep
insmod gzio
insmod part_gpt
insmod btrfs
search --no-floppy --fs-uuid --set=root 32fe2019-db43-4af7-9a17-5fe8f3002e9c
linux	/@/boot/vmlinuz-5.18-x86_64 root=UUID=32fe2019-db43-4af7-9a17-5fe8f3002e9c rw rootflags=subvol=@  apparmor=1 security=apparmor udev.log_priority=3 i915.enable_guc=2 resume=UUID=9a029e11-a1f8-4a75-8068-4e2997f34e58 image_size=8000000000
initrd	/@/boot/intel-ucode.img /@/boot/initramfs-5.18-x86_64.img

In the same entry, if I edit and replace 5.18 with 5.17, it works properly. Also, I have tried purging the packages linux518, linux518-nvidia and linux518-headers and reinstalling them once again.

All I see is this screen if I use kernel 5.18.

Please do let me know if you need any more details. Until then, I’ll be using 5.17 kernel for work since it is working perfectly with all my hardware.

I found this issue via searching, and temporarily adding the ibt=off parameter to the kernel got the system booting up.

However, I don’t think this is a correct solution, so I’m still going back to 5.17 kernel.