[Stable Update] 2021-12-16 - Kernels, KDE Gear 21.12.0, Gnome Extensions, LibreOffice

One possibility is new config files and you need to merge in you changes, check for pacnew files. More info in the arch wiki

I use meld to check for changes that need to be merged:

$ pamac install meld
$ sudo DIFFPROG=meld pacdiff
1 Like

Thanks, I see no pacnew files related to this.

I am certain it is something in this update, because I have two machines with Manjaro installed and Vagrant VMs are broken on both of them now after this update. Totally at my wits end…

Something screwed up with virtualbox possibly. I’ve tried downgrading it but issue persists.

Update

I’ve installed EndeavourOS on another drive, installed virtualbox, vagrant, etc. And now my VMs are working again… so it looks like something specific in this upgrade on Manjaro. I’ve spent the whole day on this issue, and now looks like I will have to reinstall a different distro to fix it… ugh, not exactly what I wanted, but I have no choice as I use this for work.

I guess one last plea for help, anyone know whats up with vagrant/virtualbox on the latest Manjaro update?

Links (eg in Mails) do not open in firefox anymore. I have this problem since the the update from 10th december. After this update links (urls) opened wine, now they open “edit book”.
Anybody an idea?

Same Problem.
I did’t try so far. Is there an easy way to switch it back?

Also found this on the internet:
https://unix.stackexchange.com/questions/677878/supernumber-key-combos-remapping-in-gnome-40-switch-workspaces-instead-of-laun

1 Like

I’m having a strange issue since the latest update.

Tech details

OS: Manjaro Linux x86_64 
Host: 20T0001CRT ThinkPad T14s Gen 1 
Kernel: 5.13.19-2-MANJARO 
DE: Plasma 5.23.4 

Today I encountered issue with nginx not starting, due to “unknown host: domain.local”
domain.local is a fake host which I put to /etc/hosts along with domain2.local and domain3.local.

For some reason, ping domain.local also results in “unknown host” error, as if my /etc/hosts is completely ignored by system.

upd: I checked /etc/nsswitch.conf file and see the following line:
hosts: mymachines mdns4_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] files myhostname dns

Is it correct? My colleague has hosts: files mdns4_minimal [NOTFOUND=return] dns in Ubuntu and his /etc/hosts works fine

upd2: I guess there might be an issue with me naming my local domains with .local suffix

this :point_up:

You can change the order if you like. It’s your system.

Thank you for the reply. However I still don’t undertand the reason behind such change. Why would “files” be not the first entry? /etc/hosts is historically used to overwrite other data, so it should be first, right?

mymachines seems perfectly reasonable as first entry nowadays :man_shrugging:

I’ve had mdns4 lookups after files (or resolve in my case as it’s supposed to “support /etc/hosts internally but with caching”) since I set up my installation years ago

hosts: mymachines resolve [!UNAVAIL=return] files mdns4_minimal [NOTFOUND=return] myhostname dns
1 Like

Because I got lost in the KDE appearance settings (strange combinations of green and blue) I ran a virtual machine with the latest 21.2rc1 image and copied the settings from there. Maybe it can help others too:
global theme: breath; appl.style: breeze; plasma: breath dark; colors: breath light; windows decorations, icons, cursors, splash: breeze.

This should be addressed in 21.1.2-2 @ScottM. Please review and give feedback.

Manjaro stable branch now has alsa-ucm-conf v1.2.6.3-0 that has patched /usr/share/alsa/ucm2/sof-soundwire/soundwire.conf
Manjaro - Branch Compare - alsa-ucm-conf

fresh manjaro kde install has this issue where both pulseaudio and pipewire are running at the same time causing many problems. also sof-firmware package should be installed by default.

1 Like

very nice theme’s “easter egg”!

Along the same lines as “toggle your plasma theme” so the Dolphin icon follows the Accent Color… “toggle your App Launcher” (via Show Alternatives) so the Manjaro M follows the Accent Color!
Screenshot_20211220_095312

@philm Yes, 21.1.2-2 fixed both the resume-from-suspend and TTY switching problems for me. Thank you! :grinning:

2 Likes

OMG! This must be the issue I had with this update as well. I have several vagrant VMs I use for development work. All have dummy domains ending with .local and pointed to VM ips in /etc/hosts and after this update none of the domains would resolve.

I spent the entirety of yesterday trying to figure out why, and finally just moved to a different distro (Endeavour) where they work.

Using .local is probably a bad practice as it’s used by other things but, gee wiz, shouldn’t /etc/hosts be the final authority on where domains resolve?!

This is a known problem with all DEs that PipeWire can be enabled and started after an update

Users can either disable and mask Pipewire services to continue using PulseAudio
(KDE dependencies do not allow for uninstalling pipewire)
Or install manjaro-pipewire which includes pw-pulse to replace pulseaudio

also sof-firmware package should be installed by default

Sound Open Firmware drivers are only required for Intel systems that require Intel® HD Audio Intel® Smart Sound Technology on proprietary OS

2 Likes

I cannot update the system. It gets stuck at the level

   ~  sudo pacman -Syu                                                                                                         1 ✘  19m 50s  
[sudo] Mot de passe de doudou : 
erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
:: Synchronisation des bases de données de paquets…
 core                                                          168,9 KiB  23,4 KiB/s 00:07 [####################################################] 100%
 extra                                                        1918,1 KiB  16,8 KiB/s 01:54 [####################################################] 100%
 community                                                       6,8 MiB  28,9 KiB/s 04:00 [####################################################] 100%
 multilib                                                      176,5 KiB  55,6 KiB/s 00:03 [####################################################] 100%
erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
erreur : erreur GPGME : Pas de données
erreur : la synchronisation de toutes les bases de données a échoué (base de données non valide ou corrompue (signature PGP))
    ~ 
1 Like

Thank you very much! It worked !

Same problem for me, plus shortcuts like alt+f+4 stopped working for me.

However, when editing the shortcuts though the settings, I noticed that all of these were changed - including the super+ shortcuts!

I disabled/changed them, and it all works again, as previously!

Would’ve loved a heads up about such changes in the changelog though :pensive: