No sound after recent update

Hello there,

I recently updated some packages and it seems my audio doesn’t work. To be more accurate, I can play videos or songs. Also, the volume icon seems okay, but there is no sound at all. I tried everything. Unfortunately, none of the solutions work for my case. Here below are some infos:

[mehd1@mehd1 ~]$ inxi -Fazy
System:
  Kernel: 5.10.85-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
    root=UUID=b24ea8ca-da53-4899-8251-25343399a131 rw quiet
    resume=UUID=bc6c9e95-fad8-4d2b-b380-04442b93a087 udev.log_priority=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 20C600CSUE v: ThinkPad Edge E540
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 20C600CSUE serial: <superuser required> UEFI: LENOVO
    v: J9ET96WW (2.16 ) date: 10/14/2014
Battery:
  ID-1: BAT0 charge: 25.1 Wh (96.9%) condition: 25.9/38.9 Wh (66.5%)
    volts: 11.9 min: 10.8 model: SANYO LNV-45N1 type: Li-ion serial: <filter>
    status: Not charging
CPU:
  Info: model: Intel Core i5-4300M bits: 64 type: MT MCP arch: Haswell
    family: 6 model-id: 0x3C (60) stepping: 3 microcode: 0x28
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1068 high: 1440 min/max: 800/3300 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 798 2: 1440 3: 798
    4: 1237 bogomips: 20762
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
    IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: Lenovo
    driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0416 class-ID: 0300
  Device-2: NVIDIA GK208M [GeForce GT 740M] driver: N/A
    alternate: nouveau, nvidia_drm, nvidia bus-ID: 01:00.0 chip-ID: 10de:1292
    class-ID: 0302
  Display: x11 server: X.Org 1.21.1.2 compositor: kwin_x11 driver:
    loaded: intel display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0")
    s-diag: 414mm (16.3")
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 99 size: 350x190mm (13.8x7.5")
    diag: 398mm (15.7")
  Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
    vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 00:03.0
    chip-ID: 8086:0c0c class-ID: 0403
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20
    class-ID: 0403
  Sound Server-1: ALSA v: k5.10.85-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.42 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Lenovo driver: r8169 v: kernel port: 4000 bus-ID: 04:00.0
    chip-ID: 10ec:8168 class-ID: 0200
  IF: enp4s0 state: down mac: <filter>
  Device-2: Realtek RTL8723BE PCIe Wireless Network Adapter vendor: Lenovo
    driver: rtl8723be v: kernel port: 3000 bus-ID: 05:00.0 chip-ID: 10ec:b723
    class-ID: 0280
  IF: wlp5s0 state: up mac: <filter>
Drives:
  Local Storage: total: 465.76 GiB used: 132.78 GiB (28.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST9500420AS
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: HPM1 scheme: GPT
Partition:
  ID-1: / raw-size: 58.59 GiB size: 57.37 GiB (97.92%) used: 26.66 GiB (46.5%)
    fs: ext4 dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 148.93 GiB size: 145.53 GiB (97.72%)
    used: 106.11 GiB (72.9%) fs: ext4 dev: /dev/sda3 maj-min: 8:3
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 23.44 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda4 maj-min: 8:4
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 215 Uptime: 1h 13m wakeups: 1 Memory: 5.69 GiB
  used: 3.36 GiB (59.1%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1637 lib: 431 Shell: Bash
  v: 5.1.12 running-in: konsole inxi: 3.3.11

[mehd1@mehd1 ~]$ pacmd dump
### Configuration dump generated at Sun Dec 19 17:00:51 2021

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="pci-0000_00_03.0" card_name="alsa_card.pci-0000_00_03.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-alsa-card device_id="1" name="pci-0000_00_1b.0" card_name="alsa_card.pci-0000_00_1b.0" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-native-protocol-unix
load-module module-default-device-restore
load-module module-always-sink
load-module module-null-sink sink_name=auto_null sink_properties='device.description="Dummy Output"'
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-switch-on-port-available
load-module module-x11-publish display=:0 xauthority=/home/mehd1/.Xauthority
load-module module-x11-xsmp display=:0 xauthority=/home/mehd1/.Xauthority session_manager=local/mehd1:@/tmp/.ICE-unix/959,unix/mehd1:/tmp/.ICE-unix/959
load-module module-cli-protocol-unix

set-sink-volume auto_null 0x7c80
set-sink-mute auto_null no
suspend-sink auto_null yes

set-source-volume auto_null.monitor 0x10000
set-source-mute auto_null.monitor no
suspend-source auto_null.monitor yes

set-card-profile alsa_card.pci-0000_00_03.0 off
set-card-profile alsa_card.pci-0000_00_1b.0 output:analog-stereo

set-default-sink auto_null
set-default-source auto_null.monitor

### EOF

[mehd1@mehd1 ~]$  pacmd list-cards | grep 'active profile'
        active profile: <off>
        active profile: <output:analog-stereo>

Thanks in advance! :smiley:

you have both pulseaudio and pipewire running. choose one of them and install either manjaro-pulse or manjaro-pipewire and reboot. also make sure you have sof-firmware installed.

2 Likes

Thank you sooooo much ^_____^

How do you “choose one of them”?

I also have PA and PW listed as running in inxi, and only have manjaro-pulse installed

  Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
  Sound Server-2: sndio v: N/A running: no
  Sound Server-3: JACK v: 1.9.19 running: no
  Sound Server-4: PulseAudio v: 15.0 running: yes
  Sound Server-5: PipeWire v: 0.3.40 running: yes

Is the correct outcome to have only ALSA and PulseAudio listed as running?

Would I need to uninstall these packages?

1 Like

this is my inxi -

image

for pa install manjaro-pulse and for pw install manjaro-pipewire

both shouldn’t be running as that will surely cause some issue later.

just installed manjaro-pipewire and dont remove anything else unnecessarily and reboot

I think I figured out the answer to my question @ Sound Stopped Working

The reason they are both listed as “running” is that they both are running as “services” under systemctl

$ systemctl --user status pulseaudio
● pulseaudio.service - Sound Service
     Loaded: loaded (/usr/lib/systemd/user/pulseaudio.service; disabled; vendor preset: enabled)
     Active: active (running) since Mon 2021-12-20 09:48:08 CST; 38min ago
TriggeredBy: ● pulseaudio.socket
   Main PID: 1370 (pulseaudio)
      Tasks: 8 (limit: 38406)
     Memory: 12.5M
        CPU: 2.748s
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pulseaudio.service
             ├─1370 /usr/bin/pulseaudio --daemonize=no --log-target=journal
             └─2506 /usr/lib/pulse/gsettings-helper

Dec 20 09:48:07 AM4-5600X-Linux systemd[1127]: Starting Sound Service...
Dec 20 09:48:08 AM4-5600X-Linux pulseaudio[1370]: stat('/etc/pulse/default.pa.d'): No such file or directory
Dec 20 09:48:08 AM4-5600X-Linux systemd[1127]: Started Sound Service.

$ systemctl --user status pipewire
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: enabled)
     Active: active (running) since Mon 2021-12-20 09:48:07 CST; 39min ago
TriggeredBy: ● pipewire.socket
   Main PID: 1987 (pipewire)
      Tasks: 2 (limit: 38406)
     Memory: 1.9M
        CPU: 13ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─1987 /usr/bin/pipewire

Dec 20 09:48:07 AM4-5600X-Linux systemd[1127]: Started PipeWire Multimedia Service.

So what I need to do is stop/disable one of these services.

EDIT: Hmmm, may be not as it’s still running after a stop/disable…

$ systemctl --user stop pipewire
Warning: Stopping pipewire.service, but it can still be activated by:
  pipewire.socket

Okay… after taking a peek at what uninstalling pipewire would mean, I learned it has way too many things that depend on it that I’d consider “core” and system breaking if I removed them… basically, pipewire is a required dependency.

Going through the motions of uninstalling pulseaudio yields a much cleaner list, only a couple “optional dependencies”, and nothing core or system breaking.

It seems to me that when I installed Manjaro KDE, pipewire was a necessary dependency, but pulseaudio was the focus as it has many related packages installed (whereas pipewire does not)… I likely have always had these two services running.

So the only real service option to shut down and uninstall is pulseaudio… switch over to manjaro-pipewire, and take a look at and install the pipewire optional dependencies.

Actually, I think it’d be simpler to just focus on the meta-packages… uninstalling manjaro-pulse and installing manjaro-pipewire. Which was probably always the recommendation… but I just needed to wrap my head around the 5 W’s :slight_smile:

1 Like

Both of those are probably running for everyone that haven’t tinkered with sound, both are running on my system and I just check with the most recent Manjaro iso release and both of those are running - see screenshot:

i have already filled a issue here

It does seem strange to have both activated, but so far I haven’t had any issues. I’ve learned over the years not to tinker too much with the core parts of my installation unless absolutely necessary, but I will keep in mind your suggestion on deactivating one of them should I encounter problems.

1 Like

Thank you for re-mentioning sof-firmware… I thought it was odd one day that it appeared as an orphan to delete. Obviously initially installed as an optional dependency whose parent was removed… but now that I’ve explicitly re-installed it that should not repeat.

Why would you want to disable pipewire? It’s used by KWin to provide screen sharing on Wayland and some other features. pipewire.service doesn’t conflict with pulseaudio.service.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.