[Stable Update] 2021-04-28 - Kernels, Wine, Ruby, JDK, KDE-Dev, Mesa 21.0.3, KDE Apps 21.04, Python, Haskell, Mate 1.24.2, Virtualbox, Thunderbird

Having problems with wine after the last 2 updates.

I suspect Akonadi not working has to do with KCoreAddons (and several other KDE packages) being installed from git (from the community repo) instead of the actual release.

How do I make sure everything goes back to an actual release in KDE, instead of git packages?

Firefox would not start at all ( I could not go in and disable hw acceleration because it was just not starting ) I downgraded back to Firefox 87 and started with backwards compatibility to recover my profile.

This seems to be broken for a lot of nvidia and intel users. Kind of a surprise this was allowed to get into stable.

I have a similar problem here with plymouth, sddm + kde. Boot gets stuck just before showing the loginscreen, no reponse to keyboard, no switch to tty, no ctrl-alt-del. Only emergency power off helps.

System reaches login when I press ESC early enough to exit plymouth before login.

Install plymouth-git from AUR,it fixes the problem

3 posts were split to a new topic: Ungoogled-chromium: error while loading shared libraries

A post was merged into an existing topic: Ungoogled-chromium: error while loading shared libraries

Yeah, I’ve been using git version since a year or two as well, when it turned out that repo version is completely broken.


Yup, manually identifying all *-git KDE packages and replacing them with normal proper release seems to have solved my issue.

Can you please post the link of the issue at the VBox Forum as well?

Error updating packages, rubY files exist

Dont know how to scroll up in tty, im using tty because x server wont start so i tried updating

This error is general … more information about the problem is on next lines.

Often it can be mix of Virtual Box and Extension Pack versions … but it’s just a blind hint :eyeglasses:

It might be a slippery slope. Don’t know if you use KDE or gnome, but when I started getting error messages like that, removing db.lck, running pacman-mirrors or turning to pamac for updates inside GUI, things went horribly wrong along the way and my system eventually crushed. See the solution post here for the close-to-fool-proof way to go about updating. Pacman and TTY are your friends!


got issues, mainly with firefox and akonadi. Both crash on launch. Call from a terminal for firefox log a bus error, with core dumped. Coredumpctl show same errors for Firefox, Akonadi, Whatsapp-linux, and Midori, with a signal, and always the same stacktrace (for lines 0 to 5) from coredumpctl info :

Stack trace of thread 8194:
#0 0x00007f4aea656153 memset (ld-linux-x86-64.so.2 + 0x24153)
#1 0x00007f4aea63a40a _dl_map_object_from_fd (ld-linux-x86-64.so.2 + 0x840a)
#2 0x00007f4aea63b82d _dl_map_object (ld-linux-x86-64.so.2 + 0x982d)
#3 0x00007f4aea645f6c dl_open_worker (ld-linux-x86-64.so.2 + 0x13f6c)
#4 0x00007f4aea20db38 _dl_catch_exception (libc.so.6 + 0x139b38)
#5 0x00007f4aea645ade _dl_open (ld-linux-x86-64.so.2 + 0x13ade)
#6 0x00007f4aea5df34c n/a (libdl.so.2 + 0x234c)
lines 1-26

It’s far away from my competence to debug this kind of errors…

I have the same issue after EVERY major Manjaro update. (never happens during normal reboot)

It tries to mount and unmount disks in circles. The system never reboots after update – I am forced to turn it off physically.

LOG is here.

system info:
RAZER Blade 15 (2018)
dual boot with Win 10
GNOME 40.0.0

It worked for me with a very similar problem a couple weeks ago.

1 Like

Thank you for the warning, I always used pacman and tty, but if it does not work, there is not much else I could do. Unfortunately, I did not check if db.lck was there before using pamac, but I think it would have blocked pamac as well, so the problem lay somewhere else.

And if pamac is so bad, I don’t understand why it is still bundled with Manjaro, also since it lost half of its AUR functionality since version 10.

I just hope that the next Manjaro upgrade will fix the audio/video issues.

1 Like

Pamac is not that bad because it was able to deal with the remain lock after your reboot and perform the upgrade. A thing that pacman was not able to do.

1 Like

I had a very very small issue. Same as last time, after pamac download all packages it freezes there. Then I hit cancel, close pamac, re do upgrade and everything went smooth (of course the packages were not downloaded again).

Out of curiosity, how long did you wait for pamac, before deciding it was frozen?

I ask because I’ve made the same assumption in the past, when it sometimes just takes a minute or two after downloading all packages to continue with upgrades – I think that it’s decompressing the packages when this happens (a visual indication of this would be helpful, but it’s a minor nitpick).

Still, glad you were able to successfully update. :slight_smile:

@Anthony I’ve had much more success with pamac (in run-level 3) than pacman, personally, or at least I’ve borked my system a lot less often. LoL