[Stable Update] 2021-04-28 - Kernels, Wine, Ruby, JDK, KDE-Dev, Mesa 21.0.3, KDE Apps 21.04, Python, Haskell, Mate 1.24.2, Virtualbox, Thunderbird

Since the Update, Civ: Beyond Earth: Rising Tide no longer plays due to the dGPU losing the Signal during Gameplay.

I had to settle for Playing the Game on Win10.

Screen shows weird after restart.
It shows ok when I low the resolution and then set it back to the same resolution.
It’s XFCE.
Second screen shows fine anyway.

    ○ → uname -r
    ○ → sudo !!
    sudo lshw 
        description: Laptop
        product: XPS 13 9343 (0665)
        vendor: Dell Inc.
        width: 64 bits
              description: Host bridge
              product: Broadwell-U Host Bridge -OPI
              vendor: Intel Corporation
              physical id: 100
              bus info: pci@0000:00:00.0
              version: 09
              width: 32 bits
              clock: 33MHz
              configuration: driver=bdw_uncore
              resources: irq:0
                 description: VGA compatible controller
                 product: HD Graphics 5500
                 vendor: Intel Corporation
                 physical id: 2
                 bus info: pci@0000:00:02.0
                 version: 09
                 width: 64 bits
                 clock: 33MHz
                 capabilities: msi pm vga_controller bus_master cap_list rom
                 configuration: driver=i915 latency=0
                 resources: irq:47 memory:f6000000-f6ffffff memory:e0000000-efffffff ioport:f000(size=64) memory:c0000-dffff

I apply a xrandr command when system boots that now is messing refresh rate or something (it went well before this update so much time).

xrandr --output eDP1 --primary --mode 1920x1080 --pos 0x900 --rotate normal --output DP1 --mode 1440x900_60.00 --pos 0x0 --rotate normal --output HDMI1 --off --output VIRTUAL1 --off

That looks like it may be a refresh rate issue. I’m not that familiar with the KDE interface but I would go into your display settings and try changing the refresh rate (even if it appears to be the correct refresh rate try a lower rate and then try changing it back.

It’s XFCE, I’ll update my first comment. thanks.

Do you have plymouth? I have a similar issue but with KDE and plymouth,SDDM doesn’t show when plymouth is activated,this update looks like it meeses up something but in the journalctl doesn’t show anything wrong,when i disabled plymouth SDDM works again,try disabling plymouth to see if GDM start on its own again.


Upgrading brltty (6.3-1 -> 6.3-2)...
Please add your user to the brlapi group.

Should I do this and if so, why?

OK this is officially weird.
No success booting from USB with either KDE or XFCE images – gets to the boot menu but then black screen on booting, but can boot the same images from DVD.

Hardware: CPU: Intel i3 CPU 540 @ 3.07GHz (4 cores)
Graphics: Intel core processor integrated.

Reinstall from DVD??? or any better ideas?

I have FF Dev Ed 89.0b4 (64-bit) and KDE and found no problem.

I have problem with the exact same combination (KDE & Firefox Dev Edition)

The problem of color theming in QT Applications has not been solved! :confused:

QGnomePlatform is working as intended. I have no issue with it using Adwaita or themes based on it like Orchis. The Fedora devs have added some rudimentary Kvantum support, but it’s not a priority for them.

Kernel 5.12.0 just straight up won’t boot on my machine. I make it to the ‘No IRQ for Vector…’ messages created by the kernel, and then blackscreen. No ability to view startup messages, no ctrl-alt-f switching, no visible kernel panic, no GUI, nada. “It ain’t there, kid!”

Happily, 5.11.16 still runs like a champ.

– edit –

Additionally, I can’t find anything in the system logs pertaining to a failed boot of any kind.

Manjaro Linux x86_64
Host: GA-970A-UD3
Kernel: 5.11.16-2-MANJARO
Shell: zsh 5.8
CPU: AMD FX-6300 (6) @ 3.500GHz
GPU: NVIDIA GeForce GTX 1650
Memory: 3580MiB / 16056MiB

Hey there! Since ~3 weeks I’ve been experiencing similar issues, so I opened up a post at this forum. It turns out many more people has been running into the same, and we’ve been sharing our experiences since then. We’ve not found an effective solution yet, but hope you can find some useful information over there! Feel free to provide any ideas or issues you may face :smiley: https://forum.manjaro.org/t/system-frequently-crashing-after-gpu-drivers-update

1 Like

Everything worked perfectly except I have a strong feeling that the colour calibration on my Thinkpad internal display has changed - colours are desaturated, there’s a blue tint, etc. I don’t have a hardware device for measuring colour calibration so I can’t be certain but after rebooting it immediately looked noticeably different. Anyone experience anything similar with this update? The graphics setup is ThinkPad X1 Carbon 4th, Intel Skylake GT2 [HD Graphics 520], i915, modesetting.

I switched to Windows 10 on the same laptop, no issue, the colours looked saturated and full. Copied the ICM file for the colour profile Windows was using onto my Manjaro partition and then booted into Linux and activated that colour profile: no change. Then I realised that it was only in Chromium that I was noticing the weird colours, not so much the rest of the desktop environment. I went into Chromium flags and set the " Force color profile - Forces Chrome to use a specific color profile instead of the color of the window’s current monitor, as specified by the operating system" flag to the same color profile I had set in Cinnamon DE-wide color profile settings and relaunched Chromium. Now the colours look normal. I guess it must be a Chromium bug with the new version?

Big mess here.
I dont use grub anymore. Only EFI with bootctl.
/home is on btrfs and /efi obvioulsy on fat32.
5.12 just hangs (rc5 was ok)
5.10 stops as it can’t mount /home.
mount -a gives : vfat and btrfs = unknown filesystems.
Where should I begin???
Some help would be great…

Called systemd-boot :wink:

I had not used CMake-gui for a month but today when I started it:

❯ cmake-gui      
cmake-gui: error while loading shared libraries: libQt6Widgets.so.6: cannot open shared object file: No such file or directory

Edit 1: qt6-base is optional dependency of cmake and it resolves the problem.

sudo pacman -S qt6-base

Why? Is there a specific fix?

Another issue is that Kate has disappeared as a select able menu item in the Gnome panel. I can still run it from the terminal. Reinstalling it from pacman -S did not seem to affect it.

Kate does show in the menu tool.Screenshot from 2021-04-30 00-24-24

Kwrite still shows up in the Gnome menu like any other app.

Not sure what to do at this point.

Edit: I toggled Kate off and on in the menu tool and it showed normally for a moment, was able to open it, but the icon no longer shows after a few seconds in the GNOME menu.

Edit2: I Installed the same iso to two different machines. One of which I did not update. Can confirm that Kate shows normally on the one that did not update.

Sure… But Bootctl is mandatory to automate updates.
I’m not before my gear right now but would appreciate to have some directions with that mess.
Obviously, the kernel modules are not loaded (else mount would not fail).
Any idea on that regard?